PostgreSQL, often simply Postgres, is an object-relational database management system (ORDBMS) available for many platforms including Linux, FreeBSD, Solaris, Microsoft Windows and Mac OS X.

learn more… | top users | synonyms

4
votes
2answers
896 views

How to install PostgreSQL 9.3 in FreeBSD jail?

I configured virtual NICS using pf, and a jail for FreeBSD using qjail create pgsql-jail 192.168.0.3. When I tried to install PostgreSQL 9.3 using port collection, it shows strange message at first. ...
0
votes
2answers
225 views

CentOS 5: My Postgresql server version is different with my psql client. What should I do?

I installed PostgreSQL 9.1 in CentOS 5 x86_64 VPS, with these following commands: I specified which Postgresql version I'd like to install, so I choose 9.1 because I want to equate between ...
1
vote
1answer
52 views

Kali Linux Postgresql Error

I recently installed kali Linux and keep getting an error code starting metasploit this is the code [...] Starting PostgreSQL 9.1 database server: main [...] Error: could not exec ...
1
vote
1answer
84 views

Change default python distribution for postgres from the system's python (to Enthought Canopy)

On an RHEL6 system, I'd like my postGIS implementation (ie my postgres/postgresql databases) to use Enthought's Canopy distribution of python, rather than the built-in GNU's distribution. (This is ...
1
vote
0answers
27 views

ERROR: Failed to build gem native extension on Arch (postgresql)

I can't install gem pg on Arch due to the error: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /home/alex/.rvm/rubies/ruby-2.1.1/bin/ruby extconf.rb checking for ...
1
vote
0answers
37 views

Postgresql 9.1 - Kali Linux

I start to read this book : http://www.amazon.fr/Metasploit-The-Penetration-Testers-Guide/dp/159327288X And i have some trouble in using postgresql 9.1 (in Kali Linux). When i start msfconsole, i ...
1
vote
0answers
33 views

PostgreSQL installation error in debian

I'm trying to install PgSql in the system with following specs: Distributor ID: Debian Description: Debian GNU/Linux 7.1 Release: 7.1 x86_64 But I am getting an error like this The ...
1
vote
0answers
141 views

Passing escape sequences to shells within ansi-term in Emacs

In a regular terminal (e.g. iTerm2 on OS X) I can connect to a database, e.g. > psql .... and then, as I type my command in psql, e.g. $ select foo from bar I can move around (as I type psql ...
1
vote
0answers
89 views

Postfix, postges courier-imap / relay reject error on gentoo

I followed a guide to put together a server https://wiki.gentoo.org/wiki/Complete_Virtual_Mail_Server it went smooth with no real headaches. First domain works like a champ but adding a second domain, ...
1
vote
0answers
118 views

Firewall config prevents hibernate connecting to postgres in CentOS6.3

I have an operating environment in CentOS 6.3 that has tomcat7 and postgres9.2 installed. There is just one web application deployed in tomcat that tries to establish a connection from localhost to ...
1
vote
0answers
656 views

“No PostgreSQL user name specified” - possible concurrency issues?

For my dissertation I'm running the same cronjob on around 300 machines, which is: 10,25,40,55 * * * * /path/to/db_script.sh 1>/dev/null This script gets some values from the system (whether ...
0
votes
0answers
94 views

cannot start PostgreSQL on OpenBSD 5.4 through rc.d

I've installed the postgresql-server package on OpenBSD 5.4 amd64, and I try starting it through its rc.d script, however, it doesn't look like it's running after that. opti# /etc/rc.d/postgresql ...
0
votes
0answers
206 views

Postgresql 9.3 with posgis extenstions not working after restart

I'm running Mint 16. In pgAdmin it gives me this output. An error has occurred: ERROR: could not load library "/usr/lib/postgresql/9.3/lib/postgis-2.1.so": libjson.so.0: cannot open shared ...