1
vote
0answers
287 views

ERROR: Failed to build gem native extension on Arch (postgresql)

I can't install gem pg on Arch due to the error: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /home/alex/.rvm/rubies/ruby-2.1.1/bin/ruby extconf.rb checking for ...
2
votes
1answer
391 views

/etc/rc.d/postgres start vs rc.d postgres start

What's the difference between those two commands? /etc/rc.d/postgres start and rc.d postgres start Aren't those interchangeable? I tried starting PostgreSQL using the latter, but it only works ...
4
votes
1answer
515 views

How do I pg_upgrade my database on Arch Linux?

I was running postgres 8.4 on arch but now have 9 installed I want to use pg_upgrade to upgrade but I don't know what all the options I have to use are, and all the directories that I have to point it ...