pip is a Python package installer

learn more… | top users | synonyms

1
vote
1answer
16 views

'altinstall' python-devel; can't install psycopg2 on centos

I installed python2.7 on my centos 2.6.32-431.17.1.el6.x86_64 following these directions: http://toomuchdata.com/2014/02/16/how-to-install-python-on-centos/ #after the yum stuff... # Python ...
4
votes
3answers
3k views

Install PIL/Pillow via pip in Debian testing (Jessie)

On Debian testing (Jessie), when I try to install PIL or Pillow (python imaging libs) in a virtualenv via pip I get the following error: running egg_info writing Pillow.egg-info/PKG-INFO writing ...
2
votes
1answer
746 views

Pip install - CPU you selected does not support x86-64 instruction set

I'm trying to use pip install mysql-python inside a virtualenv container and am getting the error building '_mysql' extension gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall ...
4
votes
3answers
1k views

Recommended way of installing python packages on Arch

What's the recommended way of installing python packages on Arch? Searching for them on the AUR and installing them from there (or create a PKGBUILD file to make a package yourself) or using pip? I ...
0
votes
1answer
114 views

Django not installing with pip because of mismatched hash

I have a virtual machine set up with a directory created with virtualenv (env2). I am inside this directory and have it activated and want to instal django 1.4. This is my command: $ pip install ...
0
votes
1answer
195 views

Can't use peewee on Mac OS X Mountain Lion

I am getting an error when I run Python programs that imports peewee: ImportError: No module named peewee The same program works fine under Ubuntu 12.04. I used pip to install peewee, and it ...
1
vote
4answers
1k views

pysqlite install error on FreeBSD in virtualenv

I am trying to install pysqlite using pip under a virtualenv in FreeBSD 7.3, with Python version 2.6.2. I didn't have any issues for installing other packages like Django, PIL etc. All of them I ...
4
votes
4answers
4k views

How can I upgrade pip on Ubuntu 10.04?

On Ubuntu 10.04 I've used apt-get install pip to install pip after which I installed django. Then I tried to uninstall django with pip via pip uninstall django which gives me: pip: error: No command ...