PHP is a widely-used, general-purpose scripting language that is especially suited for web development.

learn more… | top users | synonyms

2
votes
2answers
3k views

Git pull error libcurl.so.3 not found

I have a php script to git pull from my github repository set up in my webservice hook urls like so: <?php echo shell_exec('~/git/usr/bin/git pull 2>&1'); ?> When I open this script ...
1
vote
2answers
42 views

How do fast Convert a .xls (MS Excel) file to .csv

How will do fast covert excel to csv. I had tried with php, perl, JavaScript. but it will take too much time. i.e for 5MB file it will take 3-5 mints
1
vote
1answer
993 views

PECL memcached installation gets error

I installed Zend Server 6 (debian). Also installed several packages: apt-get install gcc apt-get install g++ apt-get install libncurses5-dev apt-get install zlib1g apt-get install zlib1g-dev ...
3
votes
1answer
868 views

suexec with chrooted environment

I'm trying to get a chrooted Apache environment working running mod_fcgid with suexec. Looking at suexec log inside jail, the wrapper scripts are being executed with no problems, however, when I look ...
0
votes
0answers
10 views

Doctrine OCI8 charset behavior between php-cli and php-fpm

My Oracle database is in ISO8859-1 (not by choice). I'm struggling with segfault from php-fpm for a couple of days now. To dig out the source of it I've set two parallel environnements with the ...
1
vote
0answers
41 views

Opcache and shared memory issue

I installed zend_opcache on my server box , but I can not increase opcache.memory_consumption over 1600 . (example : 2048) . after increase following error occur in server : Fatal Error Fatal Error ...
0
votes
0answers
26 views

Why does apt-get upgrade not install the latest PHP version?

I usualy do apt-get update apt-get upgrade in order to keep my Debian 8.x server up to date. I also tried apt-get dist-upgrade, however, my PHP version is still the same one that I installed months ...
0
votes
0answers
7 views

PHP-FPM / Nginx, hundred requests / second in a single file

My FPM Config (PHP 5.6.x with opcache) pid = /var/run/php-fpm/php-fpm.pid rlimit_files = 10000 rlimit_core = 0 [www] listen = 127.0.0.1:9000 listen.allowed_clients = 127.0.0.1 user = nginx group = ...
1
vote
1answer
892 views

phpmyadmin doesn't work after installing php5-mysqlnd

I am currently running into some problems with phpMyAdmin. I set everything up correctly and made sure everything worked. Then later after some developing on some pages I noticed I couldn't execute ...
0
votes
0answers
4 views

“[unixODBC][Driver Manager]Data source name not found, and no default driver specified” When using Teradata ODBC Drivers

I am running a PHP script on a RedHat server using Teradatas ODBC drivers. <?php $conn = odbc_connect("Teradata", "username", "password"); $result = odbc_exec($conn, 'SELECT count(*) FROM ...
0
votes
1answer
587 views

Multiple PHP Versions / cPanel with mod_fcgid

I'm trying to get multiple PHP versions working on a cPanel server which was compiled with mod_fcgid and PHP 5.3. Below is the PHP config generated by cPanel. AddHandler fcgid-script .php5 .php4 ...
5
votes
2answers
29k views

PHP 5.5.13 on CentOS 6.5 with yum

I've got problems with installing PHP 5.5.13 (last stable build) on a CentOS 6.5 (64 bit) machine, through yum. Can somebody guide me through this a little bit? It is not a part of the CentOS, EPEL ...
2
votes
1answer
2k views

Howto fix my PHP install on FreeBSD using pkg

I've been messing around with pkg install, installing / removing both php5-5.4.29 and php55-5.5.13. But when I run php from the command line, it will give me an error like this: PHP Warning: PHP ...
0
votes
1answer
3k views

How to install Owncloud on CentOS 6.5

I wanted to install Owncloud on my VPS running CentOS 6.5. I followed the instructions on the official owncloud website but when I run the command yum install owncloud it says Error: Package: ...
0
votes
0answers
4 views

Separate web directories of nginx+php-fpm

On my server I run mediawiki, owncloud, roundcube on same hardware, with same nginx and php-fpm process. But I worry about security. Because if hacker get access to filesystem of one of this web ...
0
votes
0answers
11 views

php update on ubuntu 11

I need to install Moodle2.9 but it requires at least php 5.4.4. The server runs ubuntu 11.04 and webmin: ~# cat /etc/issue Ubuntu 11.04 \n \l ~# php5 -v PHP 5.3.6-13ubuntu3.10 with Suhosin-Patch ...
0
votes
1answer
3k views

mcrypt, EPEL and CentOS 6.4

I am having issues installing php-mcrypt. I am not an administrator of any level. I have performed the following. Installed EPEL Installed REMI Configured EPEL Updated YUM Cleaned YUM Installed ...
1
vote
2answers
1k views

Running system bash command in PHP script - syntax error: unexpected T_LNUMBER

If anyone can shed some light on my issue that'd be great. Please don't down-vote me; I'm new to the language and the OS itself and I'm trying my best to research before asking questions, so any ...
9
votes
8answers
17k views

How do I install a PHP CLI with a usable interactive prompt on Debian Wheezy?

When I install php5-cli on Debian Wheezy (currently testing), the interactive prompt is very unusable due to missing readline support (bug 341868). What's the easiest way to install a version linked ...
0
votes
1answer
1k views

Slow DNS resolve from curl/lynx etc

I have a strange issue with DNS resolving: Root of the problem is that I get curl errors: "Error executing HTTP request: name lookup timed out". Tried to ping some sites, all resolved fine (and fast). ...
0
votes
0answers
13 views

NGINX Stopped Serving PHP After Upgrade

Preface: I performed a dist-upgrade of my Debian LEMP server from 7.x (jessie) to stable and PHP pages stopped displaying. I eventually figured it out but am not really sure -WHY- my fixed worked. I ...
2
votes
4answers
14k views

Executing a shell command from PHP with shell_exec

Included in my thesis is to create an administration interface, in which an administrator can approve users whom have asked for access to use OpenNebula. Upon approval the users should be added to ...
0
votes
3answers
743 views

Unresolved dependencies though the packages are installed (Debian 6 Sqeeze)

I'm working with a VirtualBox 4.2.14 VM and Debian 6 Sqeeze as guest system and want to install some PHP modules: root@devmv:~# apt-get install php5-fpm Reading package lists... Done Building ...
1
vote
0answers
11 views

Nginx php doesn't execute

I'm using nginx on centos 7 with php 5.4.16. I have tried this to adding nginx.conf: location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass ...
0
votes
0answers
25 views

Is my Nginx,php-fpm and mysql config good enough?

My Setup: Intel(R) Xeon(R) CPU E5-2680 v3 @ 2.50GH 30 GB Ram 1 Gbps Premimum/Dedicated Line Softwares3 MariaDB 10.0.20 NGinx 1.8.0 PHP with FPM 5.6.8 Our servers gets a LOT of requests (more ...
0
votes
1answer
304 views

WordPress on LinuxMint: Can't create directory (or write file)

I run Linux Mint, with Apache2, PHP and MySQL. I've activated modules for Apache so that users' public_html can be used and that PHP-scripts can be run from them. I installed WordPress in my ...
0
votes
0answers
18 views

How should I upgrade php5.3.20 to PHP 5.4 or higher than in Centos 5.3?

I build a webs application by using Codeigniter3 which required PHP5.4 o higher than this version and hosted in Centos Linux 5.3. So how should I upgrade PHP5.3 to higher version? However what is PHP ...
3
votes
1answer
2k views

Securest way to authenticate users against /etc/shadow using PHP?

This question became important to me, since I'm setting up a Horde environment and want to use the system accounts. Doing some search I found mainly 4 ways of doing that, which all seem to have some ...
0
votes
0answers
13 views

How to set user creation limit on vtiger CRM?

I have installed vtiger latest version. In the admin panel how to set the user creation limit? I need to set maximum users = 10.
0
votes
1answer
48 views

ispconfig PHP not parsing on apache2 virtual host

I have trouble installing ispconfig 3 on my (L)Ubuntu 15.04. I can fully install ispconfig but I can't reach the website when viewing the virtual host of apache2. I can open ispconfig from ...
0
votes
1answer
22 views

Installing a different php version for a subdomain

I have a cPanel dedicated server installed with PHP 5.2.17. I need to use php 5.3 version for my subdomain and the directory needed php.5.3 is /home/website30/public_html/blog/. Can anyone provide ...
-2
votes
1answer
45 views

Errors trying to execute a Metasploit script

I'm trying to run this exploit in Metasploit on Kali Linux. I have the file in the exploit folder, I just need to execute the script, but I'm getting some errors. This is the description from the ...
0
votes
1answer
188 views

PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/php_mysql.so'

I am running PHP 5.6 on Linux. When I try to load a PHP page, I'm getting the following PHP error. PHP Startup: Unable to load dynamic library /usr/lib64/php/modules/php_mysql.so' When I look ...
0
votes
2answers
1k views

Cron job to check if PHP script is running

I am having trouble regarding Cron jobs, I've basically got two PHP scripts that I want to keep running continuously on my server. Currently I am using an infinte loop to keep them going but they seem ...
0
votes
0answers
25 views

enforcing php version based on git branch

Is there a way similar to .rvmrc to automatically set the php version used while developing in a branch? I think phpbrew will do what we want, however we are uncertain how to enforce a specified ...
0
votes
1answer
320 views

PHP 5.4 ON CENTOS 7 , NGINX , page not found error

I am trying to install PHP 5.4 on CentOS 7 currently , my conf files look like the following : /etc/nginx/conf.d server { listen 80; server_name 178.62.255.79; root ...
1
vote
1answer
138 views

PHP mail (using Postfix) send out to Gmail marked as SPAM

I'm totally new to "Email Systems" and it's concepts. I just use a simple email sending codes via PHP, like: mail("recipient@gmail.com","my header","my body"); I understand this is going through ...
2
votes
0answers
135 views

install php7 alongside php5 on ubuntu

I have installed php 5 as my main version on ubuntu 15.04 which i use to develop my current projects. I want to install php 7 alongside php 5 is there a way to install both??
0
votes
1answer
35 views

Enable centos server to make FTP connection to other windows based server via php

When i am running this same code from my local wamp.Works fine and prints the result. //connection to a ftp server across proxy putenv('TMPDIR=/tmp/'); $ftp_server = "SERVER IP"; $ftp_user_name = ...
1
vote
0answers
34 views

php5-embed does not load extensions

While setting up php on my Ubuntu server (using php5-embed under uwsgi/nginx), I noticed curl.so was not being loaded. The file /etc/php5/embed/conf.d/20-curl.ini exists and contains ...
1
vote
2answers
42 views

how can I configure Apache so that PHP scripts are run with permissions of the owner of the script?

I have an Apache webserver. I have some PHP scripts on it. Scripts are run as the user www-data - it is as the user that runs Apache. I want to configure Apache so that PHP scripts are run with ...
0
votes
1answer
54 views

find returns 'No such file or directory'

Continuously getting so many warnings yet my command is working fine. find: `api/PlayersImpl0.smali': No such file or directory find: `api/PlayersImpl1.smali': No such file or directory find: ...
1
vote
0answers
37 views

nohup not working when called from root folder

When i execute nohup command from the same folder it's working fine (server.php is used to listen to a port 7070) root@servername:/var/www/html/admin# nohup php server.php & [4] 2803 ...
0
votes
2answers
99 views

how to Check a php script is running if not run

i am running a php file using nohup php server.php & this listen for a particular port and do action according to the input. The problem is sometime the script stops and I can't use cron job ...
0
votes
1answer
48 views

How can I configure my server to avoid information leakage from the SERVER header of its HTTP response

I have a centos 7 server with apache v2.4.6 php 5.4.16 and OpenSSL 1.0.1e-fips installed. I was just doing a scan to it to see how secure my server is. I found out that my server is giving out ...
0
votes
0answers
98 views

PHP 5.6.10 Bad Installation on CentOS 7 using Plesk 12

I upgraded the PHP version from 5.4 to 5.6.10 with remi and while I am trying to access to a file.php I can see the full code in "Source code". I was reading about that and it seems that the ...
2
votes
3answers
87 views

Run a task in background and know the time of its termination

I need to run a unix shell script (my_script) in background and monitor it from web interface. I start the actual script from php like so: $command = 'my_script'; $pid= exec("nohup {$command} > ...
0
votes
1answer
82 views

php drop down menu to execute script with argument

I have shell script which I run like this /var/www/test.sh 2015 or /var/www/test.sh 2014 When this script runs, it actually takes data from freeradius and generates gnuplot base graph for the ...
0
votes
1answer
176 views

Chromebook crouton LAMP

I'm trying to install a LAMP stack on Ubuntu through crouton on a Chromebook (Acer c720p). I was able to install the following packages apache2 mysql-client mysql-server php5 libapache2-mod-php5 ...
2
votes
2answers
2k views

Using sudoers to allow php to run command

I am trying to get my php page to run this command: shell_exec("sudo /home/xbian/433Utils/RPi_utils/codesend {$num}"); So I added this entry to my sudoers file with visudo: www-data ALL=NOPASSWD: ...