A Linux package manager, originally developed for the Arch Linux distribution.

learn more… | top users | synonyms

0
votes
0answers
4 views

Can we add Manjaro repository to Arch-Linux?

It's just as the title says.Can we do it? or is it different from how arch-repos work? If so, how can we do it? -Thanks in advance!
4
votes
2answers
1k views

pacman-key --init takes too long and does not exit

First, I am new to Arch Linux. I have installed Arch Linux on my system and now when I try to install something using pacman, it gives me an error that the key 'xxxxxxx' was not found. I Googled and ...
-3
votes
0answers
22 views

“Oh no! Something has gone wrong” shows up - archlinux

I was installing some softwares like kivy and pip and everything seemed to work fine but I remember that some libs in cython or python had conflicts with other libs or something like that so I agreed ...
5
votes
3answers
7k views

Cannot Compile Apache: “Error, SSL/TLS libraries were missing or unusable”

Arch Linux 2011.08.19 (Linux 3.4.2 i686) Apache 2.2.22 → 2.2.22 (recompile & reinstall) OpenSSL 1.0.1.c-1 These details are likely irrelevant, but: I’m using yaourt with customizepkg to build ...
1
vote
0answers
14 views

Arch: Cannot open kernel arbiter, no multicard support

I'm currently using Arch Linux on a Chrombook Flip C100P in conjunction with the xf86-video-armsoc driver. When printing the /dev/dri folder on my device as root, it detects the following: card0 ...
0
votes
2answers
8k views

Installing sublime-text 2 with pacman

I want to install sublime-text 2 in Arch Linux with pacman package manager; how i can do this work?
0
votes
1answer
35 views

How can I clean pacman's database of missing files?

I was experimenting with some new desktop managers and I ended up screwing up my machine. At this point, I'd like to get rid of lightdm and start over, but I can't seem to remove it. pacman -Ssq ...
0
votes
0answers
15 views

How can I forcefully replace gtk3-ubuntu with gtk3?

I tried installing Unity-for-Arch. When I try to remove the Ubuntu-related stuff, I run into problems because gtk3 is a dependency to like...everything haha. sudo pacman -R gtk3-ubuntu would fail ...
0
votes
1answer
53 views

How to force pacman to answer yes to all questions?

I am trying to run pacman from a script. The problem is that a package should be installed that conflicts and provides, but not replaces a currently installed package. As answered here I passed the ...
0
votes
0answers
15 views

how do you make a list/file for pacman to install from

I am trying to move from one arch install a (partitioned one) to another (a less-partitioned one) on my computer and I want a similar set up. So I was wondering if there was a simple way to get pacman ...
3
votes
0answers
61 views

Configure connection timeout of pacman full system upgrade

Is there a way to set the timeout which pacman uses to establish connections to repository servers? My ISP (university) has blocked several Arch Linux (I use Manjaro) AUR and a few community servers. ...
32
votes
3answers
12k views

In Arch Linux how can I find out which package to install that will contain file X?

I'm looking for a package that provides a specific binary, so I can install it. how can I search to find out what packages provide this binary? (note: I know there's at least one tool that does this, ...
0
votes
1answer
21 views

Archlinux'es pacman + tee == unclear console IO [closed]

I have a small issue with capturing the pacman's IO with the tee utility. I try this command line: pacman -S group-1 group-2 | tee pacman.log And there is an issue: when the pacman query which ...
0
votes
0answers
243 views

pacman a file owned by two packages

i have installed microchip and jlink softwares from aur on my system. unfortunately this two packages own 99-jlink.rules file so i had to force install jlink. but now pacman and yaourt give me this ...
0
votes
1answer
71 views

How to install mit-scheme in Arch Linux?

It seems to be available here. But when I try the following command: $ sudo pacman -S mit-scheme I get the following: error: target not found: mit-scheme I've also tried with mit-scheme-git ...
1
vote
0answers
29 views

Which mirror did I download the Arch Linux package database from?

It seems that some packages in the official package repository have a new dependency which is not in the official repos: $ sudo pacman --sync --refresh --refresh --sysupgrade :: Synchronising package ...
3
votes
1answer
53 views

pacman doesn't download dependencies with -S and -w?

I got this weird thing going on where, pacman -S -w awesome xorg-xinit xorg-server xorg-server-utils pacman doesn't download all the required dependencies. The reason for downloading the packages ...
0
votes
1answer
79 views

Install 32 Bit Application on 64 Bit Arch Linux

I have an ancient openoffice plugin which requires the 32bit version of openoffice/libreoffice and does not work with the 64 bit version. So I would like to know, if there is any way to install the ...
5
votes
2answers
5k views

Arch Linux: pacman cannot be upgraded because pacman version is too high?

This seems a bit like an April Fools' joke, but this is what I was greeted with this morning, when trying to bring my Arch up to date: :: The following packages should be upgraded first : pacman ...
0
votes
2answers
1k views

Arch Linux failed to install libproxy for invalid signature

The following message is from my terminal: resolving dependencies... looking for inter-conflicts... Targets (1): libproxy-0.4.7-2 Total Installed Size: 0.29 MiB Proceed with installation? [Y/n] ...
0
votes
0answers
44 views

Cannot login after pacman -Syu

A few days ago Chromium complained about wanting to be updated. I performed the following series of commands, deciding to upgrade Python for kicks. pacman -Syy pacman -S chromium pacman -S python I ...
0
votes
0answers
9 views

Pacman select older application version from repo containing multiple

I'm installing Catalyst on my Antergos install, and because I have a slightly old(er) card (Redwood XT based FirePro v4800) I can't use the latest and greatest version. The repo maintained by VI0L0 ...
9
votes
1answer
19k views

pacman could not find database

I want to install sudo. So I type in pacman -S sudo. But then I get the following errors: warning: database file for 'extra' does not exist warning: database file for 'community' does not exist ...
0
votes
1answer
146 views

Archlinux Broken after clearing of pacman orphans and cache

I get an error message when I log into plasma 'All shell packages are missing. This is an installation issue, please contact your distribution. '. And I can't open a konsole session anymore. The last ...
3
votes
1answer
308 views

How can I keep two versions of the same package in archlinux?

I'm running Archlinux. Recently, one of the package named icu got updated; however, Firefox depends libicuuc.so.56, while R depends on libicuuc.so.55. How can I solve this problem? Note: the R ...
10
votes
3answers
2k views

Should I restart after a pacman upgrade?

after running sudo pacman -Syyu or sudo pacman -S [something to install] should I restart just to be safe?
0
votes
1answer
33 views

Format packages vertically in pacman

Suppose I don't upgrade my system for a while. Once I finally run pacman -Syu, I'll obviously get lots of packages. In cases like this, the output is completely unacceptable - all packages are written ...
2
votes
0answers
32 views

Why does pacman stop when I freeze the output with ctrl+s

I sometimes use ctrl+s to send an XOFF signal to freeze the output of a program without stopping the program itself. However, pacman, unlike most other programs, stops as if you had pressed ctrl+z. It ...
3
votes
2answers
2k views

pacman “exists on filesystem” error

I ran sudo pacman -Syu and I got some interesting errors reading: error: failed to commit transaction (conflicting files) and a long list of files followed by exists in filesystem. Full output ...
1
vote
1answer
4k views

How do I uninstall gnome-extra?

I come from an Ubuntu background. So I ran the following command: "sudo pacman -S gnome gnome-extra --needed" and I get this output: :: There are 40 members in group gnome: :: Repository extra 1) ...
1
vote
0answers
125 views

Frequent issues with Pamac, Pacman [closed]

I have recently switched over to Arch. I'm facing problems with Pacman and Pamac too frequently. GPGME error Unable to lock database Core not found, just to name a few I have been able to ...
-2
votes
1answer
39 views

how to extract package-links from pacman[Solved]

I have a slow internet connection,and need to extract packages from pacman so that I can remotely upload them and get them from my work. Do you know any way to do that?
1
vote
1answer
61 views

AUR package cannot be built and installed - what to do?

AUR is said the largest repository out there but sometimes, when trying to build and install, and also to build and install dependencies, the outcome is not always a success. What a medium user can ...
1
vote
0answers
34 views

Pacman add-repo error, is not a package file

I'm using archlinuxarm, armv7h architecture I'm trying to use add-repo but it gives me the following error: $ repo-add test.db.tar.gz dep/python2-numpy-1.9.2-2-armv7h.pkg.tar.xz ==> ERROR: ...
1
vote
0answers
120 views

pacman won't list files for a specific package, why? [closed]

I am trying to list files that belong to an installed package with pacman. For some of the packages, it works fine (I get the list of files): alex@tardis ~ % pacman -Ql bumblebee bumblebee /etc/ ...
16
votes
3answers
3k views

Make package explicitly installed in pacman

I have a package that's installed on my PC as an dependency to another package. I would like to have the package explicitly installed, but without actually re-installing it, or downloading any files. ...
0
votes
1answer
528 views

Setting up Arch Linux stuck in pacstrap

So when i run the command pacstrap /mnt base base-devel i get stuck at (0/140) checking keys in keyring [------------------------------] 0% I have internet connection but i don't know where the ...
0
votes
1answer
360 views

List that contains the last installed / upgraded packages in Arch Linux

How can I get a list of packages, that last installed / upgraded by pacman / yaourt in Arch Linux including the timestamp?
4
votes
2answers
8k views

What exactly is PKGBUILD and should I edit it when installing packages?

Whenever I use yaourt -Syua in my Manjaro Linux system, it'll give me Edit PKGBUILD ? [Y/n] ("A" to abort) and sometimes Edit chromium-pepper-flash.install ? [Y/n] ("A" to abort) Somewhere I ...
0
votes
0answers
53 views

How do I circumvent or gain root priviliges for pacman with PyDev?

I have downloaded and forked a project that I like to tinker with in Eclipse using PyDev. However, this project makes use of the package manager pacman that installs and uninstalls packages and needs ...
13
votes
5answers
6k views

List optional dependencies with pacman on arch linux

I'm using arch linux. Is there a way to list optional dependencies of all installed packages? And if yes, can I filter this list to see only the missing (not installed) packages?
0
votes
0answers
543 views

How to downgrade VirtualBox after a kernel upgrade to 4.1.4-1?

I run Arch Linux and did a complete pacman sync and upgrade of my entire system. One of the updates was a kernel upgrade that I am happy with and had no other problems with. One of the packages that ...
0
votes
1answer
75 views

Unable to update arch linux under proxy [duplicate]

Cannot update pacman using sudo pacman -Syu under proxy network. I tried exporting environment variables using export http_proxy='http://uem:12345@172.16.0.1:3128/' as my workplace network uses ...
2
votes
2answers
4k views

ImportError: libavcodec.so.56: cannot open shared object file: No such file or directory

I was installed opencv with pacman, when i try to import opencv, i have this error: >>> import cv2 Traceback (most recent call last): File "<stdin>", line 1, in <module> ...
1
vote
1answer
118 views

Efficiently running arch's makepkg on git master (frequent but “small” changes)

On arch, when using makepkg to build a pacman-installable .pkg.tar.xz file from source... If it's an AUR "-git" source rather than an upstream release, is there a way to (after the first makepkg) do a ...
1
vote
1answer
871 views

How do you downgrade multiple packages in arch linux?

I am trying to downgrade the vim package on arch linux to an earlier version (as I need to use an earlier version of ruby which breaks it [ref]). running downgrade vim and selecting the version ...
1
vote
0answers
272 views

Reinstall Arch Linux without losing downloaded packages

I was installing Arch Linux when the Internet went down. I was unable to download all the required packages. Over 70% of packages were downloaded. I'm trying to reinstall it with the command: ...
0
votes
1answer
233 views

Always answer Yes to replace package Arch Linux [duplicate]

I am trying to build the latest KDE Frameworks git packages. However, I currently have installed the stable non-git packages. In order to install all of the git packages I need to answer 'y' to all of ...
1
vote
1answer
3k views

Pacman's always failed when upgrading (unknown trust)

I'm trying to upgrade my systems, I even tried using another mirror, but it always show signature from <email> unknown trust, [package-file] is corrupted (invalid or corrupted package (PGP ...
1
vote
2answers
283 views

Alternatives to xsounds.org for haskell-core on arch linux

Every time I attempt to update my arch system using sudo pacman -Syu it fails because it failed to retrieve some files. The culprit is my ISP. It doesn't give me a reliable connection to the mirror of ...