tools for installing and maintaining software packages

learn more… | top users | synonyms (1)

6
votes
3answers
11k views

How to install emacs using YUM without X11 libraries?

I have installed a minimal installation of CentOS 6.3 inside a VirtualBox VM. Now, I would like to install Emacs for use from the command line only. When I do a search for emacs using yum search ...
2
votes
0answers
971 views

How to edit rpm's HEADER and NAME-VERSION-RELEASE

Is there's a way or a tool that can modify the HEADER and the NAME-VERSION-RELEASE for an existing rpm without installing/rebuilding it?
3
votes
1answer
222 views

Compile mkvtoolnix for router with customized firmware

I am using my router (asus-rt66u with customized firmware (tomato) as a media server. To get the tools I need, I have been using the optware package manager which has has bunch of cross-compiled ...
8
votes
3answers
4k views

Package manager for AIX

While installing Subversion on AIX (version 7.1) from the official site, there are dependencies I need to resolve first before I can proceed to install the subversion package. While installing the ...
4
votes
1answer
1k views

How can I get a package manager on a Samsung Chromebook?

I have enabled developer mode, and I can access the shell, but I don't have the emerge command, I remember reading that ChromeOS is built on Gentoo. How can I get a package manager on ChromeOS?
5
votes
1answer
1k views

Automate installation of VirtualBox Guest Additions via command-line

How can I install VirtualBox Guest Additions from a Bash script, in a unattended way? Whenever I run apt-get -y install dkms virtualbox-guest-dkms from the terminal I'm presented with a interactive ...
0
votes
1answer
136 views

Are there any non-GPL linux package managers?

I'm looking for a linux package manager for personal project. The main criterium is non-GPL (and it's variants) license. So far I've managed to find that only Slackware's pkgtools meet this rule, but ...
3
votes
2answers
623 views

How can I query for obsolete/outdated installed packages (ebuilds) on Gentoo?

Installed packages sometimes become obsolete because the package got version bumped and the ebuild for the old version got dropped. Also it happens that packages are dropped completely from the tree (...
0
votes
1answer
607 views

How to install apt-get without a package manager

How can I install apt-get on a 32-bit Linux System if I don't have an existing package manager, like yum? What do I need to get?
6
votes
3answers
339 views

See end-nodes of dependency graphs

I'm using Arch Linux, with its Pacman package manager. I want to keep my system as clean as possible, and that includes not having any unused packages installed. But, because of dependencies, it's not ...
0
votes
0answers
770 views

Why can't I find wireless-tools in Debian repositories?

I have installed the squeeze version of Debian on a computer in offline mode (no internet connection during installation). After the installation (that was successful) I edited /etc/apt/sources.list ...
2
votes
1answer
567 views

Fedora 16 to Fedora 17 post-upgrade tasks

I have just successfully upgraded from Fedora 16 to Fedora 17 using the Preupgrade tool. One of the post-upgrade steps suggested here is to "remove unsupported packages". The guide says to run ...
4
votes
1answer
1k views

How to make an rpm package that installs a Java environment if needed

I'm very new to RPM packaging and I'm curious if, during the installation of one RPM it is possible to conditionally install another RPM if needed. In a nutshell. My RPM requires a particular JRE. ...
5
votes
2answers
2k views

How to enable vim addon packages?

I have installed vim-nox as well as vim-latexsuite and vim-outliner on Ubuntu 12.10. There's nothing wrong with Vim but neither of the add-on packages does anything. What do I have to do to in order ...
3
votes
3answers
5k views

Remove yum repo using yum

I have no root access on my machine at work, but I have sudo permission to use sudo yum (and only yum). Recently I accidentally installed a faulty repository (dropbox), and now I'd like to remove it. ...
3
votes
3answers
2k views

OpenSUSE: Find all Packages without a repository

I just upgraded to OpenSUSE 12.2 from OpenSUSE 12.1 by changing all of my repositories to target 12.2 (instead of 12.1). Now that I've upgraded, I've found a bunch of packages that have no repository*,...
2
votes
2answers
3k views

Using a lua rock installed with luarocks

I wanted to install luasql.mysql with luarocks, and I've ran into a problem. Even though the packages were installed providing mysql.h, luarocks couldn't find it. I solved it eventually: luarocks ...
2
votes
2answers
343 views

Missing dependency during rpm install

When I install CodeAnalsyt, i get a failed dependency on libbfd-2.20.51 on Centos 6.3. Binutils is installed on my system and the failed dependency does exists at /usr/lib64/libbfd-2.20.51.0.2-5.34....
3
votes
2answers
582 views

Install programs without an internet connection on Debian

So I've been battling with my debian install lately, it doesn't have the firmware for either eth0 or wan0 NIC's. However, I got a firmware.zip file that I need to extract to /lib/firmware. The problem ...
2
votes
2answers
164 views

Do best-practices indicate that usage of /var should be restricted to sudoers

I wrote a package, and would like to use /var to persist some data. The data I'm storing would perhaps even be thought of as an addition for /var/db. The pattern I observe is that files in /var/db, ...
4
votes
1answer
285 views

How do I delete a partial package in OpenBSD

While upgrading, I tried to add a package that was already there and due to some error, a partial package got created - partial-gnutls. When I try to delete this partial package, I get these errors: ...
-1
votes
1answer
299 views

Installing packages after the RedHat installation?

I was installing the RedHat 5.5 64 bit. But in hurry I forgot to install the Packages needed. And I don't want to install RH again. How can I install packages after installation?
0
votes
3answers
6k views

Updating PHP 5.3 to 5.4 in CentOS

I followed this tutorial to update PHP from 5.3 version to 5.4. My distro is CentOS 5.5. After running the following command: yum --enablerepo=remi,remi-test install httpd php php-common I get ...
8
votes
3answers
3k views

Download ALL rpms for a product

I have two CentOS machines, one 6.3 box (A), and another CentOS 6.1. (B) 6.3 box is with internet connection, 6.1 box is without internet connection. I want to download ALL dependencies of a product ...
1
vote
1answer
62 views

Finding which Debian distro CDs contain a certain package

I am currently installing Debian Linux on a computer that does not have Internet access. I have burned the first few CDs from the distro and have a working system so far. However, I am unable to find ...
3
votes
1answer
1k views

Getting newer version of GEOS than what is available in Debian repositories

I need to install a GEOS version >= 3.2.2, and doing so is beyond my current aptitude (pun intended). The current Debian squeeze version is 3.2.0, which will not work for my purposes (using the rgeos ...
3
votes
1answer
397 views

Unable to uninstall libglib2.0-0 from Software Center

I have a fresh install of Debian 6.0.5 (i386) on VMware Player. I was trying to install libglib2.0-0 using this command: sudo aptitude install libglib2.0-0 Unfortunately, I don't remember the ...
1
vote
3answers
6k views

sudo: apt-get: command not found

I am trying to install aircrack-ng in my Sabayon 9 by the use of this command: sudo apt-get install aircrack-ng but it says: sudo: apt-get: command not found How to install it?
7
votes
1answer
2k views

apt-get -f install is stuck on “corrupted filesystem tarfile”

I am having issues with apt-get on my Raspberry Pi. This is the output when I try and install a package: pi@raspberrypi ~ $ sudo apt-get -f install cowsay Reading package lists... Done Building ...
3
votes
1answer
498 views

Install debian without gnome

I would like to install debian with another desktop than Gnome. In this case I can't use tasksel but have to install every package with apt-get. What do I need to run debian with Windowmaker?
6
votes
2answers
6k views

Check for updates of packages installed through yaourt

Is there anyway to update package installed with yaourt ? yaourt -Syu seems to do the same as pacman -Syu, which only care about package in official repository.
3
votes
0answers
33 views

Find packages not maintained in main repo? [duplicate]

Possible Duplicate: listing packages in Debian, a la dpkg -l, but including the package origin/source E.g. Ubuntu Server offers only security updates for software contained in the main ...
8
votes
3answers
11k views

CentOS: Install packages listed in a text file?

I have an existing CentOS installation which I'd like to install extra packages to. The packages to be installed were supplied to me in a list, one package per line, which looks like: .... ...
1
vote
4answers
91 views

Is really need Internet connection after installed all pkgs?

I know when you want to Install any new pkg then internet connection is required .right now I am using Ubuntu 12.04 I have Internet connection. using following command I installed one pkg.(e.g vlc ...
1
vote
1answer
472 views

Transfer programs to another OS

I have openSUSE. I can install programs with yum. yum install <progname> I want to move my install to a new hard disk. How can I transfer programs from one OS to another? My problem is ...
2
votes
3answers
1k views

Are there websites that allow one to search for which package contains a particular file?

I want to write some generic instructions on how to find the package that installs a particular file (the exact context is TeX packages: find the package in the Unix distribution that contains a ...
6
votes
3answers
847 views

Effect of compiling from source on already installed applications

I use Ubuntu 12.04. Say I have installed package x from the repository (with all its dependencies) at version 1.7 but I need some functionality that is only available in version 1.8, so I download the ...
0
votes
1answer
125 views

package management [duplicate]

Possible Duplicate: automatically installing packages I have two virtual machines, and I want to install packages atomically from repository . Is there any specific package management software,...
0
votes
1answer
284 views

How to automatically install packages?

I want to install packages automatically by running a script I can write yum install php, but I want it to install another package once installation of the php package is completed. Is there any ...
5
votes
3answers
3k views

Can I determine what changed in an upgraded package using apt or dpkg on Debian 6?

I just did an apt-get upgrade on my Debian 6 development server and noticed that a certain package named tinyproxy was upgraded. I have a particular interest in seeing precisely what changed in that ...
1
vote
4answers
152 views

Are packages downloaded from multiple mirror sites?

I'm running F17 and inside of yum.repos.d. I see multiple repos listed like adobe-linux-1386.repo, fedora.repo, google-chrome.repo, etc. When I yum install are some files being downloaded from ...
1
vote
1answer
110 views

What is happening exactly when I install a package with yum?

I'm running F17 from Terminal. I was wondering what is happening in the background when I yum install packagename. Is that package being searched for on my browser? Where is it being downloaded from? ...
4
votes
2answers
4k views

Identifying the system package manager

Is there a way (from a script) to identify the default system package manager? To clarify, what I want to do is run a given command and, on Debian or any of its derivatives it'll return something ...
2
votes
1answer
454 views

Custom resolution in Fedora 11

I am currently building a custom embedded project for which I need to display Fedora 11 on a small screen 800*480 pixels. Can anyone one suggest to me a way of doing it. As I am a complete noob I ...
3
votes
2answers
5k views

How do I install Chromium on F17?

I just installed the Beefy Miracle on my box, but essentially being the first time I've used Linux I'm not sure how to perform even some of the most basic tasks. I thought I would try to install ...
1
vote
2answers
3k views

How do I install packages with F17?

I just installed Fedora 17 on my box and I'm having trouble installing packages. I used to think that across all linux os'es all it took was sudo apt-get install packagae. I don't think this is the ...
2
votes
2answers
1k views

Solaris 11: how to get pkg properties in machine readable format

I would like to be able to extract (from within a shell script) the attributes of an IPS package. Basically I'm after exact same information as is listed with the pkg info command, but unfortunately ...
3
votes
3answers
1k views

Present USE flags upon emerging a package in gentoo

I was wondering if there are any tools to present the compile time options/ flags of a package in Gentoo when emerging. I am referring to something like this
0
votes
2answers
170 views

Determining Dependencies and Installing from Directory

I have a directory with all Dependencies in .deb format. But there are lots of them. I need only those that i need for gimp. biggenius@hacbook:~/Desktop/rocks/packages$ dpkg-deb -I gimp_2.6.12-...
1
vote
2answers
772 views

uwsgi install in Debian 6 (Squeeze) wants to upgrade libc6 and initscripts

I'd like to install uwsgi on my Debian server. This package wants to upgrade some core packages: libc6 from 2.11.3-3 (now, stable) -> 2.13-35 initscripts from 2.88dsf-13.1+squeeze1 (now, stable) -> ...