0
votes
2answers
131 views

Prevent Zypper trying to use IPv6

I'm setting up a box with OpenSUSE 13.1. For reasons beyond my comprehension, Zypper utterly insists on using IPv6 addresses and refuses to use IPv4. Which is a problem, since IPv6 doesn't work on our ...
0
votes
0answers
11 views

Any packages for download management (some thing like DAP 4 W$ ) in opensuse-Gnome?

I'm looking for a package that can manage my internet downloads. Especially to expedite the download process.
2
votes
1answer
82 views

Using zypper, how can I remove all packages installed from a specific repository?

Say I've added a repository using zypper ar. Then, I've gone and installed multiple packages from that repository, but now I want to remove all of them. Is there a command that allows me to remove ...
1
vote
1answer
111 views

Library mismatch OpenSUSE 12.3 - totally borked, update gone bad

My workstation at work is OpenSUSE 12.3 KDE. I added the pacman repository to update SVN from 1.7.11 to 1.8.?. Later, I ran zypper update which updates all libraries to the latest "stable" build. Well ...
0
votes
0answers
72 views

I broke zypper somehow; zypper: /lib64/libresolv.so.2

Every time I try and run zypper I get the following error: WLS1:~ # zypper zypper: /lib64/libresolv.so.2: version `GLIBC_2.9' not found (required by /usr/lib64/libkrb5.so.3) WLS1:~ # dir ...
1
vote
1answer
34 views

Command line error in OpenSUSE (old version)

I'm using an old version of OpenSUSE and when I try to update some package via the command line, e.g. Zypper update firefox it shows the message listed below. System management is locked by ...
1
vote
0answers
33 views

How to AND terms in zypper search?

Suppose I want to search for the packet luasocket in OpenSUSE, but I don't know if it's called lua-socket, lua_socket, liblua-socket, lua5.1-socket, socket-lua or who knows what. Therefore I make a ...
0
votes
1answer
59 views

Out-of-the-box openSUSE 12.3: Package webkit-sharp-devel not found

I installed openSUSE 12.3 and now want to install the package gtk-sharp2-devel: $ sudo zypper install webkit-sharp-devel Package 'webkit-sharp-devel' not found. Strange since a Google request seems ...
1
vote
1answer
536 views

How to use zypper in bash scripts for someone coming from apt-get?

I have a few questions about moving from apt-get to zypper in bash scripts. What is the equivalent of this? sudo apt-get install curl --assume-yes (where curl could be any package) I found the ...
3
votes
1answer
54 views

get info about package update in openSuSE

Is there any way to get information about an available package update via zypper? I can get info about a patch with: zypper info -t patch pachNameHere and I can obtain the patch name via: zypper ...
1
vote
1answer
217 views

Adding openSuSe mono repository?

Question: I want to install mono3 from here: http://download.mono-project.com/archive/3.0.3/linux/x64/ How can I add this link to the appropriate OpenSuse package installation program ? I tried ...
1
vote
2answers
490 views

OpenSUSE: Find all Packages without a repository

I just upgraded to OpenSUSE 12.2 from OpenSUSE 12.1 by changing all of my repositories to target 12.2 (instead of 12.1). Now that I've upgraded, I've found a bunch of packages that have no ...
4
votes
2answers
1k views

How to install patterns and packages at the same time?

How can I install package patterns (e.g. "C/C++ development tools") and packages (e.g. "mercurial") at the same time? Currently, two commands are necessary; for example, the installation instructions ...
2
votes
1answer
530 views

Tips for making software updates automatic in OpenSuse (zypper)

I'm currently working in a command line only environment. I would like to perform daily updates automatically using zypper, however I can't find a good way to do it. By good I mean clean and simple. ...
3
votes
3answers
1k views

Package managers Update versus Upgrade?

sudo zypper update The following package updates will NOT be installed: amarok bluedevil choqok cln digikam digikam-lang GeoIP gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs ...