Mono is an open source implementation of Microsoft's .NET Framework based on the ECMA standards for C# and the Common Language Runtime.

learn more… | top users | synonyms

2
votes
1answer
299 views

Install apache2-mod-mono-2.10

I am trying to install mod-mono for apache so that I can run C# asp.net websites from my server. The project I have is a .net 4 project. When I go into yast and select apache2-mod-mono for install ...
1
vote
0answers
50 views

Monodevelop D Bindings for Debian / Ubuntu?

I want to install the D-Language binding for MonoDevelop but it does require MonoDevelop 4.x, which isn't available yet for Linux based systems. Is there any way I can get around this? I tried ...
1
vote
0answers
293 views

Mono spits out too many errors after update, try to reinstall, more errors

I had errors with apt-get update && apt-get dist-upgrade, from mono mono, so I tried this instead: sudo apt-get install --reinstall banshee banshee-extension-soundmenu ...
1
vote
0answers
123 views

Program does not terminate when called from udev

I've written a program in C#/Mono that probes a device to determine if it is a modem. The program works fine from the command line. However, when it is called from PROGRAM= in a udev rule, the ...
0
votes
0answers
16 views

How to install apache mod_mono with a custom compiled version of mono in Ubuntu

Because the latest version of mono available through apt-get in ubuntu does not include support for specific libraries I need, I uninstalled it and compiled it from github. However, installing ...
0
votes
0answers
61 views

can xsp4 run .net 4.5 based application using mono framework?

I have installed mono 3.2.8 package into centOS 6.5 to run web application using mod-mono module. I have also installed apache 2, mod-mono 2.10 and xsp 2.10.2 in that system. Then I have tried to ...
0
votes
0answers
48 views

C# project not building. Error says mono is not configured correctly. On a rhel 6.5 Workstation

I'm using Eclipse, and I installed the emonic plugin for C# and the .net. When it autobuilds a project I get this error: BUILD FAILED Mono 3.5 Profile (mono-3.5) is not installed, or not correctly ...
0
votes
0answers
189 views

How to fix library problem with mono on Debian?

I installed mono and when trying to run an app: a@debianVM:~/.wine/drive_c/Program Files/BOT$ mono ./APBInfinite.exe Mono: gc took 12 usecs (sip) Mono: DllImport error loading library ...
0
votes
0answers
1k views

mod-mono-server 4 is not working, while 2 does

I need to deploy an ASP.NET MVC4 (MVC3 at least) application on Centos 6 server. I've installed Mono 3.2.1, XSP4, mod_mono (for use with apache web server) and succesfully ran the test application ...
0
votes
0answers
242 views

Installing XSP on CentOS

Trying to install xsp-2.10.2. Worked fine in the past, now getting this error. Making install in Mono.WebServer mkdir: cannot create directory `2.0': File exists GMCS /out:2.0/Mono.WebServer2.dll ...