Metasploit is an open source exploitation framework that acts as a tool for developing and executing exploit code against a remote target machine

learn more… | top users | synonyms

0
votes
1answer
33 views

How to diagnose problems of Metasploit not running correctly? [closed]

I am entirely new in Linux. I have set up a pen-testing lab with Kali Linux 1.1.0b, windows xp sp3, and, Metasploitable 2 Linux. PostgreSQL and Metasploit services are running well. But, the ...
0
votes
0answers
25 views

Metasploitable 2 don't run on VirtualBox; status = Aborted

For my tests I just configure Metasploitable 2 image in my VirtualBox (VirtualBox VM 4.3.26 r98988 linux.x86). When I try to start the VM it crashes after few seconds and takes the state "Aborted". ...
0
votes
1answer
51 views

How to achieve root privilege in Metasploitable 2 Linux?

Suppose, I have just entered the Metasploitable 2 Linux like the following command: username : msfadmin password : msfadmin Now, I need to gain 'root' privilege so that I do not need to use 'sudo' ...
0
votes
0answers
24 views

What is the basic difference between Kali Linux and Metasploitable Linux in the area of pentesting?

What is the basic difference between 'Kali Linux' and 'Metasploitable Linux'? What is the thing that one of them has, while the other doesn't? Both of them are used for penetration testing, but, I ...
-3
votes
2answers
177 views

How do I run as a limited user while logged in as Root, and another question

Is there a way to, on linux, do: run as limited user when logged in as root? (like sudo but vice versa, so instead of GRANTING rights, it limits them, i.e., for use with "bundle install" for missing ...
1
vote
0answers
970 views

Postgresql 9.1 - Kali Linux

I start to read this book : http://www.amazon.fr/Metasploit-The-Penetration-Testers-Guide/dp/159327288X And i have some trouble in using postgresql 9.1 (in Kali Linux). When i start msfconsole, i ...
1
vote
2answers
77 views

Can't find nmap executable in Metasploit

I'm running Metasploit in archlinux and when I execute msf> db_nmap -h It'll return an error: The nmap executable could not be found Now, I know I am probably missing a binary or something, ...
2
votes
0answers
249 views

How to install Metasploit Community on Debian?

After attempting to get Metasploit to work nice with my desktop box (with limited success), I've decided to instead set it up on on separate box. However, it seems like the Metasploit community ...
1
vote
0answers
648 views

Using Metasploit with 3G USB modem

I have a computer with Linux BackTrack 5 as host and Windows XP as guest on virtual box. I am using Host-Only-Adapter to create virtual LAN and to share USB modem internet as well so that both host ...
1
vote
0answers
483 views

Manually setting environment variables for Metasploit

How do I set manually environment variables for Metasploit, when I execute db_driver I get this message: [*] No Active Driver [*] Available: [*] DB Support: Enable the postgresql driver ...