0
votes
1answer
197 views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
1
vote
0answers
41 views

What are the generic-pae directories in /lib/modules?

When listing the content of the dirctory /lib/modules I see a list of generic-pae directories (Ubuntu 12.04): drwxr-xr-x 4 root root 4096 Apr 23 2012 3.2.0-23-generic-pae drwxr-xr-x 5 root root ...
4
votes
2answers
2k views

Use shared libraries in /usr/local/lib

I have build some libraries from sources, and the files after make install are in /usr/local/lib For example, in my case I have the file libodb-2.2.so which is in this directory. However when I ...
1
vote
1answer
4k views

Missing 32 bit library on a 64 bit Linux install

I am trying to figure out why Eclipse is complaining about being unable to find a library. I've managed to reproduce/reduce the java problem to: $ ldd ...
3
votes
1answer
1k views

Using Atlas from scipy

I installed Ubuntu 12.04 64 bit. I need to work with python and scipy, I installed them and when I run the test: python -c "import scipy; scipy.test()" I get the message: ImportError: ...
3
votes
2answers
605 views

Package installation and dependancies - how to prevent installation of existing libraries?

I'm a relatively new Ubuntu server user, so I'm learning as I go. I have an issue with a software package I'm installing (QGIS) which has several dependancies one of them being gdal library. ...
5
votes
1answer
3k views

Where did /usr/lib64 go and what is /usr/lib/x86_64-linux-gnu?

I have two Ubuntu-x86_64 systems. One is version 10.04, the other 12.04 and there is a difference in the structure of the lib directories. This doesn't surprise me, but I'm curious if anyone knows ...
7
votes
1answer
269 views

Finding the library versions a library was linked against

I have a library that was compiled on an unknown Ubuntu machine, And I'd like to determine what version of Ubuntu that machine had at the compile time. My idea was to try and find the versions of ...
0
votes
1answer
3k views

How to manually uninstall urllib, urllib2, requests python packages?

I'm having a problem with urllib, urllib2 and requests, three python libraries. I use Ubuntu 10.04.4 LTS and python 2.6.5 (we can use with python) (but I had installed manually, after the problem, ...
0
votes
1answer
440 views

GUI not working in Ubuntu 11.04 after removing some packages

I accidentally removed i32-libs using the following command sudo apt-get remove ia32-libs Now the GUI is not working properly: when I login, it just shows me a small terminal on one side of ...
1
vote
1answer
683 views

How and where to install a headers only library?

I like to install gource which requires libglm-dev installed on the system. I am using Ubuntu 10.10. Maverick. The newest sources of the headers only library I found is not available for apt-get. ...
3
votes
2answers
638 views

Ubuntu 10.04 can't boot, kernel panic

I downloaded pcap source compiled it and got a lib ending in libsomething.so.1.21.1. I tried to find how to install a lib online and in my impatience did the following sudo .install-sh /lib ...
2
votes
1answer
511 views

What does this error mean when installing namecoin?

I'm trying to set up namecoin, but I get the following error on running makefile.unix: $ g++ -c -O2 -Wno-invalid-offsetof -Wformat -g -D__WXDEBUG__ -DNOPCH DFOURWAYSSE2 -DUSE_SSL -DUSE_UPNP=0 -o ...