Gentoo is a Linux distribution designed to be automatically optimized and customized according to the user's need.

learn more… | top users | synonyms

5
votes
1answer
2k views

VDPAU library not found

I want to try this VAAPI backend for VDPAU. I have compiled mplayer with vdpau in Gentoo Linux (amd64) but I get this error: Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object ...
4
votes
1answer
565 views

Gentoo Live CD from Hard Drive: No Mountable Filesystems on root after modules loaded

I am attempting to install Gentoo on my PowerPC Mac. I have reached the point where I can boot the Live CD (I have no functional CD Drive, so it is from a spare Hard Drive), but after the kernel is ...
3
votes
1answer
74 views

Is there a way to “stabilize” past built unstable Gentoo binary packages without rebuilding?

Here's the scenario: build some ~amd64 package versions on your binhost later those same package versions go stable in portage, so no version bumps involved even if packages are listed stable in ...
4
votes
0answers
313 views

Migrating from Funtoo to Gentoo on a running system

I have a Funtoo system now, but want to migrate (back) to Gentoo. If possible keeping a usable system during the installation (not rebuilding from scratch using a live CD). Both systems should be ...
3
votes
0answers
84 views

Firefox ESR 31.2.0 on Gentoo Linux mangles ligatures “ff”, “fl”, “fi” and “ffl”

I am running Firefox ESR 31.2.0 on Gentoo Linux on an AMD64 computer with 8 GB RAM. Today I noticed that quite often, when Firefox encounters the text sequences "ff", "fi", "fl" and "ffl", it merges ...
3
votes
0answers
201 views

How do I make the CLI run on dedicated graphics?

I just finished my Gentoo minimal install and the first thing I wonder is why I get no picture. I did have signal on the live CD, so that was pretty odd. I plugged the monitor into the Intel HD ...
3
votes
0answers
217 views

target/build CFLAGS mixup when cross-emerging due to bug or my stupidity?

I'm trying to emerge LLVM using emerge from a crossdev (for ARM) overlay in Gentoo. I've set the CFLAG of the overlay to optimise for arm (-march=armv6j), which seems to make ./configure fail on the ...
2
votes
0answers
289 views

Unable to boot with dracut and luks: '/dev/resume' : file exists

I am installing gentoo and have performed my first reboot after configuration and installation within my chroot environment. I am using LUKS and LVM to manage encryption of my drives. I am encrypting ...
2
votes
0answers
159 views

Why will plymouth not update?

I admit I don't update my kernel very often. I used to everytime a stable release of sys-kernel/gentoo-sources came out so I'm very adept at doing it. This last weekend I attempted to update from ...
2
votes
0answers
396 views

NetworkManager cannot remember my WiFi password

My system is Gentoo 64bit, with KDE4. I just updated my Gentoo system. And after reboot, it asks me for my WiFi password. But the next I log in, it asks the password again. I checked the settings, and ...
2
votes
0answers
509 views

Can not access to samba4.1 shares on gentoo box

I have one Windows 7 x64 PC, and a Gentoo Box, which act as a NAS. I tried to migrate from Samba3 to Samba4.1.6, and while Samba isup, I fail to connect; I have the following error that is popping (it ...
2
votes
0answers
185 views

Screen keeps dimming on Power (Dis-)Connect

I would like to disable the automatic screen dimming when I plug in our out my power adapter. Every time my laptop switches between battery/ac, my screen dims even though I have disabled it in every ...
2
votes
0answers
731 views

kio sftp does not work but fish works

If I try to initiate an sftp connection from dolphin (or konquerer), it tells me the password is wrong and asks me for the correct password. Incorrect username or password Do you want to retry? ...
1
vote
0answers
74 views

Some of fn keys not recognized after upgrade

After upgrading my system (including kernel) I discovered that some of fn keys (XF86MonBrightnessUp and XF86MonBrightnessDown) are not recognized by xev and even showkey. Each time one of these keys ...
1
vote
0answers
75 views

grub-mkconfig generates duplicate entries for an Ubuntu/Gentoo dual boot setup

I'm currently running Ubuntu (Xubuntu, specifically) as the primary OS on one of my systems. I've been building up a Gentoo installation on a new logical volume on the same system and I'm at the point ...
1
vote
0answers
33 views

How to make sure to get the Main/External IP without regard to network device type/name

Hello, I need to make sure I have the external or at least the main IP address for a given machine, regardless to the device type/name. I quickly wrote that tiny script for that purpose, but I need ...
1
vote
0answers
812 views

Bluetooth troubles with AR3012 on Gentoo

I'm using Linux 3.14.14-gentoo with BT_ATH3K enabled. I've downloaded the latest linux-firmware from Portage (20131230), and bluez-5.21-r1. My Bluetooth device is an AR3012 according to lsusb: Bus ...
1
vote
0answers
89 views

MDADM Array Detection Slowing Down Boot - Why?

I have an AMD64 Gentoo (running systemd) build with a RAID0 root and some other arrays (RAID1 boot, RAID1 home etc..). The boot process is being slowed down quite dramatically as mdadm searches the ...
1
vote
0answers
112 views

nfsroot freezing every once in a while presumably due to network glitch

Setup I've set up a thin client running gentoo according to these instructions. It seems to work quite nicely except that every once in a while it freezes. I've found that I can duplicate the issue ...
1
vote
0answers
45 views

SLIM login manager Causes Urxvt window to loose Transparent/Opacity effect

On Gentoo.... This is strange.... when I start X through SLIM I loose the opacity(transparent look) on my urxvt windows. It's only when I start X through SLIM. If I start X with xinit directly, ...
1
vote
0answers
457 views

Cannot create L2TP/IPSec VPN connection on Gentoo

My system is Gentoo 64bit, DE is KDE 4, and I have just updated my system. I set up a L2TP/IPSec VPN but it cannot initiate the connection. Whenever I try to connect I got below error in my system ...
1
vote
0answers
190 views

How to debug a semop failure?

Using a 2.6.30-gentoo-r4 Linux a very complex system of php code is executed (with 4.4.9-pl0-gentoo and 5.2.10-pl0-gentoo), which occasionally runs into a semaphore blocking problem. The call to the ...
1
vote
0answers
222 views

Gnome clock on UTC, not local

My OS is Gentoo. My Hardware Clock is set to UTC. The date command returns the correct time and timezone (EDT). However, my GNOME clock is set to UTC. I have 2 clocks, one at Internet Time, and one ...
1
vote
0answers
103 views

Diagnoising a hardware issue on linux

I have a laptop that completly turns its self off after an unpredictable amount of time. It also doesn't allow for its self to turn it back on after a period of time. To me this sounds like an issue ...
1
vote
0answers
291 views

Gentoo framebuffer dual monitors

I have Gentoo and great frame buffer with smaller fonts and great resolution, also I have two monitors. On both monitors I have same frame buffer. Is it possible to have multiple different frame ...
1
vote
0answers
110 views

Help with understanding the usage of the command “equery has”

equery has portage !!! Fatal error: Used ENV_VAR without match_expression or --package There is no description in http://en.gentoo-wiki.com/wiki/Gentoolkit On the other hand man page says it is not ...
1
vote
0answers
283 views

How can I configure Wine's default paper settings?

I'm having trouble with the locale settings in my Microsoft Office Wine bottle/prefix. When I created it, I had followed the Gentoo Localization Guide's suggestion to not set LC_ALL. However, when I ...
1
vote
0answers
515 views

qemu-kvm savevm very slow

I have up to date gentoo system with kvm images located on 500 gb partition with 200 gb of free space and defragmented, running machine with Windows XP and 2gb ram, I have problem with making snapshot ...
1
vote
0answers
139 views

Program does not terminate when called from udev

I've written a program in C#/Mono that probes a device to determine if it is a modem. The program works fine from the command line. However, when it is called from PROGRAM= in a udev rule, the ...
1
vote
0answers
287 views

Gentoo Gnome 3.2 Wireless “Connecting…”

I recently updated my Gentoo with GNOME 2.x to GNOME 3.2. My NetworkManager applet refuses to connect to my network; however, it does not give an error as it simply hangs as "Connecting..." I checked ...
0
votes
0answers
5 views

Grub reboots PC after showing only “Grub loading.”

I have this old computer I use for the more experimental OSes, and about a month ago I installed Gentoo on it, with GRUB2 as boot loader. Everything worked fine, but every boot it would show an error ...
0
votes
0answers
8 views

Using package.env for phase hooks

Following this answer I've set up a simple file /etc/portage/env/echo.conf: post_pkg_postinst() { echo "updating $P to $PV" } with the line sys-apps/util-linux echo.conf in ...
0
votes
0answers
69 views

Realtek RTL8723BE Network Card not working on Chromium OS

I use the Lenovo ThinkPad E550 with Realtek rtl8723be network card and the wifi works perfectly on Windows8.1 or Ubuntu 15.04 . Now , i run Chromium OS build by ArnoldTheBat on it . The ...
0
votes
0answers
39 views

Gentoo boots into grub2, “You need to load the kernel first”

I just finished my first Gentoo install and rebooted. I'm taken to GRUB2 and try to boot, it returns error: you need to load the kernel first I tried kernel /vmlinuz But it could not find ...
0
votes
0answers
12 views

aufs root on gentoo/funtoo

I have used an aufs root before on gentoo years ago, but cannot seem to get it going now. I am using genkernel-next, I would imagine I used genkernel before as well. I am using funtoo with ...
0
votes
0answers
17 views

Upgrading Portage?

I'm attempting to upgrade portage on my Chromium OS VM and I get a masking on the upgrade saying it's masked by EAPI 5 and that my current version is EAPI 4. In order to upgrade portage I need EAPI 5 ...
0
votes
0answers
48 views

No TwinView option in nvidia-settings

Good Morning, I cannot find the TwinView options in nvidia-settings; is it gone? I tried enabling it manually in xorg.conf but then the server won't start. Nvidia Driver: 340.76 X: 1.16.4 Kernel: ...
0
votes
0answers
94 views

Getting webcam to work in gentoo

My webcam is working properly using Camorama , Guvcview and WebBrowsers[firefox,chrome] , ekiga recognizes my webcam too and it even turns on its indicator light but there is nothing but a empty ...
0
votes
0answers
72 views

Can distcc use ccache on the compile servers?

I know that ccache can use distcc as a compiler wrapper, but can the opposite also be done? I have a bunch of raspberry pi machines which use distcc to cross-compile their arm binaries on a x64 ...
0
votes
0answers
116 views

how to install unicode fonts in gentoo-based linux?

this question: How can I get full Unicode font coverage for Gentoo Linux? gives the idea of what I want to do, but I don't know HOW to do that. I wish to install all unicode fonts, because github ...
0
votes
0answers
333 views

How to change CFLAGS option -march from native to corei7?

Is it possible to change the CFLAGS -march=native to -march=corei7? Would I have to recompile the whole system once this change is made? I would like to setup distcc and I read that march cannot be ...
0
votes
0answers
2k views

Unit couchdb.service failed to load: No such file or directory

I have couchdb on Sabayon running # couchdb -version getopt: invalid option -- 'v' Try `couchdb -h' for more information. kernel-poll not supported; "K" parameter ignored Apache CouchDB 1.5.0 ...
0
votes
0answers
133 views

Emerge freezes on raspberry pi without error message

I am trying to install raspberrypi-userland to my gentoo system with the command emerge --ask raspberrypi-userland on my raspberry pi. I am well aware that without cross-compile environment this ...
0
votes
0answers
151 views

Gentoo: Display stays black after inactivity (ThinkPad T60p, ATI FireGL)

I've freshly installed Gentoo on my ThinkPad T60p. The graphics card is an ATI FireGL v5200, so I configured the Kernel to use KMS with radeon selected and included R300_cp.bin as the firmware. ...
0
votes
0answers
448 views

Suspend-to-ram fails on Gentoo with i915

I am struggling with suspend-to-ram on my Acer Aspire V3 772G with Gentoo. My configuration: Gentoo 3.12.5 kernel (.config) /etc/portage/make.conf Portage world file 1) It works in Windows 7 and ...
0
votes
0answers
146 views

PyOpenCL and Mesa Radeon driver

I'm trying to run pyopencl with the open source radeon drivers on gentoo. The package compiles fine, but every time I try to import the pyopencl module, I get an error telling me that the ...
0
votes
0answers
204 views

tweaking the gentoo livecd for a 100% headless install

I am trying to enable ssh and a create a static root password for the live-cd. While the process seems quite obvious, I haven't been able to get a bootable image out of it. SSH-enabled gentoo livecd ...
0
votes
0answers
92 views

Gentoo - problem with setting services up (KDE 4.10)

I have a problem with Gentoo. I have installed Gentoo in VirtualBox and it works perfectly. I have learned a lot about Gentoo, how to compile everything, how to set Gentoo for my needs. But now I ...
0
votes
0answers
251 views

How to set a ldflag for a library in home folder

I followed the following manual http://photivo.org/photivo/download_and_setup/linux how to compile Photivo on Sabayon: graphicsmagick 16 bit wget -c ...
0
votes
0answers
449 views

Automount in Xfce4 just stopped working

A little while ago my usb drives stopped auto mounting. It might have been after an update but not sure where to look. I have been manually mounting them as root and that is a pain. Is there maybe ...