Questions regarding GNU Compiler Collection Suite.

learn more… | top users | synonyms

5
votes
2answers
98 views

Would it be possible to compile and bootstrap GNU?

A new Guix release came out some time ago. And I got the idea that if I can bootstrap glibc, gcc, and guix to HURD and Mach, I can have a non-Linux GNU system. But I also need some software like bash, ...
0
votes
2answers
1k views

gcc: fail sanity check error, I suppose due to cxx USE flag missed

Recently I've done emerege -e world and then found that gcc was compiled without cxx flag. Now I can't compile any C++ package due to configure: error: C++ preprocessor "/lib/cpp" fails sanity check ...
5
votes
1answer
62 views

Why is this Python package trying to use a non-existent gcc?

I'm trying to install PyCrypto for Python 3 on Solaris. Whether I do it via "python3 setup.py install" or "pip3 install pycrypto", I run into the same problem: a call is made to a gcc which does not ...
2
votes
1answer
544 views

No 32 development library error after install glibc-devel.i686

I am trying to install gcc 4.9.0 on centOS 6. During ./configure there is an error coming up: /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.4.7/libgcc_s.so when searching for ...
2
votes
1answer
2k views

Linker error: /usr/bin/ld: cannot find -lgcc_s

I am trying to compile symlinks (tar.gz-file), which is a very small tool with one line for compilation: gcc -Wall -Wstrict-prototypes -O2 -N -s -o symlinks symlinks.c which gives the error .... ...
2
votes
1answer
3k views

How to install gcc 4.8.1 on debian wheezy

I would like to install GCC 4.8.1 on my Debian Wheezy 7.1.0 system. The current version of GCC installed on my system is the 4.7.2. I see gcc-4.8.1 is available on the Debian repository. Can someone ...
1
vote
1answer
430 views

Understanding SPL & U-Boot Memory Map using bdinfo?

We are using beaglebone black based custom board, I want to write some test results into RAM location from SPL, and read that log and send it via tftpput to the host PC. So far I'm able to do tftpput ...
1
vote
1answer
148 views

Install the latest gcc on Pygoscelis Papua (Gentoo)

I would like to try out Gentoo and I started a Pygoscelis Papua instance on Amazon EC2. How do I install the latest version of gcc to compile my programs? I tried emerge -u gcc gcc-config -l as ...
0
votes
1answer
62 views

Create single executable file from directory

I'm looking to create a single executable file from a directory, to make a 'standalone' app. So say my directory structure is: -app --assets --bin --views runme go.sh and within go.sh I ...
0
votes
1answer
3k views

make[2]: *** [sub-make] Error 2 make[1]: *** [all] Error 2

I tried to install MADWIFI on my OpenMediaVault-Server. Any more information needed? I get this error, every time i enter make: root@NAS2024:/media/5703066A59887FF7/Dsys/madwifi-0.9.4# make Checking ...
0
votes
1answer
124 views

Compile OS with gcc and ld on Linux

I'm practicing operating system development and am having trouble getting gcc and ld to produce pure binary without any metadata or section labels. For example: int function(){ return 100;} would ...
0
votes
1answer
251 views

How to specify a custom include directory in Debian?

I am trying to compile my program on a Debian system via ssh and without root privileges. PRETTY_NAME="Debian GNU/Linux 7 (wheezy)" NAME="Debian GNU/Linux" VERSION_ID="7" VERSION="7 (wheezy)" I ...
0
votes
1answer
66 views

Squeeze/Lenny compilation : Library Link error

I've got a problem here : I have a C++ Library ("DataTsBroad") and a C++ Test app ("DataTsBroadTest"), to test it. Actually, the Lib and the Test app are both compiled an a Debian Lenny. Now, i ...
0
votes
1answer
72 views

Problems installing MELT plug in

I'm trying to install MELT plug-in on my linux machine, and I encounter some errors. Following the readme file, I run: apt-get install gcc-4.7 g++-4.7 make texinfo texi2html autogen gawk apt-get ...
0
votes
1answer
413 views

Installation of QEMU, GCC for ARM in RHEL

We are setting up a lab which has the QEMU system to emulate an ARM processor and run assembly programs. The lab is currently setup with the host operating system as Ubuntu. We are migrating the lab ...
-1
votes
1answer
5k views

install latest gcc on rhel 6 x86_64

I have an RHEL 6 server with gcc version 4.4.7. I wanted to update the gcc version (I think the current one is 4.8). Yum update doesn't work. Also, SO answers for a similar question on CentOS does not ...
2
votes
0answers
140 views

Enabling support for AddressSanitizer in FreeBSD

The question essentially is how to compile a program that uses AddressSanitizer in FreeBSD. I use FreeBSD 10.0 (64-bit). I am trying to compile the following code with -fsanitize=address flag: int ...
2
votes
0answers
49 views

GCC cofigure error

When I'm trying to install GCC for SLED 11 SP3, the terminal show me this error: configure: error: cannot compute suffix of object files: cannot compile. Before to intall GCC, I installed the GMP ...
2
votes
0answers
319 views

sudo apt-get install g++-4.8-multilib not working on Mint?

I've got the latest version of Linux Mint 16 (64 bit) and in Netbeans I am compiling a project in 32 bit mode. I get the error that I am missing bits/config.h. I think this is because I am in 32-bit ...
2
votes
0answers
622 views

Compile parameters for MIPS based codesourcery toolchain?

I installed codesourcery cross compile toolchain for mips32 architecture on my WIN 7 machince. I want to first compile a simple 'factorial' binary for my router which is based on MIPS32. From little ...
2
votes
0answers
379 views

Error cross compiling linux kernel using buildroot

I am trying to build a kernel bt in cross compiling the kernel when I ran following command make CROSS_COMPILE=i686-linux- ARCH=x86 I got the following error: UCLIB_EXTRA_CFLAGS="" \ ...
1
vote
0answers
65 views

How can I install gcc-4.2 g++-4.2 on Linux Mint 17 with gcc-4.8 already installed?

I need an older version of gcc (specifically 4.2) alongside current gcc (4.8) on Linux Mint 17. Default Mint repositories can't find needed package: sudo aptitude install gcc-4.2 No candidate version ...
1
vote
0answers
168 views

Getting “cannot open shared object file: No such file or directory” error while run time

I have successfully compiled the file but now I am getting following errors export LD_LIBRARY_PATH=/opt/mcr/v717/sys/java/jre/glnxa64/jre/lib/amd64/server/:D_LIBRARY_PATH ./invoke ./invoke: error ...
1
vote
0answers
153 views

-fstack-protector-strong not supported by compiler gcc 4.8.3

On Fedora 20, I need to install a linux driver for a particular PCI express serial port card which is given by the manufaturer. In order to do this, I have to compile the source code of the driver. ...
1
vote
0answers
183 views

Building HDF5 with GCC 4.7 and OpenMPI

I am trying to install hdf5 with GCC 4.7 from binary, because I do not have root permissions, using following script on a machine using CentOS release 5.6(AMD64bit): module purge module unload ...
1
vote
0answers
162 views

Install gcc into x86_64-linux-gnu

I'm trying to compile and install gcc-4.9.0 on my Debian system, and in particular I want the new version to overwrite an old version of libstdc++.so.6 in /usr/lib/x86_64-linux-gnu that came as ...
1
vote
0answers
252 views

Gcc configuration error

I am trying to build GNU toolchain for OpenRISC by following the guide given at http://openrisc.net/toolchain-build.html#_stage_1_gcc on Fedora Virtual Box Image. I am getting error saying ...
1
vote
0answers
402 views

Cross-compiling OpenSSH for Android

I'm working on compiling OpenSSH for Android based on this answer at Stack Overflow. Here's what I've done so far: Building on Ubuntu 14.04 amd64. apt-get install build-essential ...
1
vote
0answers
76 views

how to install gcc4.8 in netbsd 6.1.3?

I did a "make install" for lang/gcc48 in pkgsrc. It did built ok. However, when I do gcc --versions, the default gcc 4.5.3 is displayed. What steps do I need to do after the build?
1
vote
0answers
456 views

Problem with configure - cannot find -lgcc_s

I want install Argos 0.5 to Debian 3.12.6-2 (2013-12-29) x86_64 GNU/Linux. I had to install gcc 3.4 because Argos call for it. Now I have gcc 3.4 and gcc 4.8.2-2 too. Problem is that ./configure ...
1
vote
0answers
74 views

Stanford's StanfordCPPLib on Linux

I'm using SUSE Linux 13.1 and self studying Stanford's CS 106B course. Here I have found the following zip file, cs106b-hw2-ngrams-starter-files.zip, and downloaded. Now questions This libs are for ...
1
vote
0answers
695 views

How to compile gcc toolchain with special sysroot correctly?

I try to compile a new gcc, including binutils and glibc. Since I can not be root, I want to install it all in ~/local. I set these variables: PREFIX=~/local && export PREFIX ...
1
vote
0answers
220 views

How to install gcc 4-8 on #! Waldorf 64-bit?

I would like to install and use g++ 4-8 compiler. It supports various C++11 features, and I am willing to look into them and use them. Also, as I came here from Windows, my previous files also used ...
1
vote
0answers
111 views

ices-cc (libvorbis) linking fails on Ubuntu 13.04 - lgcc_s not found

I'm trying to compile compile ices-cc into a set of static files on Ubuntu Server 13.04. I use the automatic Centova's build-ices.sh script and use the following command: ./buildices.sh ...
1
vote
0answers
39 views

GNU toolchains against GCC SVN?

Is there anything like CodeSourcery which provides prebuilt binaries for arm toolchains built against gcc-svn. http://elinux.org/Toolchains#Prebuilt_toolchains Otherwise, a working instruction for ...
0
votes
0answers
16 views

default llvm toolchain issue on Mac

Recently I have been using Mac 10.10; but I find that the compilation toolchain is a bit odd to me. It's known to us that on recent Mac OS versions the default gcc is a faked one that is based on ...
0
votes
0answers
28 views

Cannot connect to OpenSSH when compiled with the gcc option: -finstrument-functions

I want to make custom traces of sshd. So, I have added the source file ptrace.c from here. This file enables to trace function calls (but this is not the subject of my question). So, I have modified ...
0
votes
0answers
32 views

Implications of including GPL software in a distribution?

It's well known that the FreeBSD project is actively trying to route out all traces of GPL'ed software in favor of more permissive-licensed software replacements.[1] Their reasons are ambitious, ...
0
votes
0answers
91 views

How to change CFLAGS option -march from native to corei7?

Is it possible to change the CFLAGS -march=native to -march=corei7? Would I have to recompile the whole system once this change is made? I would like to setup distcc and I read that march cannot be ...
0
votes
0answers
167 views

How to install older version of GCC for Mex compatibility with Matlab on OpenSUSE?

Matlab MEX is compatible just with GCC version 4.7.X, however OpenSUSE 13.1 comes with GCC 4.8.1, when I compile a Matlab MEX file a warning comes out: Warning: You are using gcc version '4.8.1'. The ...
0
votes
0answers
86 views

Why will the C++ Library not disable, GCC

I've been up all night trying to get this to work. I got the second to latest gcc and latest binutils and am attempting to create a cross compiler on a debian system. For some reason, GCC won't ...
0
votes
0answers
48 views

Not compiled gcc, failed configure-target-libquadmath

Trying to compiling gcc-4.8.2 after downloading: ../gcc-4.5.2/configure \ --target=$LFS_TGT --prefix=/tools \ --disable-nls --disable-shared --disable-multilib \ --disable-decimal-float ...
0
votes
0answers
27 views

How do I install GCC and make on a mac without administrator access or using Xcode?

I'd like to install gcc and make on my Macbook Air, but I don't have root access on it. I found this link through searching on google, but I have no idea how to set up the prefix's so that the actual ...
0
votes
0answers
78 views

C Preprocessor (cpp) and cc1 issue

I've been trying to fix a problem related with cross (kernel) compilation which as given the following message: gcc: error trying to exec 'cc1': execvp: No such file or directory I found that this ...
0
votes
0answers
242 views

gdb-multiarch command not found

I have installed QEMU in RHEL for running the assembly programs in ARM. I have successfully installed QEMU and ARM. However, for debugging we are thinking to use GDB. I want to install the ...
0
votes
0answers
303 views

How to install cpp in RHEL 6.3?

I want to install gcc in RHEL 6.3, but it has cpp dependencies. So I go to cpp rpm download page, but it has no rpm for 6.3 version: Is there any other way to install cpp in RHEL 6.3?
0
votes
0answers
1k views

How to set library searching path using environment variable in compile-time

-I option set header file searching path for gcc/g++, and CPLUS_INCLUDE_PATH/CPATH append the searching path list. Then what about libs? It seems that LD_LIBRARY_PATH is just a path list for ...