refers to the wired style to connect a bunch computers or a way to connect to such network. This tag is for both software and hardware part of this issue.

learn more… | top users | synonyms

1
vote
0answers
1k views

Why does eth0 only go up sometimes on boot?

I just installed Arch with Archboot. On boot, there's about 50% change of eth0 to go up. If it doesn't I'll have to reboot. What could cause this? If it goes up, dmesg contains: [ 7.9...] IPv6: ...
1
vote
0answers
417 views

Wlan0 Static Ip bridge

EDIT: Even taking br0 out, still cannot get a static IP connection. I had the following /etc/network/interfaces configuration and it was working auto lo iface lo inet loopback auto eth0 iface etho ...
1
vote
0answers
65 views

Would it be possible to not have the network link cycled on loading the kernel module?

Using some cheap hardware in a thin-client setup we use a diskless PXE booting a small Linux kernel. Currently, it takes a quite some time to boot it fully up and we're looking into some optimizations ...
1
vote
0answers
908 views

Linux Mint: LAN “Cable not connected”, despite it is

I've just installed Linux Mint 13, 64 bit (from the CD of "c't kompakt Linux", if this matters), and came across a very unexpected problem, for which I've not found a solution with Google or searching ...
1
vote
0answers
340 views

Configuring multiple static IP addresses for a disk image

Using Ubuntu 10.04 I'm using Clonezilla to create and install a customized image. I'd like to be able to set up multiple static IP addresses. For example, I'd like the first interface to have the IP ...
1
vote
1answer
682 views

Network fail on FreeBSD: Ping to router fails, but router believes computer is connected

I have a TP-Link TL-WN851N wireless adapter, which is based on an Atheros device. When I attempt to connect to my WPA2 wireless network, ifconfig wlan0 tells me that the connection is 'associated'. My ...
1
vote
1answer
851 views

Setting up Intel Giga PHY I217V on Debian 2.6.32 kernel

Trying to getting the Intel integrated network card driver (Giga PHY Intel I217V) working on Debian (kernel 2.6.32) but I'm having issues. I've downloaded the driver from the Intel website and ...
0
votes
3answers
344 views

Data transfer between Ubuntu and CentOS [duplicate]

How do I transfer data between Ubuntu and CentOS using LAN cable, in the same network? I tried installing Samba which did not go well in CentOS.
0
votes
2answers
539 views

Access remote server after running ifdown eth0

I had a problem: Could not retrieve mirrorlist http://mirrorlist.centos.org/release=6&arch=x86_64&repo=os error was 14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'" Error: ...
0
votes
3answers
176 views

How do I configure my Linux computer to provide Internet to a FreeBSD computer via Ethernet port?

I have FreeBSD computer to which I want to provide with an Internet connection via the Ethernet port. I bought a single board computer (SBC Wangboard DUAL) onto which I have installed Ubuntu. I ...
0
votes
3answers
8k views

eth0: ERROR while getting interface flags: No such device [duplicate]

I set up CentOS yet. it's no network connection. eth0 is not device list. I take a message network is unreachable while ping 192.168.0.1 the screen shot of device list How can I do reachable ...
0
votes
2answers
2k views

How to check if ARP is enabled or not

I have enabled the arp support on my dell based server running linux on it. I wanted to check that if arptables are enabled or not. Could anyone tell me how do I check the same? Is it enough to run ...
0
votes
1answer
21 views

Can't find eth0 in my ifconfig output

I have a old desktop with ASUS P5KPL AM/PS board with intel core2Duo processor. I have installed kali linux on it when I run ifconfig in root shell all I can see l0which is my loopback address and ...
0
votes
1answer
30 views

Boot blocked during 1min30sec because /etc/network/interfaces

With the following config (see config file below): if only ethernet cable is connected, it 100% works: I can quickly SSH the computer via eth0's IP, if both ethernet cable and wifi dongle are ...
0
votes
1answer
15 views

Error while trying to connect 2 pcs in lan

I'm trying to connect two PCs in local network and am having difficulties: not that information you need, so I will put some, if I can put it need more: pc1: OS GNU/Linux Mageia pc2: OS GNU/Linux ...
0
votes
1answer
45 views

USB3 to Ethernet stops after sometimes

This is my first post to this website. I this that my question is related to serverfault cause it is related to ethernet communication issue. If you disagree please let me know what is the appropriate ...
0
votes
1answer
443 views

FreeBSD Ethernet NIC driver not recognized

Intel Motherboard GA-H61N-D2V $ pciconf -l -v re0@pci0:1:0:0: class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x06 hdr=0x00 vendor = 'Realtek Semiconductor' device = 'Gigabit ...
0
votes
1answer
34 views

Itcpdump output - why is it showing an Ethernet status?

tcpdump -i mlan0 -n tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on mlan0, link-type EN10MB (Ethernet), capture size 262144 bytes Why is this ...
0
votes
1answer
189 views

Route a local connection via an ethernet link in QNX

I am currently facing a challenge in QNX, where I have 2 Network Interfaces - viz. one Network port from PCIe Ethernet Expansion card (wm0) and other from the normal Ethernet port (en0). I have ...
0
votes
1answer
709 views

Ho to bridge wlan0 in AP mode and eth0 so that eth0 is static and wlan0 uses DHCP?

I have a router that provides internet access. Connected to this router is a desktop PC that has working eth0 (static IP address) and wlan0. Also connected to the router is a laptop which I use to ...
0
votes
0answers
30 views

Realtek RTL8111 Network card not working on Ubuntu 14.04

I'm trying to install an Ethernet Card into my Ubuntu 14.04 desktop computer. Here is my lspci output (First one is my new ethernet card): 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. ...
0
votes
0answers
35 views

Ubuntu - Ethernet Card Driver Installation: asm/linkage.h file not found

I'm trying to install an Ethernet Card into my ubuntu 14.04 desktop computer. Here is my lspci output (Second one is my new ethernet card): 03:00.0 Ethernet controller: Marvell Technology Group Ltd. ...
0
votes
1answer
30 views

Can't connect to ethernet Linux Mint 17.1 Xfce

I have just installed Linux Mint on my netbook (HP Compac Mini 700). I have managed to make it connect to WiFi, downloading driver, but it won't connect via cable. Strangely enough, the other day, ...
0
votes
0answers
6 views

Which technologies can be used to build up communication between MIPS linux and Windows?

We have an embedded Linux system running on a MIPS processor board. This system is used to control and to poll some other hardware, and to consolidate all the measurement data in one place. Now, we ...
0
votes
0answers
8 views

Ethernet adapter Not recognized at all (Steam Os)

I have having an issue where my Ethernet adapter(realtek TL8118AS-CG0) in my Samsung np365ec(amd a8-4500m Quad core 4gb of RAM)is not recognized at all. The wireless card works fine but is only ...
0
votes
0answers
17 views

Is it possible to control and limit the transfer speed of a Ethernet TCP/IP via command?

I'm suffering from some "low data transfer" from a device running Embedded Linux to my computer. I'm aware that it has some hardware limitations that could be strangling the speed (e.g. 372 Mhz ...
0
votes
0answers
8 views

I wish to move SBC flash image to new board and maintain network interface indexing

I wrote a small php application on a SBC. I created a disk image from the CF card. When I write the image to a new CF and install on a new SBC the interface index numbers (I hope I am stating that ...
0
votes
1answer
52 views

Problems Setting Up DHCP Server On CentOS 6

I have been trying to set up a DHCP server on CentOS 6 running on an Intel NUC i7. I have installed dhcpd and am using the example dhcpd.conf subnet 192.168.1.0 netmask 255.255.255.0 { option ...
0
votes
0answers
19 views

in realtek 8139cp driver code, where does the start_xmit function triggers the chip?

Hope somebody could give me an explanation. I was looking at http://lxr.free-electrons.com/source/drivers/net/ethernet/realtek/8139cp.c#L731 and found in cp_start_xmit(..) function, there are all ...
0
votes
1answer
75 views

How to make virtual interface ping to a host in the network

I crated a virtual interface as indicated in this link. sudo modprobe dummy sudo ip link set name eth10 dev dummy0 sudo ifconfig eth10 up sudo ifconfig eth10 192.168.1.150 now if I want to make a ...
0
votes
0answers
30 views

wireless and wired both not working at the same time

On a Raspberry Pi, running Raspberry OS, I have bridged eth0 and wlan0 in order to share the internet connection of Ethernet using wifi. both the interfaces are configured and both are up.but after ...
0
votes
0answers
24 views

POE Connection Failure

I have 2 POE ports which are on different NICs. When I connect them together the ports' Ethernet does not come up. In other words, the associated "port status" register of those ports should turn to ...
0
votes
1answer
138 views

Debian wired connection static IP wont connect

I've installed Debian with xfce and did some configuring by installing themes, configuring xfce, installing and uninstalling software; the usual. Anyway, after a reboot I can't connect to the ...
0
votes
0answers
49 views

kernel panic - get log

My system keeps hanging every several hours. I think the problem is somehow connected with network, because plugging ethernet cable eliminates the problem (even if ethernet is used locally only). If I ...
0
votes
0answers
68 views

Ethernet only works when PC booted with cable plugged in

My Ethernet adapter is Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06) and I'm using x64 Arch Linux, kernel 3.18.4. Connections are managed using ...
0
votes
1answer
467 views

NetworkManager does not detect when cable is connected or disconnected

On my Fedora 21 64bit Gnome 3.14.3 install, I have noticed that the NeworkManager always connects to the wired connection, even if the cable is not connected: However, the driver (or something) ...
0
votes
1answer
108 views

Debian server makes internet connection drop

I have setup a small home server / NAS running Debian 7. The server is connected directly to the router with a static IP set in the router's control panel. There are no port forwarding rules set for ...
0
votes
0answers
16 views

What Linux app will show me how much internet bandwidth each process is using? [duplicate]

Linuxmint 13 Cinnamon 32 bit with ver. 16 backports ethernet (eth0) + pppoe (ppp0) + FTTH (fiber optic to the home) no wifi What program(s) can I use to tell me how much up/down internet traffic ...
0
votes
0answers
83 views

Unable to connect the Ubuntu EC2 instance to VPC LAN on AWS using secondary NIC adapter?

Infrastructure setup: VPC is created with 192.168.254.0/24 netwok Private subnet within VPC (Virtual Private Cloud) is created with 192.168.254.0/25 network Public subnet within the VPC is created ...
0
votes
1answer
107 views

trouble bridging tap0 and tap1

I have a GNS3 router that is connected to tap1 in my host. On the other hand, I have an user application connected to tap0 running locally in my host. I can ping both the router and my application. ...
0
votes
0answers
108 views

connected to ethernet and wifi, “route” browser's connection to wifi only

Sometimes, in my company, I have to work with a different network (through ethernet) that has no internet. On the other hand, I do have access to out Wifi, which has internet. Since I have to spend a ...
0
votes
0answers
64 views

How can I compile and run a program designed for an older kernel version (2.6) in a newer kernel (3.16)?

I'm trying to run a driver for a network card, but it only supports kernels up to 2.6.32. I need to be able to use this piece of hardware to connect to the Internet. The device I'm using is "VIA ...
0
votes
0answers
109 views

Why on my Linux PPPoE connection displays sometimes authentication failure?

Here is my log: Oct 18 09:51:52 -desktop pppd[2764]: Plugin rp-pppoe.so loaded. Oct 18 09:51:52 -desktop pppd[2766]: pppd 2.4.5 started by root, uid 0 Oct 18 09:51:52 -desktop pppd[2766]: PPP session ...
0
votes
2answers
333 views

Wifi and ethernet unstable (takes many tries to connect, disconnects)

Both my WiFi connection and my Ethernet connection have recently (I'd say about a week ago) become unstable, without any change in the configs. Now in order to connect I've to try several times and ...
0
votes
0answers
70 views

Intel Centrino Wirelsess-N 1030 not getting connected on generic mode in ubuntu 14.04

I upgraded Ubuntu from 12.04 to 14.04. After upgrading neither WLAN and ethernet work and also does not work in recovery mode (enable networking) or root shell. When booting the previous version ...
0
votes
0answers
1k views

eth0 and wlan0 set-up problem in Linux Mint

I had a perfectly working wi-fi connection on my Mint-KDE PC. Recently, I brought a Synology NAS and after some research figured that I need to set my eth0 to static IP for it to connect to NAS via ...
0
votes
1answer
3k views

Linux Mint 17, Wifi Slow and Drops Connection, No Ethernet Connection

On a fresh install and updated Linux Mint 17 XFCE, the system cannot maintain an internet connection through wifi, and is unable to connect at all through ethernet. Wifi will work somewhat slowly for ...
0
votes
0answers
148 views

Cannot connect to wired ethernet after hibernate

When I am at home I use wired connection on my laptop and it works fine. Then I put it to hibernate with sudo pm-hibernate and start it up again when I am work. I am not able to connect to internet ...
0
votes
0answers
239 views

How to make linux see my internet connection?

I'm sort of booting off of a Mint 17 LiveCD (the situation is described here: How can i make my pc boot back into windows?) and the network does not work. It's wired if it matter. I've also tried to ...
0
votes
1answer
731 views

wired ethernet interface not detected by lshw, lspci

I have a Toshiba Satellite PSAG8U-04001W. No eth* interface shows up on ifconfig. $ ifconfig -a lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 ...