emerge is the definitive command-line interface to the Portage system. It is primarily used for installing packages, and can automatically handle any dependencies that the desired package has. There are at least two distributions which widely use this tool: gentoo and funtoo.

learn more… | top users | synonyms

0
votes
0answers
59 views

emerge scheduled 2 versions of the same package to build - causing conflicts

I'm trying to update all my packages, so I ran: emerge -aUDU --with-bdeps=y --verbose-conflicts @world and I found a few package conflicts. Interestingly enough though, is that it has scheduled two ...
1
vote
1answer
55 views

How do I get Portage to always select to install and upgrade to the latest available version of selected software?

I would like to get Portage to always install the latest available version of selected software (i.e., software specified when running emerge, along with all relevant dependencies that also need to be ...
1
vote
1answer
135 views

An issue that use Emerge to install package

I'm not too much experienced within Gentoo portage, When I tried to install Nodejs # emerge --ask monit nginx nodejs into my gentoo and i get an error message like: [ebuild N ] net-libs/...
2
votes
2answers
108 views

Gentoo won't update Chromium due to conflict with libxml, icu USE flag is globally set on make.conf, qt-webkit is not part of the conflict

I am running Gentoo Hardened using kernel version 4.1.7-hardened-r1. When I first set up my system I was able to emerge Chromium without a hitch. However, I recently issued emerge --sync followed by a ...
0
votes
0answers
100 views

How to install ibus-cangjie (on Gentoo KDE)?

Simply, I want to type CangJie (倉頡) on my Gentoo KDE. CangJie is a very common input method to type Chinese. (Majorly in Hong Kong may be.) When I wanted to install CangJie input method, I found ...
1
vote
1answer
237 views

How do I apply multiple profiles at once on Gentoo?

I am installing KDE on a Gentoo Linux Hardened system. The official Gentoo wiki says the recommended way is to apply the KDE desktop profile, issue emerge -NDu --with-bdeps=y @world, and then install ...
3
votes
1answer
120 views

Fatal mistake: Uninstalled sys-devel/binutils - emerge don't work anymore

I cleaned up my system 3 weeks ago and made a fatal mistake. Well, I don't really know why, but I uninstalled sys-devel/binutils. After I recognized the mistake I tried re-emerge, but it doesn't work....
1
vote
1answer
32 views

How to download nouveau source in selected directory with Portage?

I would like to download Nouveau source code. There is an x11-drivers/xf86-video-nouveau ebuild, but I don't want to install it(downloading is okay though). Let's say that I want to install it into ~/...
3
votes
1answer
330 views

How to stop emerge showing “unnecessary” blockages

I am usually updating my ~amd64 Gentoo system using emerge -avNuD --backtrack=100 @world. I do however often get the following type of blockages. sys-libs/ncurses:5 (sys-libs/ncurses-6.0:5/6::...
0
votes
1answer
80 views

Can't install MySQL client libraries on Gentoo

I'm new in Gentoo. I'm trying get the mysql2 gem installed. But it's stuck. I found out that I need MySQL client libraries. I tried: emerge dev-db/mysql:minimal * IMPORTANT: 2 news items need ...
0
votes
1answer
62 views

Using package.env for phase hooks

Following this answer I've set up a simple file /etc/portage/env/echo.conf: post_pkg_postinst() { echo "updating $P to $PV" } with the line sys-apps/util-linux echo.conf in /etc/portage/...
4
votes
2answers
1k views

What does “WHIRLPOOL size ;-)” mean?

Often when installing or upgrading packages the following appears in the log: * ….tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ... What does this mean and what does the emoticon signify? ;-)
2
votes
1answer
610 views

Python now thinks arguments are files: Broken emerge, pip, livestreamer and most tools using Python

For these commands (in both bash and fish): sudo emerge eix emerge eix I get this error: usage: emerge [-h] [--version] [input [input ...]] emerge: error: argument input: can't open 'eix': [Errno ...
4
votes
1answer
931 views

Why does Chromium use so much disk space on Gentoo Linux?

I am a newbie on Linux, and I have chosen Gentoo for my Linux distribution. I installed it in VirtualBox for practice purposes only, so I just gave it 10GB of disk space. Yesterday when I tried to ...
0
votes
1answer
268 views

Gentoo CPU_FLAGS_X86 doesn't work

I havn't updated my system for few months and found i have to add new option to my make.conf. Ok, so now i have CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ...
0
votes
1answer
39 views

Flag change log in gentoo

I was wondering if there is any tool that shows changed flags of recently emerged packages? I missed to use --ask -v while using emerge and I lost the verbose details. I have checked the /var/log/...
3
votes
2answers
619 views

Installl a specific version of a portage overlay package

I need to install an older version of x11-libs/bamf package , as you can see below there are different versions available I want to install 0.5.0[2], but it always go to 9999 version using "emerge ...
1
vote
1answer
2k views

How to remove set from portage

I was dealing with a lot of blocks of Qt5. [blocks B ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102) [blocks B ] <dev-qt/qtsql-4.8.6:4 ("...
8
votes
2answers
2k views

Packages to rebuild after upgrading gcc on gentoo systems

Which packages should be rebuilt after upgrading gcc on a gentoo system? Is it sufficient to run # emerge -a --oneshot `equery depends gcc |awk '{print " ="$1}'` as suggested similar for perl in ...
3
votes
1answer
83 views

How to summarize error messages of an emerge run?

An update on a gentoo system with # emerge --update --newuse --deep --keep-going @world creates lots of text on the console. Error messages and warnings appear between less important informative ...
1
vote
1answer
39 views

Forwardticks in example command in `man emerge`: local misconfiguration or typo?

In Manpage of EMERGE it is stated: To find files that need to be updated in /etc, type find /etc -iname ´._cfg????_´* Taking a closer look at it (copy-pasted from terminal -- not from the online ...
8
votes
3answers
5k views

Portage on Gentoo how to view available software versions?

I would like to install program foo using emerge on a Gentoo system; so I simply use emerge foo to install and portage selects the most current version of that software that's in its repository. If I ...
0
votes
1answer
269 views

How to avoid emerge recalculating dependencies after adding required keywords/uses?

While emerge --autounmask-writes followed by a etc-update basically automates adding additional keywords and use flags, running emerge afterwards (without any other modifications) will again calculate ...
4
votes
2answers
2k views

Emerge on Gentoo fails with “Multiple package instances within a single package slot have been pulled … in”. How can I resolve this?

I'm trying to install Google Chrome on my recent Gentoo box. But emerge is throwing some errors that are way over my head. I genuinely don't know what the problem even is. !!! Multiple package ...
2
votes
1answer
370 views

What does the (-) in 'abi_x86_32(-)' signify in an ebuild?

In the process of updating my Gentoo system, I've run into something I don't understand. Wine is requesting app-emulation/emul-linux-x86-soundlibs, which in turn requests >=media-plugins/alsaequal-...
0
votes
0answers
207 views

Emerge freezes on raspberry pi without error message

I am trying to install raspberrypi-userland to my gentoo system with the command emerge --ask raspberrypi-userland on my raspberry pi. I am well aware that without cross-compile environment this ...
2
votes
1answer
106 views

Is it safe to `emerge -uavDN @world` while working?

In a related question, a few answers ("Yes", "...no problem", "typically... no problem") verify that it is safe to perform emerge -uavDN @world while working. Is it really so (for Funtoo/Gentoo)?
1
vote
1answer
62 views

How to differ between build-dependencies and usage-dependencies?

Some dependencies of packages are only required for compilation, while others are required for actual usage. As an example, I happen to know net-misc/unison does require dev-lang/ocaml only for ...
0
votes
1answer
811 views

econf fails when installing pth

I'm just starting out with Gentoo and I'm getting a bit stuck installing programs with Portage. It's wonderful and automatic except when it isn't. Many of the programs I try to install (git, gedit, ...
23
votes
4answers
14k views

Using ABI_X86 in Gentoo

For one reason or another (I've been busy, I guess), it's been months since I've updated my Gentoo system. And, as you can imagine, this means there's a lot of packages (and USE changes) I need to go ...
0
votes
0answers
106 views

Gentoo - problem with setting services up (KDE 4.10)

I have a problem with Gentoo. I have installed Gentoo in VirtualBox and it works perfectly. I have learned a lot about Gentoo, how to compile everything, how to set Gentoo for my needs. But now I ...
1
vote
2answers
368 views

Is there a way to prevent emerge --sync from deleting files from the portage tree?

Although PORTAGE_RSYNC_OPTS, a make.conf option, allows one to change the rsync options but removing --delete from it causes emerge to fail. I think with it remarking about missing md5-cache entries ...
1
vote
1answer
747 views

Gentoo how to compile LVM statically linked?

A Gentoo install still in the livecd stage (unable to boot so far) fails to emerge LVM statically. I need a statically compiled lvm in order to use it in my initrd. My make.conf: CFLAGS="-O2 -march=...
3
votes
1answer
1k views

How to disable portage LICENSE checks

Whenever I install a package with an EULA, portage asks me to add it to package.license: The following license changes are necessary to proceed: (see "package.license" in the portage(5) man page for ...
2
votes
1answer
727 views

package.use equivalent for VIDEO_CARDS, ABI_X86, etc

You can configure USE flags per package in /etc/portage/package.use. Is there an equivalent for similar flags like ABI_X86 or VIDEO_CARDS?
3
votes
1answer
431 views

How can I download all the software ( funtoo git repository) for offline use of funtoo, similiar to apt-mirror

I am working on a ship so once at sea I have no internet. The idea is to clone the complete git repository so that I can still install software when offine. I am using apt-mirror with debian which ...
3
votes
2answers
422 views

Gentoo: How to update from one portage only?

I have an overlay alone with the default portage. Basically, I want to emerge only the updates from the main portage when I run emerge world -unD, and emerge the extra packages from the overlay ...
3
votes
3answers
1k views

Present USE flags upon emerging a package in gentoo

I was wondering if there are any tools to present the compile time options/ flags of a package in Gentoo when emerging. I am referring to something like this
12
votes
4answers
11k views

Safely uninstall a package in Gentoo

I wanted to uninstall a specific package in Gentoo and browsed through the emerge man page. I found the --unmerge option: WARNING: This action can remove important packages! Removes all ...
8
votes
2answers
5k views

On Gentoo, how do I rebuild all packages depended on some other package?

I made mistake and changed perl non-threaded version to threaded by unmerge first, change USE flags to include ithreads and emerge perl again. Now most packages depending on perl are broken. How do I ...
6
votes
2answers
876 views

On Gentoo is there a way to find a list of installed packages which doesn't have other packages depended on them?

On Gentoo, is there a way to find a list of installed packages which doesn't have other packages depended on them (so called leaf packages)? Or, is there analog of pkg-orphan FreeBSD utility?
6
votes
1answer
3k views

On Gentoo how do I find list of packages installed after some specific date?

I have Gentoo VM that I use to test different puppet recipes and I frequently need to remove packages to bring it to clean initial state. While I could do this by hand when there are only few packages ...
9
votes
4answers
3k views

How to install multiple versions of the same package in Gentoo?

I would like to install two (or more) versions of the same packages on my Gentoo system. I know for sure there won't be any file clash, since there very few files installed and each of them is named ...