Additional software that some software requires to function

learn more… | top users | synonyms

2
votes
2answers
2k views

Why does yum continue to complain about a missing dependency that is already installed?

I have a self-created rpm for mapserver 6.2.1 that I want to support Oracle, but I am having a lot of difficulties getting it all to work. I have installed the ...
1
vote
2answers
304 views

Lots of unmet dependencies while updating Python

It was suggested that I uninstall and reinstall Python, so I deleted every directed labeled python until 'which python' and 'which python3.4' didn't show anything. Then I did apt-get remove python ...
3
votes
1answer
566 views

Make RPM Satisfy Dependency Requirements of Other Installed Packages

So, I am installing a java app that I wrote which uses jnetpcap. This requires libpcap of at least v1.0.0. My CentOS 5.8 only has libpcap 0.9.4, which is required by other installed packages. I've ...
2
votes
1answer
105 views

Cross-compiling Slackware: is the build order listed anywhere?

I'm building a Slackware system from source and hitting a dependency wall here. (Before you ask: no, I'm not trying to "make it faster"; I'm building against a different C library.) Getting a ...
2
votes
1answer
297 views

How can I list all the dependencies necessary to install PHP-Soap?

I have a server running Centos 5.10 with no internet access that I control remotely on which I'd like to install PHP-Soap. I also have an identical box in the office which is a clone of the remote ...
2
votes
1answer
1k views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
2
votes
1answer
485 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
1
vote
1answer
594 views

How can i fix the following gmp library dependency error while trying to install Charm?

I am trying to install Charm crypto python framework in ubuntu 11.04 with python 2.7. Requirements say that i should have gmp installed 5.*. I have successfully installed gmp lib and i have run all ...
1
vote
1answer
647 views

Resolving circular dependency hell for libX11 and libXi

I'm trying to install X11 from source. Source files from some repository: libX11-1.6.0.tar.gz libXi-1.7.1.901.tar.gz libX11-1.6.0 paulk@node005:libX11-1.6.0$ ./configure --prefix=$HOME/software ...
0
votes
1answer
123 views

cannot install wine on 17.1 mint: unmet dependencies, broken packages

i have a Linux Mint 17.1 Rebecca - Release amd64 20141126]/ trusty contrib main non-free installed, and the apt-get install wine wont do the trick. it returns the following: Some packages could not ...
0
votes
1answer
94 views

Dependencies problems installing VNC Server in Red Hat Enterprise Linux Server release 6.5

I'm triying to install VNC Server in a Red Hat Enterprise Linux Server release 6.5. I have the .rpm of VNC Server, but it has a depedency with xterm, which I have the .rpm too. Trying to install xterm ...
0
votes
1answer
32 views

messed up system after offline package installation for WLAN driver

I'm running Linux Mint 17.1 on my old desktop pc. Since I moved, I had no internet connection, but could use the WLAN of my neighbors. For that, I had to install an old FRITZ! USB WLAN driver. I did ...
0
votes
1answer
32 views

rpm -R verses zypper info --requires

Consider the following: root# rpm -qR foobar rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadIsLzma) <= 4.4.6-1 root# zypper info --requires ...
0
votes
1answer
842 views

cannot install locales in Debian 7 due to unmet dependencies

So instead of including the wheezy-backport in my sources.list I had the bright idea of adding jessie directly. Realising my mistake I cut out of and apt-get update/upgrade midway through and then ...
0
votes
1answer
61 views

libmpg123 bugging up yum

I had to manually install some dependencies in my fumbling attempts to get netflix working yesterday with pipelight, and ultimately failed. I uninstalled everything I installed during that process, ...
0
votes
1answer
158 views

How to avoid emerge recalculating dependencies after adding required keywords/uses?

While emerge --autounmask-writes followed by a etc-update basically automates adding additional keywords and use flags, running emerge afterwards (without any other modifications) will again calculate ...
2
votes
0answers
16 views

What is the systemd equvalent to sysvinit 'X-Start-Before'?

Quoted from https://wiki.debian.org/LSBInitScripts. X-Start-Before: boot_facility_1 [boot_facility_2...] X-Stop-After: boot_facility_1 [boot_facility_2...] provide reverse dependencies, ...
2
votes
0answers
235 views

Unmet dependency after linux mint distribution update

I have recently updated to Linux mint rebecca. I am getting unmet dependencies for apt-get when I am trying to apt-get install a package named monodevelop-nunit monodoc-nunit-manual then this ...
1
vote
0answers
33 views

About Dependencies

In the absence of internet connection for the present, I am trying to use apt-offline. When I execute the order in terminal I get "ERROR: FATAL: Something is wrong with the apt system." I have been ...
1
vote
0answers
109 views

Missing dependencies in VMware install?

I'm in the process of setting up my HP thin client with Fedora 20 (already done) and using VMware view client on it. I've completed most if not the whole installation except the condition that the ...
1
vote
0answers
136 views

Tor install on CentOS server

I have followed the instructions provided here: https://www.torproject.org/docs/rpms.html.en However, when running yum install tor, i get the following dependency error: Error: Package: ...
1
vote
0answers
87 views

How to combine deb dependencies into main package?

I want to include deb-dependencies with main deb-package. Consider 1 deb package which have 19 deb dependencies, so I have to install all packages by dpkg -i *.deb. If all 19 dependencies can be ...
1
vote
0answers
127 views

Linux dependencies between packages

I have following error: You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: linux-kernel-generic : Depends: linux-image-3.11.0-12-generic but ...
1
vote
0answers
450 views

Make and apt-get Have Stopped Working

So I downloaded the non-free broadcom driver(b44) for my debian install, however when I try to make it I get the following error: make make -C /lib/modules/2.6.32-5-amd64/build ...
1
vote
0answers
110 views

Installing rpm & dependencies

I am trying to install an rpm, namely the Oracle 10g database for CentOS 6 for testing an app. The problem is that the machine the OS is installed on does not have access to the internet and there ...
1
vote
0answers
484 views

Mon Configuration

I am trying to get the hang of the mon daemon, in linux. I was wondering, can you set up dependencies in mod, if so how. As far as I understand it the script below will run ping then http regardless. ...
1
vote
0answers
330 views

Dependencies between shared libraries in the same Debian packages

Suppose I want to create a package with multiple shared libraries - call it libfoo, which contains liba.so.1 and libb.so.1. Now, say liba.so.1 uses a symbol from libb.so.1. If I compile like this, ...
0
votes
0answers
57 views

Unmet dependencies when installing mtrack

I'm trying to install mtrack on Ubuntu 14.04 on my macbook pro: sudo apt-get install xserver-xorg-input-mtrack But I get unmet dependencies: The following packages have unmet dependencies. ...
0
votes
0answers
12 views

unmet dependencies for gir1.2-accountsservice-1.0 on Ubuntu 14.04.2

I'm trying to install a software package which depends on gir1.2-accountsservice-1.0. However, when I attempt to install gir1.2-accountsservice-1.0 I get the following message: sudo apt-get install ...
0
votes
0answers
29 views

How to uninstall gnome-bluetooth dependancies?

As you can see below, I installed (and then deleted) gnome-bluetooth on my Debian Xfce desktop. It's come with a lot of librairies and autoremove doesn't get rid of them. Is there an automatic way to ...
0
votes
0answers
42 views

Gpgpu-sim dependencies in centOS

I try to install gpgpu-sim in my CentOS 6, there are some dependencies need to be installed before I can compile gpgpu-sim successfully. the dependencies are as follows: GPGPU-Sim dependencies: ...
0
votes
0answers
534 views

install gstreamer1.0-libav (mainly libavcodec54) on debian wheezy

I need to install gstreamer1.0 libraries.. I found that they are in wheezy-backports. So I added wheezy-backports to sources.list updated try ton install and stuck on dependency problems: aptitude ...
0
votes
0answers
77 views

Lot of dependencies while uninstalling libimobiledevice2 library

I want to remove package libimobiledevice2 and install package libimobiledevice5. Unfortunately there is a problem: libimobiledevice2 has many odd dependencies. When I type: apt-get remove ...
0
votes
0answers
88 views

Problem while installing LibreOffice on Elementary OS

I'm having the following message when I try to install LibreOffice on Elementary OS 32 bits. I'm doing it on a ASUS Eee PC 900. Lendo listas de pacotes... Pronto Construindo árvore de dependências ...
0
votes
0answers
46 views

Installing grub2 pulls X11 as a dependency?

I've ended up with a rather strange issue after a broken install of vlc-nox on a headless server. I'm now trying to reinstall grub, using the command aptitude install grub2 but aptitude wants to ...
0
votes
0answers
27 views

Mac Firebreath plugin port to Linux (dependencies)

I have Firebreath plugin for Mac that I need to port to Linux. I am trying to find the replacement dependencies for the Linux version. Here is the dependencies I have in my cmake for Mac: ...
0
votes
0answers
1k views

Install CUDA 6.0 on Debian 7 via package manager

I am following the official installation guide for Ubuntu. I first installed the cuda-repo package (cuda-repo-ubuntu1304_6.0-37_amd64.deb), which adds the NVIDIA repository to apt. Then it gives when ...
0
votes
0answers
1k views

How to resolve broken packages when upgrading: from Ubuntu 13.10 to 14.04

I am having an issues upgrading to 14.04 (Trusty Tahr) from 13.10 (Saucy Salamander), where I get a message Could not calculate the upgrade, and I believe it is due to my unofficial software packages. ...
0
votes
0answers
42 views

install zziplib on Amazon Linux

We are trying to configure php4 on Amazon Linux 64bit using the command below: ./configure --enable-bcmath --with-bz2 --enable-calendar --with-curl --enable-dba --with-cdb --with-inifile ...
0
votes
0answers
386 views

Issues with Skype, ia32-libs and Qt apps in elementaryOS

I just installed elementaryOS Luna. After updating my system, drivers etc. I added the Canonical Partners and installed skype immediatly. This worked just fine, but when I wanted to install apps such ...