Additional software that some software requires to function

learn more… | top users | synonyms

0
votes
0answers
6 views

Could not perform immediate configuration on 'multiarch-support'

I am not sure what I was thinking when I accidently deleted my /etc/dpkg/ folder. While I was fixing that, I tried many things and that made things worst. Now I am in a situation where I can not ...
1
vote
1answer
48 views

How can I install 32-bit dependencies on a 64-bit machine using dnf builddep?

I am trying to install the build dependencies for Wine, so that I can do a bit of hacking with it. I am running Fedora 22, 64-bit. I have installed the 64-bit dependencies successfully using dnf ...
1
vote
3answers
42 views

Install Git offline without sudo

I have a corporate Linux server which does not have internet connection, and sudo access needs to be approved through many levels of hierachy. I've tried install git but I soon realized this needs a ...
1
vote
1answer
703 views

Resolving circular dependency hell for libX11 and libXi

I'm trying to install X11 from source. Source files from some repository: libX11-1.6.0.tar.gz libXi-1.7.1.901.tar.gz libX11-1.6.0 paulk@node005:libX11-1.6.0$ ./configure --prefix=$HOME/software ...
0
votes
3answers
1k views

Installing virtualbox on Debian: dependency problems

I'm currently running Debian Wheezy (Testing). I want to install virtualbox but when I run the following: # aptitude install virtualbox ...I get the following result: The following packages have ...
0
votes
1answer
49 views

KDE 5 of Debian Jessie - What Qt version was used to compile it?

I had go back to Windows a while ago because of the incompatibility of linux desktops with high-res (UHD) and touch screens. As now it got much better than before, I'd like to come back to linux, as ...
0
votes
1answer
436 views

Synaptic Package Manager: Could not apply changes! Fix broken packages first.

Have been trying to fix it in various ways, but all these advices on the internet turned out useless for me. It was too strange to see when one instruction help other people, but don't solve my ...
2
votes
2answers
2k views

Why does yum continue to complain about a missing dependency that is already installed?

I have a self-created rpm for mapserver 6.2.1 that I want to support Oracle, but I am having a lot of difficulties getting it all to work. I have installed the ...
3
votes
4answers
374 views

How to find the packages that depend on a certain package in apt?

How can I get, not the dependencies of a package, but the packages that are depending on a certain package? I'm on debian 6.0 Squeeze-LTS (the first-time extension to squeeze for long term support!) ...
0
votes
1answer
127 views

apt-get doesn't work on kali linux v2.0 [closed]

For example, when i type apt-get install tor i get : Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to ...
0
votes
1answer
34 views

unmet dependencies on old Ubuntu version (10.10)

I'm trying to install git on an old Ubuntu machine (Ubuntu 10.10, Maverick). But i get the following errors: sudo apt-get install git Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
172 views

Unmet dependencies when installing mtrack

I'm trying to install mtrack on Ubuntu 14.04 on my macbook pro: sudo apt-get install xserver-xorg-input-mtrack But I get unmet dependencies: The following packages have unmet dependencies. ...
0
votes
0answers
206 views

Installing jre-8u51-linux-x64.rpm on SLES 11 SP3: Failed dependencies

I tried to update my Java installation on a SLES 11 SP3 system (for some reasons I want to run the original Java and not the IBM Java provided by SUSE) and I got the following error message: error: ...
1
vote
2answers
48 views

Strange dependency error in installing package

I am trying to install an app we made in Ubuntu (with Quickly) to Raspberry Pi Raspbian. However, it has a dependency python:any (>= 2.7.1-0ubuntu2) which is unmet in Raspbian although it has Python ...
1
vote
1answer
665 views

How can i fix the following gmp library dependency error while trying to install Charm?

I am trying to install Charm crypto python framework in ubuntu 11.04 with python 2.7. Requirements say that i should have gmp installed 5.*. I have successfully installed gmp lib and i have run all ...
0
votes
1answer
17 views

Network Install Debian on a VLAN

My lab is on a VLAN. If the machines are connected to the VLAN they can connect to the Internet. If not they can't. Installing the VLAN package enables network connectivity. However, I don't know how ...
3
votes
1answer
612 views

Make RPM Satisfy Dependency Requirements of Other Installed Packages

So, I am installing a java app that I wrote which uses jnetpcap. This requires libpcap of at least v1.0.0. My CentOS 5.8 only has libpcap 0.9.4, which is required by other installed packages. I've ...
2
votes
1answer
1k views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
1
vote
0answers
110 views

How to combine deb dependencies into main package?

I want to include deb-dependencies with main deb-package. Consider 1 deb package which have 19 deb dependencies, so I have to install all packages by dpkg -i *.deb. If all 19 dependencies can be ...
0
votes
1answer
36 views

How to get ALL kinds of reverse package dependencies: reverse-depends pendant for non-Ubuntu distributions

I would like to find all possible reverse dependencies (no need for recursive reverse dependencies) of a certain package p, that is, I want to find all packages which depend on p. This shall include ...
14
votes
2answers
341 views

Could Apt delete packages that are need by software that users have installed from source?

Apt handles dependencies among packages installed from its repositories or *.deb files. However, what about software that users have compiled and installed from source with ./configure && ...
1
vote
1answer
45 views

Can `make` automatically install dependencies?

When I am installing a program with the make and make install method, there are (very often) many dependencies that need to be installed before the installation of the new program can begin. So ...
1
vote
3answers
2k views

Unmet acroread dependencies preventing Synaptic install

In Synaptic I am getting the error: acroread: Depends: acroread-l10n-en but it is not going to be installed or acroread-l10n Depends: acroread-debian-files but it is not going to be installed ...
1
vote
2answers
56 views

How do I resolve package dependencies for a different target system?

(TL;DR: how do I determine the minimum set of packages to install, given an initial state and desired package list?) I'm creating an Ubuntu installer ISO for systems without access to distribution ...
0
votes
0answers
18 views

unmet dependencies for gir1.2-accountsservice-1.0 on Ubuntu 14.04.2

I'm trying to install a software package which depends on gir1.2-accountsservice-1.0. However, when I attempt to install gir1.2-accountsservice-1.0 I get the following message: sudo apt-get install ...
1
vote
2answers
157 views

How to Resolve a .so Dependency

I have a package (.rpm) on CentOS 6.5 that requires a .so file, which I also have on my machine. When I attempt to install the package I get an error stating unresolved dependencies regarding the .so ...
1
vote
1answer
136 views

How can I install all missing perl libraries?

I'm attempting to install logitechmediaserver 7.8.0 on my OSMC (Raspbmc) Raspberry Pi. I primarily followed instructions from here, although some of the install did not work (some dependencies missing ...
2
votes
0answers
45 views

What is the systemd equvalent to sysvinit 'X-Start-Before'?

Quoted from https://wiki.debian.org/LSBInitScripts. X-Start-Before: boot_facility_1 [boot_facility_2...] X-Stop-After: boot_facility_1 [boot_facility_2...] provide reverse dependencies, ...
2
votes
1answer
510 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
0
votes
2answers
56 views

Why does ./configure give me unmet packages, that do not exist?

I'm trying to compile Caribou 0.4.18.1 on Xubuntu 14.04. In the INSTALL document it says, that I should run ./configure && make && make install. But the ./configure step ended with: ...
1
vote
0answers
51 views

About Dependencies

In the absence of internet connection for the present, I am trying to use apt-offline. When I execute the order in terminal I get "ERROR: FATAL: Something is wrong with the apt system." I have been ...
0
votes
0answers
52 views

How to uninstall gnome-bluetooth dependancies?

As you can see below, I installed (and then deleted) gnome-bluetooth on my Debian Xfce desktop. It's come with a lot of librairies and autoremove doesn't get rid of them. Is there an automatic way to ...
4
votes
1answer
130 views

Circular dependency in Ubuntu Release upgrade

The title is the best way I could describe this error. Basically the packages kbd, console-setup, console-setup-linux, and keyboard-configuration all depend on each other. So I cannot remove, ...
0
votes
0answers
71 views

Gpgpu-sim dependencies in centOS

I try to install gpgpu-sim in my CentOS 6, there are some dependencies need to be installed before I can compile gpgpu-sim successfully. the dependencies are as follows: GPGPU-Sim dependencies: ...
3
votes
2answers
140 views

Is there a way to see why certain dependency of a package is needed?

I was about to install mysql-client-5.5 package which has debianutils package as a dependency. However, I first checked which binaries are installed with debianutils package. It installs nine ...
0
votes
1answer
227 views

cannot install wine on 17.1 mint: unmet dependencies, broken packages

i have a Linux Mint 17.1 Rebecca - Release amd64 20141126]/ trusty contrib main non-free installed, and the apt-get install wine wont do the trick. it returns the following: Some packages could not ...
0
votes
1answer
189 views

Dependencies problems installing VNC Server in Red Hat Enterprise Linux Server release 6.5

I'm triying to install VNC Server in a Red Hat Enterprise Linux Server release 6.5. I have the .rpm of VNC Server, but it has a depedency with xterm, which I have the .rpm too. Trying to install xterm ...
2
votes
0answers
274 views

Unmet dependency after linux mint distribution update

I have recently updated to Linux mint rebecca. I am getting unmet dependencies for apt-get when I am trying to apt-get install a package named monodevelop-nunit monodoc-nunit-manual then this ...
1
vote
2answers
85 views

yum is trying to install a package PLUS dependency - I DO NOT want that dependency

I am trying to install grive in my CentOS server. The rpm available is: grive-0.3.0-1.el6.xz.x86_64.rpm The problem is that the rpm seems to be tied to json-c version 0.11 but the one I really need ...
0
votes
1answer
37 views

messed up system after offline package installation for WLAN driver

I'm running Linux Mint 17.1 on my old desktop pc. Since I moved, I had no internet connection, but could use the WLAN of my neighbors. For that, I had to install an old FRITZ! USB WLAN driver. I did ...
2
votes
2answers
158 views

Debian - get all dependencies updated when they 'wont be installed'

I've been trying to install Percona Toolkit onto my Debian (wheezy) server. I downloaded it as per the instructions: wget percona.com/get/percona-toolkit.deb then installed it sudo dpkg -i ...
4
votes
2answers
4k views

Java JDK missing libjli.so path in dependency list, Debian

I am scripting the creation of chroot jails and part of that automation includes copying various executables and their dependencies into the jail. I am using the following bash line to parse the file ...
0
votes
2answers
1k views

Install mplayer on Centos 7

I've been trying for several days to install mplayer on Centos 7 without success, I've install many repos but nothing works, I've always the following error: -> Resolve Dependencies completed ...
2
votes
1answer
132 views

How to get all the dependencies for a package

I'm trying to get all the dependencies for a package..for example apache2 I've tried to use apt-cache depends apache2 but it gives some dependencies but when I want to install apache2 on a live CD it ...
2
votes
1answer
1k views

Missing/broken dependancies on OpenSUSE, normal?

Re-installing our little LAMP server at work, a bit tired of Ubuntu server so I had a look around and decided on OpenSUSE, nicely supported, well maintained blah blah however pretty much every package ...
-1
votes
1answer
331 views

How to remove a package on a debian-based system WITHOUT removing dependencies? [closed]

I have a computer running Linux Mint and I'd like to remove a package WITHOUT removing its dependencies. For the particular package I'd like to remove, there are about 20 dependencies and some ...
2
votes
1answer
428 views

Remove only unused dependencies using Synaptic

As all distros, install much unused software, so does PCLinuxOS. But when I am trying to remove this software using Synaptic, it marks the dependencies as "to be removed" too. The problem is that ...
0
votes
1answer
817 views

Trying to install rpm package in Fedora 21, but dependency on OpenJDK 7 results in errors

I am running Fedora 21 32bit workstation version. Trying to install iris-4.22.0-1.noarch.rpm: [itse@localhost Downloads]$ sudo yum install iris-4.22.0-1.noarch.rpm [sudo] password for itse: Loaded ...
0
votes
1answer
45 views

rpm -R verses zypper info --requires

Consider the following: root# rpm -qR foobar rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadIsLzma) <= 4.4.6-1 root# zypper info --requires ...
0
votes
1answer
43 views

Non-sense error messages for unmet dependencies in Debian Jessie

My problem is not understanding the error messages: It says I need blah-blah-1.49 (>= 1.49-1) and this is not installable but I have blah-blah-1.55 installed already. I think 1.55 is greater than ...