Additional software that some software requires to function

learn more… | top users | synonyms

0
votes
1answer
664 views

Installing jre-8u51-linux-x64.rpm on SLES 11 SP3: Failed dependencies

I tried to update my Java installation on a SLES 11 SP3 system using rpm -i jre-8u51-linux-x64.rpm (for some reasons I want to run the original Java and not the IBM Java provided by SUSE) and I got ...
1
vote
0answers
497 views

Trouble installing Unity8-LXC on Mint

(I originally posed this on askubuntu but was told it should be here instead.) I want to install unity8-lxc on Linux Mint so I can check out Unity8 without installing it. Mint 17.3 (Rafaela) of ...
1
vote
2answers
26 views

rpm: what determines whether a package updates a previous one or gets installed in addition

Is it simply the installation path? If that is the case then any package that has version in the name/path will never update another, so that cannot be it. I don;t see a mention of this in the ...
0
votes
1answer
72 views

Which Gentoo Package provides Qt5CompositorConfig.cmake?

I would like to compile and then install Hawaii from source code, but I am stuck at the compiling GreenIsland (a dependency of Hawaii) from source code stage. I created a build subdirectory of the ...
1
vote
0answers
38 views

How can the output of ldd be checked to see of they exist on a different system or not? [duplicate]

Running ldd on an executable gives the output displayed below. How can the output be parsed for the library names in the first column and their existence tested on another computer, giving output ...
0
votes
1answer
63 views

How to minimize the unnecessary files installed by package dependencies?

I'm trying to install packages with having as little files from their dependencies as possible, since system size is important to me. For example, when wanting to install a package, I could install ...
9
votes
2answers
7k views

Debian: Is it possible/safe to install packages from an older version of the repository?

I'm currently running Debian testing (Wheezy) and am trying to get SCIM working. I want to install the scim-pinyin package, but there is no such package available in the testing repository, although ...
2
votes
1answer
217 views

Cross-compiling Slackware: is the build order listed anywhere?

I'm building a Slackware system from source and hitting a dependency wall here. (Before you ask: no, I'm not trying to "make it faster"; I'm building against a different C library.) Getting a ...
1
vote
2answers
276 views

Broken packages problem trying to install python-dev

I need to install python-dev in order to install another application, but when I do sudo apt-get install python-dev I get: The following packages have unmet dependencies: with a list of dependencies. ...
2
votes
1answer
163 views

Error with dependencies higher than expected

I try to make msfupdate inside the actuall kali linux sana repository. I dont understand the dependencies. for ex. i have xpdf <= 3.03-11 but 3.03-10 should be installed - wheres the problem? If i ...
1
vote
2answers
526 views

The following packages have unmet dependencies

Every time I try to use apt-get install or remove or purge on my Debian, I have this error pop up: The following packages have unmet dependencies: libimage-magick-q16-perl : Depends: ...
1
vote
0answers
189 views

aptitude automatically removes packages, while upgrading php

I've facing this problem since my debian wheezy distro has been upgraded (I'm currently running ParrotSecurity 1.9 and the current version is 2.0.4). I've added http://dotdeb.org/ to my ...
1
vote
1answer
833 views

How can I install all missing perl libraries?

I'm attempting to install logitechmediaserver 7.8.0 on my OSMC (Raspbmc) Raspberry Pi. I primarily followed instructions from here, although some of the install did not work (some dependencies missing ...
4
votes
1answer
785 views

Make RPM Satisfy Dependency Requirements of Other Installed Packages

So, I am installing a java app that I wrote which uses jnetpcap. This requires libpcap of at least v1.0.0. My CentOS 5.8 only has libpcap 0.9.4, which is required by other installed packages. I've ...
0
votes
0answers
45 views

Problem while installing ReviewBoard on Oracle Linux 6.2

I am trying to installing ReviewBoard on Oracle Linux 6.2. For that first of all I have installed a epel-release-latest-6.noarch.rpm provided by Fedora. Then when I am trying to give command yum ...
0
votes
0answers
23 views

Install Vlc 1.1 without building it from source

I am using Ubuntu 15.04. Is there any way to install VLC version 1.1 without having to build it from source? I tried these method but I was stuck in endless loop of unmet dependencies: sudo dpkg -i ...
0
votes
1answer
437 views

Linux debian dependency issues and wine installation

I am trying to install wine since several days but I cannot succes I have so MANY dependencies issues when I try to install a missing dependency it requires another dependency etc .. infinite circle ...
2
votes
1answer
4k views

How to force `dpkg` to install dependencies [closed]

I would like to install .deb file via dpkg in Arch Linux. This .deb file needs many dependencies. I don't want to install dependencies one by one manually. How do I force dpkg to install all ...
0
votes
3answers
157 views

Why does linux not allow multiple versions in the central repository?

I'm total newb to Linux, but here goes.. It seems to me that a lot of the problems using Linux is because of mismatched dependencies. Specifically that you can't install two versions of a library. ...
2
votes
0answers
314 views

Debian 8 - Jessie - Broken Packages / Dependency Hell

I'm having issues installing packages and doing upgrades. If I execute sudo apt-get upgrade, I get: The following packages have unmet dependencies: gksu:i386 : Depends: sudo:i386 ...
1
vote
1answer
41 views

How to know before compilation which dependencies a package will need?

I want to install a package on Ubuntu 14.04 using ./configure; make; sudo make install, however, it is failing due to several missing libraries. How can I produce a list of needed packages and ...
1
vote
0answers
100 views

Could not perform immediate configuration on 'multiarch-support'

I am not sure what I was thinking when I accidently deleted my /etc/dpkg/ folder. While I was fixing that, I tried many things and that made things worst. Now I am in a situation where I can not ...
3
votes
1answer
671 views

How can I install 32-bit dependencies on a 64-bit machine using dnf builddep?

I am trying to install the build dependencies for Wine, so that I can do a bit of hacking with it. I am running Fedora 22, 64-bit. I have installed the 64-bit dependencies successfully using dnf ...
1
vote
3answers
909 views

Install Git offline without sudo

I have a corporate Linux server which does not have internet connection, and sudo access needs to be approved through many levels of hierachy. I've tried install git but I soon realized this needs a ...
0
votes
3answers
1k views

Installing virtualbox on Debian: dependency problems

I'm currently running Debian Wheezy (Testing). I want to install virtualbox but when I run the following: # aptitude install virtualbox ...I get the following result: The following packages have ...
1
vote
1answer
638 views

KDE 5 of Debian Jessie - What Qt version was used to compile it?

I had go back to Windows a while ago because of the incompatibility of linux desktops with high-res (UHD) and touch screens. As now it got much better than before, I'd like to come back to linux, as ...
0
votes
1answer
2k views

Synaptic Package Manager: Could not apply changes! Fix broken packages first.

Have been trying to fix it in various ways, but all these advices on the internet turned out useless for me. It was too strange to see when one instruction help other people, but don't solve my ...
1
vote
1answer
859 views

apt-get doesn't work on kali linux v2.0 [closed]

For example, when i type apt-get install tor i get : Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to ...
0
votes
1answer
318 views

unmet dependencies on old Ubuntu version (10.10)

I'm trying to install git on an old Ubuntu machine (Ubuntu 10.10, Maverick). But i get the following errors: sudo apt-get install git Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
773 views

Unmet dependencies when installing mtrack

I'm trying to install mtrack on Ubuntu 14.04 on my macbook pro: sudo apt-get install xserver-xorg-input-mtrack But I get unmet dependencies: The following packages have unmet dependencies. ...
1
vote
2answers
144 views

Strange dependency error in installing package

I am trying to install an app we made in Ubuntu (with Quickly) to Raspberry Pi Raspbian. However, it has a dependency python:any (>= 2.7.1-0ubuntu2) which is unmet in Raspbian although it has Python ...
0
votes
1answer
100 views

Network Install Debian on a VLAN

My lab is on a VLAN. If the machines are connected to the VLAN they can connect to the Internet. If not they can't. Installing the VLAN package enables network connectivity. However, I don't know how ...
2
votes
1answer
1k views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
1
vote
0answers
223 views

How to combine deb dependencies into main package?

I want to include deb-dependencies with main deb-package. Consider 1 deb package which have 19 deb dependencies, so I have to install all packages by dpkg -i *.deb. If all 19 dependencies can be ...
0
votes
1answer
136 views

How to get ALL kinds of reverse package dependencies: reverse-depends pendant for non-Ubuntu distributions

I would like to find all possible reverse dependencies (no need for recursive reverse dependencies) of a certain package p, that is, I want to find all packages which depend on p. This shall include ...
14
votes
2answers
372 views

Could Apt delete packages that are need by software that users have installed from source?

Apt handles dependencies among packages installed from its repositories or *.deb files. However, what about software that users have compiled and installed from source with ./configure && ...
1
vote
1answer
93 views

Can `make` automatically install dependencies?

When I am installing a program with the make and make install method, there are (very often) many dependencies that need to be installed before the installation of the new program can begin. So ...
1
vote
3answers
2k views

Unmet acroread dependencies preventing Synaptic install

In Synaptic I am getting the error: acroread: Depends: acroread-l10n-en but it is not going to be installed or acroread-l10n Depends: acroread-debian-files but it is not going to be installed ...
2
votes
2answers
201 views

How do I resolve package dependencies for a different target system?

(TL;DR: how do I determine the minimum set of packages to install, given an initial state and desired package list?) I'm creating an Ubuntu installer ISO for systems without access to distribution ...
0
votes
0answers
32 views

unmet dependencies for gir1.2-accountsservice-1.0 on Ubuntu 14.04.2

I'm trying to install a software package which depends on gir1.2-accountsservice-1.0. However, when I attempt to install gir1.2-accountsservice-1.0 I get the following message: sudo apt-get install ...
1
vote
2answers
250 views

How to Resolve a .so Dependency

I have a package (.rpm) on CentOS 6.5 that requires a .so file, which I also have on my machine. When I attempt to install the package I get an error stating unresolved dependencies regarding the .so ...
2
votes
0answers
162 views

What is the systemd equvalent to sysvinit 'X-Start-Before'?

Quoted from https://wiki.debian.org/LSBInitScripts. X-Start-Before: boot_facility_1 [boot_facility_2...] X-Stop-After: boot_facility_1 [boot_facility_2...] provide reverse dependencies, ...
2
votes
1answer
622 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
0
votes
2answers
153 views

Why does ./configure give me unmet packages, that do not exist?

I'm trying to compile Caribou 0.4.18.1 on Xubuntu 14.04. In the INSTALL document it says, that I should run ./configure && make && make install. But the ./configure step ended with: ...
1
vote
0answers
92 views

About Dependencies

In the absence of internet connection for the present, I am trying to use apt-offline. When I execute the order in terminal I get "ERROR: FATAL: Something is wrong with the apt system." I have been ...
0
votes
0answers
151 views

How to uninstall gnome-bluetooth dependancies?

As you can see below, I installed (and then deleted) gnome-bluetooth on my Debian Xfce desktop. It's come with a lot of librairies and autoremove doesn't get rid of them. Is there an automatic way to ...
0
votes
0answers
205 views

Gpgpu-sim dependencies in centOS

I try to install gpgpu-sim in my CentOS 6, there are some dependencies need to be installed before I can compile gpgpu-sim successfully. the dependencies are as follows: GPGPU-Sim dependencies: ...
3
votes
2answers
145 views

Is there a way to see why certain dependency of a package is needed?

I was about to install mysql-client-5.5 package which has debianutils package as a dependency. However, I first checked which binaries are installed with debianutils package. It installs nine ...
0
votes
1answer
535 views

cannot install wine on 17.1 mint: unmet dependencies, broken packages

i have a Linux Mint 17.1 Rebecca - Release amd64 20141126]/ trusty contrib main non-free installed, and the apt-get install wine wont do the trick. it returns the following: Some packages could not ...
0
votes
1answer
435 views

Dependencies problems installing VNC Server in Red Hat Enterprise Linux Server release 6.5

I'm triying to install VNC Server in a Red Hat Enterprise Linux Server release 6.5. I have the .rpm of VNC Server, but it has a depedency with xterm, which I have the .rpm too. Trying to install xterm ...