0
votes
1answer
163 views

Broken libglib on debian 6

So, some time ago I wanted to update mpd from 1.5 to 1.6 which required a newer version of libglib( >= 2.31.8) on amd64, so I compiled them from source as I was on debian oldstable and couldn't find ...
0
votes
1answer
665 views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
0
votes
0answers
35 views

How can the output of ldd be checked to see of they exist on a different system or not? [duplicate]

Running ldd on an executable gives the output displayed below. How can the output be parsed for the library names in the first column and their existence tested on another computer, giving output ...
4
votes
2answers
228 views

Is there a way to determine what packages or libraries should be loaded to support an executable?

There is an executable I want to install on a computer that I can't recompile that wasn't built as a package, and I want to download the libraries it requires to run them. Below is part of the output ...
2
votes
2answers
3k views

How to install a custom boost version in CentOS?

I'm trying to compile and install boost 1.54 from source in CentOS. The documentation is pretty straight forward and there are plenty of tutorials in the internet available (1) (2) (3). This is what ...
1
vote
1answer
189 views

How can i fix the following gmp library dependency error while trying to install Charm?

I am trying to install Charm crypto python framework in ubuntu 11.04 with python 2.7. Requirements say that i should have gmp installed 5.*. I have successfully installed gmp lib and i have run all ...
0
votes
1answer
358 views

Is there a way to use/recompile libgio-2.0 on machine with libc-2.5?

I have a program (JavaFX 2, namely), and one of its binaries (libglass.so) requires libgio-2.0.so.0. The problem is, the system, on which I need to run the app, is quite old and mostly out of my ...
2
votes
1answer
453 views

Fedora 16 dependency hell

There's a package libvpx-0.9.7 which is required by empathy application. Now I want to install another application which requires libvpx-1.0... Update is not allowed because some applications depend ...
3
votes
1answer
666 views

libstdc++.so.3 => not found on CloudLinux, no SuperUser permissions, seemingly in chroot.

I am trying to install the Linux x64 BOINC command-line interface client on a CloudLinux machine with x86_64 Architecture. When I try to run the executable I get an error: ./boinc: error while ...
1
vote
2answers
500 views

Failed dependencies

I am searching for the following : libpython2.5.so.1.0 libtinfo.so.5 python(abi) = 2.5 I searched , but I am not able to find these. I am running Centos 5.6 with linux kernel 2.6.18-238.el5. $ ...
2
votes
2answers
5k views

How does rpm resolve library dependencies?

I try to make a package of a program which is linked to such library (output from ldd): libwx_baseu-2.8.so.0 => /usr/lib64/wx-2.8-wxcontainer/libwx_baseu-2.8.so.0 Pretty straightforward, ...