1
vote
2answers
43 views

CUPS libusbx-devel is needed error when trying to build cups-1.7.1 from source

I have been trying to build CUPS 1.7.1 on RHEL 5.6 using $ sudo rpmbuild -ta ./cups-1.7.1-source.tar.bz2 and was getting: error: Failed build dependencies: libusbx-devel is needed by ...
8
votes
3answers
4k views

Mount printers at /dev/usb and still use CUPS

Due to a new version of CUPS, I suddenly lost the direct path to my printers that was previously available under /dev/usb/lpXXX. I used this to print directly from the command line. echo "test" > ...