A Configure script is an executable script designed to aid in developing a program to be run on a wide number of different computers.

learn more… | top users | synonyms

3
votes
1answer
578 views

GVim compiled from source does not use gtk2

I have two HP-UX machines say A and B with HP-UX 11.11 and 11.31 respectively. I'have compiled gvim 7.3 from source an B, and gvim 7.0 on A. On A, gvim uses "version with GTK GUI", Compilation with ...
1
vote
1answer
460 views

Why doesn't Ruby's configure script detect my executables and header files?

I'm trying to compile Ruby and really understanding what's going on while doing so. I've used and written Makefiles before, but not autoconf's configure.in files, so maybe the result I'm getting is by ...
3
votes
1answer
2k views

Does `make install` overwrite files?

I've taken some time to install a newer version of Apache2.x on my Mac Os X 10.6.8. When configuring apache through ./configure I specified the Darwin layout. This layout assumes the path setup of ...
2
votes
1answer
47 views

./configure, how to provide a different executable during the checking phase

I am trying to install the MonoDevelop IDE from source. One of its prerequisites is Mono 2.10. Unfortunately the preinstalled mono runtime on my current Ubuntu system is 2.6.7. I managed to make a ...
36
votes
4answers
17k views

Why can't gcc find libevent when building tmux from source?

I want to install tmux on a machine where I don't have root access. I already compiled libevent and installed it in $HOME/.bin-libevent and now I want to compile tmux, but configure always ends with ...
3
votes
3answers
432 views

Output compiler options from SSH

How can I list the configuration options that ssh/sshd was compiled with? I'm attempting to troubleshoot a SELinux configuration issue, and want to make sure that SSH was compiled with ...
1
vote
1answer
285 views

Scribes Editor and Slackware64 13.37 — PyGTKSpell Cannot Be Found

I am trying to build Scribes in Slackware64 13.37 with XFCE and I am having a lot of troubles with the Python Binding for GTK Spell. I have gtkspell-2.0.16-x86_64-1 and pygtkspell-2.25.3-i486-3sl ...
4
votes
1answer
2k views

Building 32-Bit on a 64-Bit system

I'm trying to build the PHP memcache extension (v2.2.6) for i386 (32bit) on my x86_64 Ubuntu 11.04. ./configure uses config.guess by default (which outputs x86_64-unknown-linux-gnu on my system) but ...
1
vote
1answer
165 views

configure not adding line-continuation characters to makefile

This is, perhaps, a bit of a bizarre one but I don't even know where to start looking so if anyone can point me in the right direction, I'll be very grateful. I've just done a fresh install of my ...