Compiling is the process of transforming source code into byte codes for a particular computer architecture.

learn more… | top users | synonyms (2)

1
vote
0answers
17 views

How do I backport Mesa on Debian Wheezy?

This post is continuing a previous one where I tried to compile Mesa 10.0.5: What are the required build dependencies of mesa for Debian-based distros? . Except that this time, I switched to another ...
150
votes
4answers
54k views

Why is FreeBSD deprecating GCC in favor of Clang/LLVM?

So I was surfing the net and stumbled upon this article. It basically states that FreeBSD, starting from Version 10 and above will deprecate GCC in favor of Clang/LLVM. From what I have seen around ...
0
votes
0answers
51 views

What are the required build dependencies of mesa for Debian-based distros? [on hold]

My target is about playing Team Fortress 2 on Kali Linux (a Debian Wheezy stable distribution with customized Debian Sid kernel) since a long time now, but couldn't because of the following graphical ...
0
votes
1answer
28 views

How can I undo the changes after compiling a package? [duplicate]

Let's say that I have build a package using the typical method ./configure make make install and then I would like to uninstall this package. There is no any uninstall script. How can I revert my ...
1
vote
2answers
57 views

How can I link my C program against the Arb library?

I tried to compile the program Testing Li’s criterion in Ubuntu. However, when I do gcc demo.c, I get the output as, demo.c:2:19: fatal error: fmpcb.h: No such file or directory #include "fmpcb.h" ...
0
votes
1answer
72 views

Permissions for installing coreutils with pkgsrc on NetBSD

I'm trying to install coreutils on NetBSD 6.1.5 using the pkgsrc system. This is on the default install of 6.1.5. The only change made has been to install zsh and set it as my default shell for users ...
0
votes
1answer
38 views

building php-5.3 on arch linux

I'm trying to build php-5.3 on arch linux using phpenv + php-build. The problem is bison is too new: $ phpenv install 5.3.29 [Info]: Loaded apc Plugin. [Info]: Loaded pyrus Plugin. [Info]: Loaded ...
-1
votes
0answers
22 views

Why configure doesn't search for mysql socket with --with-mysql=mysqlnd option?

I was building php-5.3 on arch linux recently. And one of the problems I encountered was that it didn't work with mysql right away: $ ./php -r 'var_dump(mysql_connect("localhost", "<USER>", ...
3
votes
2answers
666 views

How to build Shallot

I am trying to build Shallot. I run x64 Debian Sqeeze. It runs into compile problems I don't understand... john@hayek:~/build/katmagic-Shallot-831de01$ make cc -O3 -I/usr/include ...
1
vote
3answers
226 views

Building zsh without admin priv: No terminal handling library found

I am trying to install Zsh without root privileges on a Linux machine. I downloaded the source tarball and run: ./configure --prefix=<my_installation_path> but then I got: configure: ...
1
vote
1answer
164 views

How can I install hulahop

I cloned hulahop via git and I'd like to use it and try to run this example. I have a problem to find out how to build and install it. I also tried to install it with apt-get but I don't have this ...
0
votes
0answers
42 views

Error while compiling bash for shellshock security exploit

I used the instruction from https://shellshocker.net/ here is the command: sudo curl https://shellshocker.net/fixbash | sh error while compiling: Running make rm -f mksyntax gcc ...
1
vote
1answer
57 views

Compiling/installing driver for Wifi dongle missing kernel modules?

Goal Install the Netis wf2190 wifi dongle onto a NUC with Debian. Environment NUC DC3217IYE Netis WF2190 Debian Linux 3.16-0.bpo.2-amd64 #1 SMP Debian 3.16.3-2~bpo70+1 (2014-09-21) x86_64 ...
2
votes
1answer
322 views

LFS 7.5 - Glibc-2.19 compile errors at section 6.9, are they fatal to my LFS build?

I am using a host Ubuntu 14.04 system, and I am currently going through the Linux From Scratch guide here. At section 6.9, http://www.linuxfromscratch.org/lfs/view/stable/chapter06/glibc.html, after ...
1
vote
3answers
1k views

Installing PostgreSQL 9.0 on RHEL 6.4 (How to get Yum to Include a version of OpenSSL I built from source)

I receive the following errors from yum install postgresql90-server: Error: Package: postgresql90-9.0.15-1PGDG.rhel6.x86_64 (pgdg90) Requires: libssl.so.10(libssl.so.10)(64bit) Error: Package: ...
0
votes
0answers
5 views

Compiling Riofs, can't compile with support to --force-head-requests

I am on Debian Jessie, compiling the last master with a gcc 4.8 and some higher versions for some of the required libs, required libs are : glib >= 2.22 fuse >= 2.7.3 libevent >= 2.0 libxml ...
2
votes
1answer
67 views

What Did Users Do or Use Before the Make Command?

I use Gentoo as my primary home Desktop OS. I have since ~2004. I appreciate the emerge command for managing a source based OS as well as it does. Every now and then I check on other distributions, ...
0
votes
0answers
30 views

Missing macros for VSYSCALL in Linux 3.16.4

I am running Arch with kernel version 3.16.4. I need to compile a kernel module for running Intel Vtune '13 (r17). GCC reports the following: ...
0
votes
1answer
933 views

Ffmpeg-php will not compile

FFMPEG: ffmpeg version N-54768-g8d9c1b3-syslint Copyright (c) 2000-2013 the FFmpeg developers built on Jul 16 2013 14:40:49 with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-3) configuration: ...
0
votes
0answers
35 views

Kernel version name is repeated twice

I'm compiling my own kernel on Ubuntu. I use make deb-pkg -j5 to compile and package the kernel. In the kernel Makefile, I have added "-mykernel" to the extraversion part of the version string. ...
0
votes
0answers
55 views

“the geoip2 module requires the maxminddb library” but the library is installed

I am trying to compile nginx with a module: https://github.com/leev/ngx_http_geoip2_module. Before the nginx compilation, this library: https://github.com/maxmind/libmaxminddb needs to be installed. I ...
0
votes
1answer
1k views

RPM: Installed (but unpackaged) file(s) found on Centos 6 with CUPS 1.7.1

Trying to install CUPS 1.7.1 on Centos 6.5 via RPM, I use: # rpmbuild -ta cups-1.7.1-source.tar.bz2 --without dbus --without libusb1 but stops with below error: Checking for unpackaged file(s): ...
2
votes
0answers
43 views

Explanation of the building process of the kernel on Ubuntu/Debian systems

I'm getting into Linux kernel programming and I have successfully built my own kernel several times now. However, I have done it using step by step guides found from the internet and I don't really ...
0
votes
1answer
23 views

Installing Xcape (a newbie question involving the “make” command)

I executed the minimal building directions of xcape: $ sudo apt-get install git gcc make pkg-config libx11-dev libxtst-dev libxi-dev $ mkdir xcape $ cd xcape $ git clone ...
0
votes
2answers
59 views

Can no run configure command: “No such file or directory”

I'm trying install on Debian package from git source, I downloaded package, then cd to directory and run ./configure command, but it return bash: ./configure: No such file or directory: what can be a ...
0
votes
0answers
452 views

Nvidia driver not working on latest kernel (3.17) and Ubuntu 14.04

I'm pretty new to kernel hacking. However, I have built my own kernel before (3.16) and it works. Now I tried upgrading to the latest kernel (3.17-rc7). I configure the kernel using the config file ...
1
vote
1answer
532 views

Enable kernel module for VPN

I'm trying to turn on modules for VPN so I followed this tutorial to compile new ubuntu kernel 3.8.6 . But the features I've turned on using make menuconfig seem not to be enabled. (the features I ...
0
votes
2answers
35 views

Compilation error when building a custom kernel

I'm trying to build a custom kernel from a git repository on my Ubuntu virtual machine. I run the make command as follows : sudo apt-get install vim libncurses5-dev gcc make git exuberant-ctags mkdir ...
0
votes
1answer
483 views

modpost.h:12:23: fatal error: elfconfig.h: No such file or directory

I am running Ubuntu: #lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 12.04.4 LTS Release: 12.04 Codename: precise Kernel info: 3.8.0-38-generic ...
3
votes
2answers
521 views

Adding Buildroot Package

I'm trying to add a package to buildroot, but I'm not having much success. The package I'm trying to add is an autotools package called scew. I've followed the buildroot guidelines about adding ...
2
votes
2answers
52 views

apt-get build-dep is unable to find a source package

I have already followed this guide to disable middle mouse button paste on my Ubuntu 12.04. Works like a charm. Now I am trying to achieve the same on my Linux Mint 17. When I try to sudo apt-get ...
1
vote
3answers
469 views

net-snmp-5.7.2 compilation fail

I am currently trying to compile net-snmp-5.7.2 on rhel 6 64bit system. ./configure step is fine, but when I do the make step I got the following error : gcc -shared -O2 -g -pipe -Wall ...
1
vote
3answers
908 views

Error compiling drivers for Ralink RT2870

Im trying to install drivers for a rosewill RNX-N600UBE wireless card (Ralink RT2870 chipset) on Kali Linux. I downloaded the drivers form their website and unpacked/unzipped them, but now when i try ...
10
votes
6answers
6k views

Compiling GNU/Linux with -O3 optimization

It's said that compiling GNU tools and Linux kernel with -O3 gcc optimization option will produce weird and funky bugs. Is it true? Has anyone tried it or is it just a hoax?
3
votes
1answer
985 views

VDPAU library not found

I want to try this VAAPI backend for VDPAU. I have compiled mplayer with vdpau in Gentoo Linux (amd64) but I get this error: Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object ...
2
votes
1answer
325 views

Kernel headers for VMware tools

I tried to compile VMware tools on my server. I compiled the kernel myself, I didn't use RPM. As VMware tools needs the kernel header files, I executed the following command in my kernel folder ...
0
votes
1answer
716 views

Which library files are needed to run a binary with an alternate libc version?

I built Firefox 26 on Mint 16 because the Ubuntu 10.04 build utilities are too old to build it. It does need to run on 10.04, however, since that's the target OS I'm building for. It built and runs ...
1
vote
0answers
32 views

How to install clang?

I have downloaded the "Clang for x86_64 OpenSUSE 13.1" (I am on Scientific Linux) pre-built binary from here: http://llvm.org/releases/download.html (Should I have got the Fedora one??) and I ...
1
vote
1answer
63 views

Compiling from source: What are the options for config script “build”?

When I am running a line like: ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu {*shortened*} \ --with-imap-ssl=/usr/include/openssl/ --enable-ftp --enable-mbstring ...
3
votes
0answers
321 views

How can I install M4 on Linux, avoiding the dependency loop with Automake and Autoconf?

I am trying to install GNU M4 on my Chromebook using the 1.4.17 tarball, but when I run ./configure and thenmake I get an error related to aclocal, which is apparently part of the GNU Automake ...
6
votes
2answers
4k views

Some M4 macros don't seem to be defined

I am trying reinstall pacman on my Arch Linux distribution. When I run the configure script "configure.ac", I get a bunch of undefined macros: error: possibly undefined macro: AM_INIT_AUTOMAKE. If ...
0
votes
0answers
47 views

yum install kernel-devel: “Nothing to do” [SOLVED]

I need the kernel-devel package to compile a program(How to check if USB WiFi-Adapter is not working or router is out of range?), but when I try to install it via yum, this is the only output: yum ...
1
vote
1answer
64 views

Error while installing glibc-2.14 from source

The version of glibc in the repository is 2.13 so I couldn't use apt-get to install it. I downloaded the source code of glibc-2.14, but when I run ./configure command I get this error: checking for ...
0
votes
1answer
159 views

Unable to 'make' anything.. Kernel-headers problem? Trying to get my RTL8723BE working

I'm a starting security/Linux student and I'm having headache-problems getting my wireless to work on Kali Linux. Recently I've bought a new laptop, to be specific the: Lenovo IdeaPad Z50-70-01418NL ...
1
vote
0answers
32 views

Setting XDG_DATA_HOME and XDG_CONFIG_HOME on compile/per program

The goal is to have a -dev version and a stable repository-based version installed at the same time, but with different data and config directories so that the dev version is not operating on(and ...
1
vote
0answers
17 views

Compiling drivers for armada 370

I am trying to compile usb_serial drivers for a Mirabox with armada 370. I first tried as followes : Install linux source for 3.2 (running kernel is 3.2.36) Install linux headers for 3.2 Edit the ...
0
votes
0answers
170 views

How to compile video4linux for ARM?

I would like to use a webcam using a Linux over ARM board. Through reading, I have discovered video4linux so I would like to compile it for ARM. My unique notes are: git clone ...
1
vote
0answers
173 views

Some questions compiling linux kernel with make-kpkg

I'm doing my first steps compiling the linux kernel and adding a new system call. I've managed to do it, but I still have some questions. For this task, I has set up a Virtual Machine guesting debian ...
18
votes
4answers
1k views

What is the difference between building from source and using an install package?

It was wondering: when installing something, there's an easy way of double clicking an install executable file, and on the other hand, there is a way of building it from source. The latter one, ...
17
votes
1answer
1k views

Configuring, compiling and installing a custom Linux kernel

I'd like to try using a kernel other than the one provided by my distro -- either from somewhere else, or as customized by me. Is this difficult or dangerous? Where do I start?