Questions specific to the CentOS Linux distribution. Use this tag if your question relates to how the CentOS distribution affects your problem; do not use it if you just happen to be using CentOS and your question is about a specific configuration detail or syntax.

learn more… | top users | synonyms (2)

0
votes
2answers
2k views

Windows Server 2012 R2 and Centos 7 dual boot: Windows gone from boot menu

I had in my mind that I cannot do much wrong when installing Linux (CentOS 7) after Windows (Server 2012 R2) to get all OSs as boot options. So, after installing Server 2012 R2 nicely, I installed ...
2
votes
1answer
329 views

What's the difference between TYPE and DEVICETYPE directives in ifcfg scripts?

While learning the Network Teaming objective of the RHCE (RHEL7) exam I noticed that examples use DEVICETYPE directive in the ifcfg scripts for master and port interfaces. I knew there was TYPE ...
0
votes
1answer
3k views

How to surpress audit daemon rotating log messages?

On a CentOS 7 system messages like these are logged several times a day: Sep 24 00:11:42 example.org auditd[756]: Audit daemon rotating log files Sep 24 00:26:23 example.org auditd[756]: Audit daemon ...
1
vote
2answers
798 views

What is the difference between installing software as root versus user?

I just installed CentOS 7 with Gnome desktop. In doing so, I created a root password, and added a user. Now I am logged in as the user. I like to install MariaDB server, PHP, and other software. To ...
1
vote
1answer
341 views

Telnet no echo output from xinetd script

I have have installed xinetd, and I wrote a script: #!/bin/bash echo "Some text" touch /home/somefile I made a service configuration under /etc/xinetd.d/ and basically it works when I connect to ...
1
vote
0answers
765 views

No volume groups found after restoring CentOS image to VirtualBox VM

I used Clonezilla to backup an HP Proliant server running CentOS 5.10. I restored the image to a VirtualBox VM but when I try to boot I get an error of "No volume groups found" "Volume Group ...
2
votes
1answer
618 views

Problems while executing slimerjs on linux (Centos 6.5 32bit)

I'm not used to work with Linux yet I wanted to try to use slimerjs on a Linux vps in order to have access to php exec function since most hosting companies disable that function. I did manage to ...
4
votes
2answers
802 views

Centos 6.5 only using 24GB/48GB of memory

I recently installed an additional 32GB of memory in my Dell PowerEdge R900 home virtual machine server. Memory check passed and I booted into CentOS. When I opened the Virtual machine manager and ...
1
vote
0answers
371 views

Yum or Reposync: How can I slowly remove a repository without unintended dependency issues?

I have used reposync to create and maintain local copies of two repositories, remi and remi-test. These are repositories maintained by Remi Collet. On several systems in an internal LAN, I added both ...
2
votes
3answers
4k views

CentOS 7 created mdadm array disappears after reboot

I created a raid1 using the below disks and command: $ ls -l /dev/disk/by-id/ata-ST3000* lrwxrwxrwx 1 root root 9 Sep 19 07:27 /dev/disk/by-id/ata-ST3000DM001-9YN166_Z1F04NR1 -> ../../sdc ...
1
vote
1answer
55 views

Empty kernel processes on CentOS vps : 2 different servers

I'm not sure I'm asking correctly, or perhaps I'm just looking at the wrong things. I'm migrating from one CentOS Vps (on an OpenVZ box) to another CentOS VPS (on a VMWare box). VPS #1 = CentOS ...
3
votes
1answer
8k views

How to Mount a Drive with Right Filesystem?

I am trying to mount the device /dev/xvdc on my CentOS system. When I run an fdisk command I get: Device Boot Start End Blocks Id System /dev/xvda1 * 1 33 ...
2
votes
1answer
18k views

CentOS 7 persistent routing issue?

I have Googled a lot but still can't find a working way on how to make some persistent routes on centOS 7. [root@asd network-scripts]# route -n Kernel IP routing table Destination Gateway ...
0
votes
1answer
5k views

Unable to install ATI Catalyst drivers under CentOS 7

I'm getting an error running ./amd-driver-installer-14.20-x86.x86_64.run # ./amd-driver-installer-14.20-x86.x86_64.run Created directory fglrx-install.xjgOcJ Verifying archive integrity... All good. ...
1
vote
1answer
147 views

Keychain SSH Key Manager prevents SFTP login on CentOS

I installed keychain and added this to my .bashrc in CentOs to help manage my SSH Keys: /usr/bin/keychain --clear $HOME/.ssh/id_rsa source $HOME/.keychain/$HOSTNAME-sh So on SSH login I am prompted ...
1
vote
1answer
692 views

What is the default behavior of %install?

I am attempting to build an RPM using the -bb flag (%prep %build %install %check package). This is the output of the %install step: Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.2kgeNY + umask 022 ...
1
vote
1answer
265 views

Get KERN_DEBUG messages into syslog on rhel7/centos7?

I've been trying to get KERN_DEBUG messages logged to a file in centos7, but have had no luck. I can get them just fine from "dmesg," but not /var/log/messages or /var/log/dmesg Here's a MWE kernel ...
1
vote
2answers
432 views

CONFIG_LOCALVERSION (CentOS 6.5)

I am in /boot as "root". I edit config-2.6.32-431.el6.x86_46 and added my name to CONFIG_LOCALVERSION="John" But when I type uname -r is just shows the version, but not my name at the end. Am I ...
1
vote
0answers
519 views

Datanode in slave isn't working : Hadoop in CentOS

We've created a Hadoop cluster of two machines following these instructions: http://tecadmin.net/set-up-hadoop-multi-node-cluster-on-centos-6/ with the machines set as follows: hadoop1 = master ...
3
votes
3answers
54 views

Where to turn first when out of free space on Cent OS Web Server?

I am a very new Systems Administrator. I have a Windows background and am now a Jr. Systems Admin working with Cent OS 5. Our web server runs Cent OS 5 and uses PHP/MySQL for our web applications. ...
2
votes
1answer
518 views

How do I determine if the linux password was changed?

I'm developing an application which is distributed on a VM. The default password is always the same, but it's hash in /etc/shadow changes with every release. How can I programmatically (e.g., from a ...
0
votes
1answer
1k views

What multimedia support should I use in centOS 7

I have recently installed Cent OS7. Its looks very nice at first. But soon realized it has a horrible multimedia support. Its own player cannot install the codecs it requires, which was much easier in ...
0
votes
1answer
171 views

Mounting Linux root fs NFS share on OS X?

I am attempting to share the root filesystem (/) of a CentOS 6.5 virtual machine to my OS X host system. While this should be relatively simple process, I'm hitting some kind of wall. Presently my ...
2
votes
1answer
370 views

autofs does not prompt for password when needed

I am trying to setup an automount point using autofs to mount a samba fileshare. I am using the following syntax in my auto.misc file mydir -fstype=cifs,rw,user=myusername ...
3
votes
1answer
386 views

How to get gnome to run /etc/gdm/PostSession/Default when using XRDP w/ VNC

I use Microsoft's Remote Desktop Client (mstsc.exe) to connect to a linux server with GNOME as my desktop. I've set up /etc/gdm/PostSession/Default to execute some steps on cleanup - which works when ...
5
votes
1answer
878 views

Transmission-daemon service spontaneously stops

I've installed, configured and ran transmission-daemon on my CentOS 6 machine using service transmission-daemon start This works nicely, and I can see the web interface on http://server.ip:9091 as ...
8
votes
3answers
17k views

What does eno mean in network interface name 'eno16777736' for CentOS 7 or RHEL 7?

Under consistent network device naming scheme, what does 'eno' stand for in network interface name 'eno16777736' for CentOS 7 or RHEL 7?
5
votes
3answers
6k views

find: File system loop detected

When I try to find a file using find -name "filename" I get an error that says: ./var/named/chroot/var/named' is part of the same file system loop as `./var/named' I ran the ls -ldi ...
1
vote
1answer
619 views

Mitigating BEAST Centos 6.5 Apache 2.2

I'm trying to get my system to pass a BEAST scan, it seems no matter what settings I use, an error is always returned stating that TLS 1.0 is enabled. I'm using Qualys SSL Labs to test ...
4
votes
2answers
11k views

Installing Epel repository on CentOS fails

This has been working on my vagrant vm for a few month without any issues. I didn't change anything, it has been vagrant up and vagrant destroy'd several times before with no problems. But now it ...
2
votes
1answer
619 views

lz4 Kernel Module in CentOS without recompiling

I just installed CentOS 7 on a vServer to play around with. Usually I use Debian. Since I had good results, I want to use zswap. I enabled it by putting zswap.enabled=1 zswap.compressor=lz4 in the ...
0
votes
0answers
58 views

After adding FORWARD NAT rules, cannot connect system eth0

I was trying to make bridge connection between wlan and eth on Centos.. I made Forward and NAT rules and then something wrong with System eth0 connection. It does not connect anymore.. Could you ...
0
votes
0answers
375 views

How to edit the “Internal Server Error” without redirecting to somewhere else?

On the web this is what I see: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, ...
13
votes
1answer
19k views

Does yum's --enablerepo option only enable a repo for the current command?

Does yum's --enablerepo option only enable a repository for the duration of the current command? For example if the enabled setting in /etc/yum.repos.d/remi.repo file is set to 0 (disabled) and I ...
-1
votes
1answer
79 views

How to diagnose the problem when Apache at random times shows “Not Found” on the web?

Suppose I reload my web site 100 times by holding down Ctrl+R on my keyboard. I notice once in a while Apache throws out a Not Found error message. If I refresh again, everything works normal ...
1
vote
1answer
11k views

Error while loading shared libraries: libdl.so.2 (and others), no such file. Libraries exist

Attempting to install a Java application from a .bin file. When opening the installer from command line, I see these errors: [boxen]# ./ZendStudio-5_2_0.bin Preparing to install... Extracting the ...
2
votes
1answer
357 views

Automated Install Fails due to CRC on /dev/sda

I'm running an X8STI-3F with an onboard LSI 1063E SAS controller running in IT mode. I'm trying to get an automated install going on it and I keep getting ddf1: physical drives with CRC AE516B03, ...
2
votes
2answers
628 views

Can I configure error notifications on a specific cronjob entry to go to a different email address?

I have multiple cron job entries configured under a single account: 0 0 * * * /foo/foo.sh 0 2 * * * /foo/foo2.sh 0 4 * * * /foo/foo3.sh Right now, if any of these encounter an error, an email is ...
-1
votes
1answer
37 views

How to edit all Apache's error codes DIRECTLY instead of using httpd.conf?

When a page does not exist.. this is what i see on the web : Not Found The requested URL /test was not found on this server. i know about : ErrorDocument 404 /test.html but i rather not use ...
1
vote
2answers
2k views

make an application startup automatically

I'm new to linux. Here I have an application deployed to linux, I want the app to startup automatically when the linux start up. I'm using an command like 'sudo ./start' to start the application. How ...
8
votes
3answers
9k views

How to disable beep sound in Linux CentOS 7 command line? [duplicate]

I just installed the basic Linux CentOS 7 (no desktop) and am experimenting with the system. Every time I make a mistake (entering things that the command line doesn't like), the computer beeps and ...
2
votes
1answer
1k views

rpm temp file question (rpm-tmp)

When installing an RPM on CentOS, I receive the following error message: /var/tmp/rpm-tmp.44492: line 578: [: too many arguments The trouble I'm having is that /var/tmp/rpm-tmp.xxxxx file is always ...
0
votes
1answer
789 views

How to login to same session with same user using xrdp and tigervnc-server?

I have Centos 6.4 with Gnome2, I'm accessing it through its xrdp (Version 0.5.0) and Xvnc TigerVNC 1.1.0 services. The clients machine are an Android tablet and a Windows 7 PC, these are using ...
1
vote
2answers
1k views

Brazilian Keyboard layout in CentOS 6.5

I'm Brazilian and new with Linux. I have the CentOS 6.5 with Gnome 2.28.2 running in a VirtualBox VM. I'm using it to PHP programming and I'm loving it. But I'm having a hard time to make ...
1
vote
1answer
3k views

Is there an all-in-one command for RPM to downgrade a package to an older version?

I want to downgrade a couple RPMs. Is there a switch combination for that? For example, when upgrading, I usually run rpm -Uvh foo.rpm but my understanding is that the -U switch means that it only ...
15
votes
3answers
36k views

How to get memory used(RAM used) using linux command?

I am trying to retrieve memory used(RAM) in percentage using linux command. My cpanel shows Memory Used which I need to display on a particular webpage. From forums, I found out that correct memory ...
1
vote
1answer
505 views

mv deleted my directory. Why?

I was trying to correct the spelling on a directory, issued a mv command, and the directory is now gone. I'd like to understand--specifically--what happened. Here's the command I ran: mv ...
3
votes
2answers
6k views

Using Awesome window manager on CentOS 7

Awesome works fine on Fedora 19, so it should work on CentOS 7, right? Well, I tried and failed to get it to work. After a long time, I managed to compile it from source and set GDM to boot from an ...
11
votes
2answers
24k views

Equivalent of update-grub for RHEL/Fedora/CentOS systems?

In Ubuntu (and I guess in Debian too) there is a system script named update-grub which automatically executes grub-mkconfig -o with the correct path for the grub configuration file. Is there any ...
1
vote
2answers
461 views

Issue in Asterisk Performance

I am running FreePBX on DigitalOcean VM. I am facing some call dropping issue in Asterisk. When looking at "htop", "top" and FreePBX GUI, I see different results of CPU utilization and can't ...