0
votes
0answers
36 views

Why does “Connection Failed: 2002” display randomly on my PHP/MySQL website?

I'm running CentOS 6 with Apache/PHP/MySQL. PS. I'm sort of a novice at Linux, but I did my best to gather info before coming here. I'm now a bit stuck. I recently upgraded PHP to version 5.5.12. I ...
2
votes
1answer
56 views

I cant save files in /var/www/html

I'm running Centos 6.5 and I'm having problems saving my files to /var/www/html. The folder currently belongs to root and I have gone through everything from SELinux to configuration procedures, but ...
0
votes
1answer
35 views

How to reconfigure PHP

We have a new linux server CentOS 6.5 with Plesk. Default PHP is 5.3.3, I have installed PHP5.4 & 5.5 on the server. I am a beginner on linux. Actually, I don't know how to install software on ...
0
votes
1answer
212 views

mcrypt, EPEL and CentOS 6.4

I am having issues installing php-mcrypt. I am not an administrator of any level. I have performed the following. Installed EPEL Installed REMI Configured EPEL Updated YUM Cleaned YUM Installed ...
1
vote
0answers
442 views

mysqld dead but pid file exists

Webserver was running fine for weeks then suddenly: I can access, but I am unable to log into Webmin I can access Magento, a php-based storefront application, but I am no longer able to log in and ...
0
votes
1answer
60 views

PHP on centos 6 not working

I have installed PHP, MySQL, Apache on CentOS 6, now I have restarted the Apache and mysql, to test PHP i have created a index.php on /var/www/html/test/ now once i go to localhost/test/index.php then ...
2
votes
1answer
128 views

Executing PHP with CronJobs in CentOS 6.4 not working?

So I've spent around 2-3 hours now and some times researching, I found several of the same responses online but none seem to work! I'm trying to execute a PHP script every minute (as a test), but it ...
2
votes
1answer
185 views

Downgrade PHP 5.4 -> 5.3 on CentOS 5.10 [closed]

Due to being in some dependency hell and some issues with PHP 5.4, we downgraded from PHP 5.4 -> 5.3. Since doing so, a few of our web apps are acting strange. E.g: # php index.php Results in: ...
1
vote
0answers
142 views

how to resolve yum replace php-common --replace-with=php55w-common error? [closed]

How to resolve yum replace php-common --replace-with=php55w-common error on CentOS 6.5? root@server [~]# yum replace php-common --replace-with=php55w-common Loaded plugins: fastestmirror, replace, ...
2
votes
1answer
49 views

How can I list all the dependencies necessary to install PHP-Soap?

I have a server running Centos 5.10 with no internet access that I control remotely on which I'd like to install PHP-Soap. I also have an identical box in the office which is a clone of the remote ...
0
votes
1answer
75 views

libphp4 Not Found?

I'm using CentOS 6.5 and Apache 2.2.15 I've installed PHP 4.3.11 by download: wget http://museum.php.net/php4/php-4.3.11.tar.gz tar zxvf php-4.3.11.tar.gz cd php-4.3.11 ./configure make make install ...
0
votes
0answers
65 views

How To Install PHP on CentOS by download packages?

I'm using CentOS 6.5 and I need to install PHP 4.3.11 i can't use "yum install php" because it'll install the latest version of PHP. So i use these command: wget ...
2
votes
0answers
407 views

Can't Install ImageMagick on Centos using Yum

I am trying to install ImageMagick on my dedicated-virtual Centos server for use with PHP. I first ran the following commands successfully: # yum install gcc php-devel php-pear # yum install ...
0
votes
0answers
38 views

Help required for LAMP Stack fail-over Configuration

I am using cloud servers of digital ocean for last some months. Recently One of my cloud servers disappeared from panel with backups @ ubiquity, the server co guys put it back after 1 day. However my ...
1
vote
0answers
1k views

How to install PHP 5.2.4 in CentOS release 6.5 (Final)?

Folks I need to install PHP 5.2.4 in CentOS release 6.5 (Final). My souces list are: # CentOS-Base.repo # # The mirror system uses the connecting IP address of the client and the # update status of ...
1
vote
0answers
42 views

rpmbuild library register for 'requires'

Big Picture: I am building an in-house rpm for a customized php. I build an rpm which works, but generate library requirements that I can't seem to meet without using 'nodeps', which I want to avoid ...
1
vote
1answer
219 views

run a php script in centos and time and timeout

I want to run a php script in centos ( /usr/bin/php file.php ), and it takes long time to execute,and in the middle of executing , it stops running , and does not give me any errors. and I'm sure that ...
0
votes
0answers
175 views

php Mails not send with in domain

My setup : Our current server 90.0.0.50 [example] which is containing domain testdom.com. testdom.com's MX record points to Google mail. Due to some issues we need to host our domain on some other ...
1
vote
1answer
304 views

ERROR: could not find driver after changing from mysql to mariadb

mysql was working fine but I wanted to give mariadb a try on a new server I have going. However I am having an issue where all my php websites seem to have issues communicating with mariadb. Webmin ...
3
votes
1answer
715 views

Does segfaults mean bad memory

This is a brand new server with a new install and fresh compile of Apache/PHP with nothing crazy. Just a WordPress site hosted and I get the following. Could this just mean bad RAM? If so how can I ...
1
vote
1answer
3k views

PHP Upgrade Error (PHP 5.3.3 to PHP 5.4.19 on CentOS 6.4)

I'm using CentOS 6.4 and I was following this tutorial in order to upgrade PHP from v 5.3.3 to v 5.4.19 but I got the following error: Error: php54w-common conflicts with ...
0
votes
1answer
900 views

Difficulty installing PHP from source to CentOS 6.4

The problem: After installing PHP from source, functionality is not present - my phpinfo test page does not work. If I use yum to install from the repository functionality is restored. Why am I ...
1
vote
2answers
624 views

Minimize PHP.CGI.Argument.Injection and further hardening of the Centos 6.4 web server

We have Centos 6.4 server with a physical firewall. We keep seeing quite an number of PHP.CGI.Argument.Injection is detected by the firewall. On the server itself we have done the basic apache ...
2
votes
3answers
6k views

Cannot install PHP packages in CentOS

In CentOS 6.3 (Edit: updated to 6.4) I can't install any PHP (MySQL, and many other) packages. For example output of yum install php-devel is: Loaded plugins: fastestmirror Loading mirror speeds ...
1
vote
1answer
5k views

Possible to install PHP 5.2.17 on a new CentOS 6.4 system?

I'm trying to set up CentOS 6.4 (Linux 2.6.32-358.11.1.el6.x86_64) with a specific version of PHP (5.2.17) as it is required by an app I'm trying to install. I've downloaded the PHP version and ...
0
votes
3answers
1k views

Linux mail client that can trigger a PHP script to parse email received

Is there any simple text-based mail client that I could use that could trigger a PHP script to parse mails received from the users? I have a PHP application that sends email out to users and it would ...
1
vote
1answer
220 views

Access Remote files through http path

I am using lamp on CentOS 6. Application code is written in CakePHP. Application files path is "/var/www/html/my_app". Another file server is mounted with an Application Server. Mounted path on ...
0
votes
0answers
108 views

uploading from Netbeans to remote CentOS server failed

I have a php web application on Netbeans on my Ubuntu , and server is CentOS on a virtualBox . Suddenly uploading to server stopped and I'm getting these errors for non-root user : Failed: file ...
0
votes
0answers
309 views

centos 6.3 apache local network not working

I have clean installed centos, apache, mysql, php and have my php pages running fine at 192.168.1.66. I type that ip in on another computer (macbook) on the same network and get nothing. Page time ...
0
votes
1answer
370 views

Installing Ioncube loaders without issues CentOS 5.9

Seem to be having issues installing Ioncube loaders on CentOS 5.9. I followed this guide to install Ioncube: but it's still not working on the site at all, I keep getting this error on BoxBilling, ...
0
votes
1answer
151 views

Bash config files being read in contradiction to `man bash`

While trying to determine the differences between .bashrc and .bash_profile I notice that .bashrc is never read, and that .bash_profile is only read from SSH, but not from PHP. This seems to ...
0
votes
4answers
6k views

HTTPd shows PHP code instead of executing it

My setup: # grep php /etc/httpd/conf/httpd.conf LoadModule php5_module modules/libphp5.so AddType x-httpd-php .php AddHandler php5-script .php # grep PHP /etc/httpd/conf/httpd.conf PHPIniDir ...
2
votes
2answers
3k views

Fatal error: Class 'HttpRequest' not found

Whilst trying to make this request I have this error. I have tried to run "sudo pecl install pecl_http" but always fails. Could not find curl/curl.h After I have tired(yum instead of apt-get ...
0
votes
2answers
5k views

Updating PHP 5.3 to 5.4 in CentOS

I followed this tutorial to update PHP from 5.3 version to 5.4. My distro is CentOS 5.5. After running the following command: yum --enablerepo=remi,remi-test install httpd php php-common I get ...
3
votes
2answers
4k views

Unable to install the php-posix package on CentOS 5.6

I have the following PHP packages installed on my CentOS 5.6 host and I am trying to install php-posix. When I run yum install php-posix I receive an error saying that php53-common conflicts with ...
0
votes
1answer
836 views

How to easily maintain the latest versions of Apache/ MySQL/ PHP on CentOS 6.2?

We have a few servers running CentOS 6.2 deploying web applications using Apache/ MySQL/ PHP. In the past we've just regularly run "yum update" to keep all the software up to date. As of right now ...
3
votes
3answers
1k views

Trying to update php on CentOS 5.7

Apologies in advance - I'm not a good Linux user by any stretch of the imagination. I have a CentOS 5.7 dedicated server on which I host a few websites. I currently have php 5.2.10 installed, but ...
0
votes
1answer
1k views

How to remove Apache from CentOS while keeping php 5.3

I have a problem with removing Apache from my CentOS install. First of all I installed lighty (lighttpd) and then I tried to install php53 which httpd was included with it. I've configured lighty ...
1
vote
1answer
633 views

cURL on Linux not compiled, although installed

cURL is not compiled into PHP. I'm running: [root@vps ~]# cat /etc/issue CentOS release 5.7 (Final) Kernel \r on an \m Then I execute yum install curl and yum install php-curl. Then: [root@vps ...
2
votes
3answers
2k views

installing ffmpeg-php on centos

With the help of this guide, I am trying to install ffmpeg using these commands: # cd ffmpeg-php/branches/ffmpeg-php/ffmpeg-php-0.6.1/ # replace 'PIX_FMT_RGBA32' 'PIX_FMT_RGB32' -- * # phpize # ...