0
votes
0answers
20 views

Can't access GPIOs when switching to systemd, but why?

I'm using this ARM AT91 Sam9x5ek Embedded Device, with my Linux Images made by a Buildroot. Usually my init-system is Busybox, now I changed it to systemd. Since then I can't access the GPIO anymore, ...
1
vote
1answer
60 views

WARNING: at kernel/irq/handle.c - after changing rootfs, but why?

today I changed from an image with initramfs to an image with separate kernel and rootfs. Theses images are used for an Embedded System (ARM9 SAM9G25), that is runnging with an Linux 2.6.39. During ...
1
vote
0answers
78 views

Why is my embedded Linux unable to detect the sd device?

I have this ARM9 SAM9G25 embedded System, running a Linux 2.6.39 Kernel and a Busybox. I put the Images (of the bootloaders, and the linux+initramfs) on a SD so that in the end the system is booting ...
3
votes
1answer
183 views

How to set the CPU freq. in Linux?

I'm using this ARM9 SAM9G25 embedded system, that when switched on, is only online for a few seconds and because I want to speed up the whole process, I'd like to check the CPU frequency, and set it ...
2
votes
1answer
131 views

How to do an automated measurement for the boot time for freshly build images?

I want to generate images for an embedded system and automatically measure the time they took for booting (especially for different systems). I'm using Buildroot to generate my Linux Images. I ...
1
vote
1answer
175 views

Buildroot OpenGL Capable Backend

I'm trying to configure QT 5 through buildroot and some options are not available with the message requires an OpenGL-capable backend. I'm using buildroot 2013.08-rc1 but the same message comes up ...
0
votes
1answer
42 views

Linux via Buildroot doesn't include alsa-utils

After following these instructions from here and from here, my booted Linux does not include ALSA-Utils like "aplay". But I have set all ALSA options. Any idea what's wrong? I also found this but I ...