Bootloader issues: what happens before the operating system itself starts.

learn more… | top users | synonyms

0
votes
2answers
55 views

Grub Recovery at Boot

So I'm not exactly sure what happened but when I went to start my computer today, it failed to boot and the only thing on the screen is a command line with "Grub recovery". I tried to repair what ...
1
vote
0answers
53 views

Where is my boot directory?

After going into developer mode on my Chromebook, I noticed something odd: chronos@localhost / $ ls / bin debugd dev etc home lib lib64 lost+found media mnt opt postinst proc root run ...
0
votes
0answers
125 views

KALI suddenly fails: Failed to start login service, booting impossible

The situation is as follows: I ran dist-upgrade I start my kali I choose the proper OS-entry in the grub-selection-list I enter my LUKS-encryption key The system boots The system-boot-process stops ...
0
votes
0answers
105 views

archlinux doesnt boot up correctly after reinstalling xf86-video-intel

I have a Thinkpad x201 Laptop, 2 months ago after installed archlinux on it sometimes my screenwas splashed 2 or 3 times in each day average. Today, I thought perhaps the Intel graphic driver was not ...
0
votes
1answer
80 views

module not loaded at boot

I'm on an archlinux 4.4.1-2 and I'm trying to set up a netctl service. Problem is that for netctl to work I need to have bcma and b43 loaded. Since these two are not out-of-tree modules I thought I ...
0
votes
0answers
163 views

EFI boot entry disappears

I have a problem, the Fedora 23 EFI boot entry keeps disappearing. Set-up is Asus Z170-deluxe motherboard, i7-6700k CPU and 2x16GB DDR4. BIOS is the latest 1602. Disk is NVME Samsung 950 Pro 512GB. ...
1
vote
0answers
56 views

Make changes to busybox/initramfs that are persistent?

I am in the process of recovering my 32-bit Debian Jessie box with a lvm+LUKS disk. I am coming back from a system that had a root partition but no boot partition. Grub executes, but either vmlinuz or ...
1
vote
2answers
87 views

System will not boot because boot partition is missing?

I deleted my boot partition several day ago and have not been able to recover it. To fix it, I installed the same image with the same parameters on a flash drive and then copied that boot partition on ...
3
votes
1answer
79 views

Does /boot need to be mounted on a separate primary partition?

I dual boot Windows 7 with Linux Mint. However, Windows 7's partition layout takes up all the primary partitions, leaving me with the option of one more primary partition or many more logical ...
0
votes
0answers
38 views

Cannot boot Debian “ata6.00: irq_stat 0x08000000, interface fatal error”

I'm running Debian 8 (Jessie). I tried to install a package but apt-get gave me an error about a read-only file system. I can't remember sudo emitted the error or apt-get. I found this question: ...
1
vote
1answer
198 views

How to Modify Android Boot Sequence in Order to Boot From an SD Card

I've been looking into how to boot Android form an SD card, and I came across this thread on XDA, but I am too much of a noob to understand it, and user has stated that she doesn't have the time to ...
2
votes
0answers
50 views

Mysterious 8 second delay in boot after grub

I have installed Fedora 23 (KDE spin) on an HP Prodesk mini 600 G2. There is one problem I can't quite figure out, though: after grub comes up, and I press enter on any kernel to boot, the screen goes ...
1
vote
0answers
183 views

kfd: error getting iommu info

I got this error during boot process. How i can fix it? [ 15.757121] kfd kfd: error getting iommu info. is the iommu enabled? [ 15.757182] kfd kfd: Error initializing iommuv2 for device (1002:...
0
votes
0answers
34 views

Plymouth respawn failing causing Boot to hang - Mint 17.3

I've posted on here before that booting Mint 17.3 was often hanging mid boot. With the help of the fellow member here, I identified what I thought was the problem, but it soon returned. After going ...
0
votes
0answers
873 views

Linux Mint Cinnamon 17.3 (Rosa) Not Booting after Restart

I am having some serious issues. I am trying to run Linux on my HP Pavillion g6 laptop which has a AMD A10-4600M. I first tried Ubuntu, ultimately I was unhappy with that, but experienced the same ...
1
vote
1answer
114 views

/boot symlinks do not match current kernel version

I'm a bit puzzled on the following: I have a multi-kernel system, with a default one set by grub.conf, which is the 3.6 ; what I don't understand is why when I list the files in /boot/ I see the ...
3
votes
3answers
97 views

How can I ask a defined server what to boot

What options are available to accomplish the following boot scenario? On boot (before boot) contact a defined webserver and ask what to boot (normal answer: boot from local hard drive; alternative ...
0
votes
0answers
580 views

Debian Jessie start rpcbind and nfs-common at boot with systemd

On my Raspbian (based on Debian Jessie), I need to start at boot rpcbind and nfs-common services because I need them to start autofs at boot for a NFS mount. Since Debian Jessie now has moved to ...
1
vote
0answers
107 views

Error booting kernel 4.5.0-rc1 on Encrypted HDD

I cloned the Git tree of the mainline Linux Kernel and compiled it(version 4.5.0-rc1). After compiling with default configuration (make defconfig) I installed it. In the grub menu I can select this ...
0
votes
0answers
27 views

RAPL PMU detected, API unit is 2^-32, 4 fixed counters 655360 ms ovfl timer

I compiled my own kernel (version 4.1.5) using the commands: #emerge --ask sys-kernel/genkernel #genkernel all And then I installed grub2 using these commands: #emerge --ask sys-boot/grub #grub2-...
0
votes
2answers
264 views

NFS mount at boot with autofs on Raspbian Jessie

I'm trying to configure my RPi with Raspbian Jessie to use autofs to mount at boot a NFS share from my QNAP NAS. The manual mount with mount -v -t nfs server://share /mnt/share works and also the ...
1
vote
0answers
32 views

How should the `crypto` kernel parameter be passed?

I've encrypted a root drive using a cipher with this format: <cipher>-<chainmode>-<ivmode>:<ivopt>. Let's call this [CIPHER] for short. To boot from this device, certain ...
0
votes
0answers
101 views

Manually move kernel image to /boot directory

I have compiled my own kernel on Gentoo (following the handbook) and then I have moved the bzImage to /boot/vmlinuz-4.0.5. But when I boot the system I get the Grub2 shell. What am I doing wrong? ...
0
votes
1answer
143 views

Kali Linux Graphic Interface = Black Screen

Helloe veryone ! I have Kali Linux since a month now, and the "F7" just crashed. When I boot, I can go till the Grub, I boot (I can see around 5 "[FAILED]" instructions in the list), and finally, ...
0
votes
0answers
14 views

Cryptsetup boot many devices “timeout”

On my server, the crypttab file has 13 entries for every hard drive connected to it. 2 are for the system partitions, 2 are for the backup system and 9 are for the mediaserver and nfs stuff. Currently,...
0
votes
1answer
1k views

Arch Linux grub installation error “airootfs”

I was following the official installation tutorial. Everything was smooth until the boot loader section. I had encountered the error of /usr/bin/grub-probe: error: failed to get canonical path of '...
1
vote
0answers
24 views

timeout when initiating a sshfs connection

I have following line in /etc/fstab 192.168.1.10:/data /mnt/data fuse.sshfs rw,noauto,nosuid,nodev,noexec,_netdev and following line in /etc/rc.local: mount /mnt/data During boot process, ...
0
votes
0answers
28 views

Need a hint about system's verbiage at bootup

I've got a dual boot W10/Ubuntu 14.04 laptop. I use GRUB2 as a boot loader. In the BIOS I chose "Legacy BIOS" option (the laptop was purchased with EUFI enabled system and W8 OEM). I don't know, maybe ...
1
vote
1answer
476 views

Kali Linux Rolling doesn't boot, freezes after login

I have recently installed Kali Linux Rolling from my usb. Everything went fine and I have booted into it once and it worked well. But when I booted into my mac partition and then tried to boot back ...
0
votes
1answer
35 views

Start radio with systemd service

On a headless RaspberryPi, I would like to automatically start radio on boot, without any human action. I have written this file as /etc/systemd/system/radio.service : [Unit] Description=Radio Wants=...
1
vote
1answer
80 views

Kali Linux won't boot from USB

I've been trying to boot Kali Linux from my 8gb USB. I get to where I'm supposed to choose from one of the various options: Live, Persistent, Persistent With...... etc etc. I go on and select one, say ...
0
votes
0answers
28 views

How can one boot Kodibuntu from grub2 when installed on Intel Stick?

I did everything as described previously "user145862" link: How can one boot Kodibuntu live USB from grub2?, which is able to install on kodibuntu Intel Stick. But after the restart sysyemu not want ...
0
votes
0answers
60 views

How do I boot into Ubuntu 12.10 or higher WITHOUT using grub2, but just grub?

I have a machine I SSH into on a Rackspace virtual XEN environment originally built as Ubuntu 11.04, but I have since upgraded to 12.04 with a grub 1.99 on menu.lst, not a grub2. The do-release-...
0
votes
1answer
28 views

How do you set a service run as a non user at boot time?

I have a PostgreSQL server that I start on the command line when I log on after I logon. It doesn't run as the normal PostgreSQL service, but under my name with the data stored in my home directory, ...
1
vote
0answers
100 views

Configuring update-rc.d script for startup only

I'm running Yocto Poky and have a test script I want to run on startup only. The script just appends date to a file echo $(date) >> ~/test.txt. I add it to the daemon with: update-rc.d -f ...
1
vote
0answers
97 views

Several devices missing from lspci— why?

I've installed Debian 8.3 on an Acer Aspire, model number SW5-012, with the stock kernel 4.4.0-trunk-686-pae. Mostly, it's working fine. But there are a few devices which the kernel claims not to be ...
0
votes
0answers
91 views

Computer doesn't boot ANY device after installing debian

During a Debian installation, everything went smoothly. However, for some reason it failed to install both the GRUB and LILO bootloaders. I tried thrice to get my installation to work. The first two ...
1
vote
1answer
1k views

Kali Linux 2.0 broken, doesn't boot

I have a Macbook Pro with a partition of Kali Linux Sana 2.0 on the macintosh hard drive. I haven't used it for a while but today I decided to boot into it. It booted as usual, I logged in etc. and ...
0
votes
0answers
77 views

Debian Jessie grub-install broken in some mysterious way

I did an apt-get dist-upgrade today (2016/02/01), and now my system won't boot. The only reason I can get in at all is that there's a copy of Ubuntu installed as well, and I can boot it from the BIOS....
-1
votes
2answers
239 views

GUI gone after apt-get upgrade on clean install, Ubuntu Wily-

I was pointed here from AskUbuntu because my question was about an unsupported Ubuntu derivate, here is the copy-pasted question: I upgraded my fresh install of Netrunner 17 Horizon (Ubuntu-based, ...
0
votes
0answers
216 views

Backbox(Ubuntu 14.04) takes too long to boot

I've recently started encountering this problem that my system takes too long to start and also to shut down. I searched it and found that dmesg shows the logs of processes at boot time. Here's my log ...
3
votes
2answers
538 views

How does Grub Stage1, exactly, access/load stage 2?

This is my first ever question, I have put this question in front of Red Hat Instructors but didn't find any satisfying answers. I'm using RHEL/CENTOS6, GRUB Legacy 0.97, and have consulted heaps of ...
1
vote
1answer
299 views

Problem mounting CIFS VFS via fstab at boot

I'm running Raspbian Jessie on a freshly installed Raspberry Pi Model B+. I used apt-get update and apt-get upgrade some hours ago, the system should be up to date. I'm trying to mount a USB disk ...
1
vote
0answers
45 views

Boot problem in lubuntu

I have an old msi u123 set up with lubuntu running 15.10. It works fine, but on each boot, I end up in a Recovery menu. I can select "resume" and it boots fine. I would like to try to correct whatever ...
0
votes
1answer
34 views

Extlinux.conf on separate partition?

I'm trying to configure a system with separate boot partition, booted with U-boot and extlinux loader. Could I locate extlinux.conf on separate partition, but kernel (zImage) and device tree on root ...
1
vote
1answer
69 views

Cryptsetup: LVM is missing (on a system without LVM)

So, I have a problem with the partitions setup of my laptop. I will try to include as many details as possible in order to make it easier to help. In the past, I had an ubuntu 15.10 system on my ...
3
votes
1answer
174 views

FDT relocated by U-Boot cannot be accessed by Linux (in highmem)

We run a customized version of U-Boot on an ARM-based embedded system and would like to load Linux 4.3 with a device tree blob. The system features 1GB of RAM of which the top 128MB are reserved for ...
0
votes
0answers
60 views

Adding vmlinuz to EFI boot adds an unbootable japanese caracter to the boot menu

I'm trying to setup a boot on an encrypted partition so I enter this command : efibootmgr -d /dev/nvme0n1 -p 1 -c -L "Arch Linux" -l /vmlinuz-linux -u "root=/dev/nvme0n1p6 rw initrd=/initramfs-linux....
0
votes
0answers
17 views

When does Plymouth starts and ends?

I am currently creating a custom Plymouth Theme/Script for my operating system. Thus i want to know when does Plymouth gets started. Which function calls it? How does it start up and display nice ...
0
votes
0answers
93 views

How to setup efibootmgr when root / is an encrypted partition?

Just wondering how to setup efibootmgr when root / is an encrypted partition. I'm installing archlinux on an encrypted root and their wiki says that i should use # efibootmgr -d /dev/sdX -p Y -c -L "...