Debian package manager

learn more… | top users | synonyms

2
votes
1answer
306 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
2
votes
1answer
104 views

apt-get purge <packages> works fine, aptitude still has <packages> marked as installed and reinstalls them

I've created a Rubygem to help with removing old kernels that have built up over years and are eating disk space. (My laptop had 19 kernels on it alone, and on a small SSD...) I want to use apt-get ...
2
votes
1answer
253 views

Weird issue with unmet dependencies when cloning package states from earlier installation on same machine

I've been doing the usual routine of saving the package selections and also marking the packages as auto or manual as outlined in the question and answer here: Restoring all data from backup of dpkg ...
1
vote
1answer
52 views

dependency error when run apt-get -f install in debian squeeze

I can't install or remove packages in Debian. When I type apt-get -f install to fix the problem I get this error: Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
100 views

Aptitude regex engine

I was trying to lookup the versions of libdb in the debian archives with something like that: $ aptitude search '~S~ndev$(~nlibdb~(\d~|-~)!~v~rnative)' which didn't work as expected so I changed ...
0
votes
1answer
29 views

Why does aptitude refrain from upgrading [UNAVAILABLE] packages?

Why does aptitude refrain from upgrading in the example below? Is it solely because existing package metadata is not in cache anymore? If package is marked as [UNAVAILABLE], does it mean the only ...
0
votes
1answer
30 views

Old Debian packages install sources

I'm trying to install make program using aptitude install make in my Debian. Unfortunately I have error : Err http://debian.balt.net lenny/main make 3.81-5 404 NotFound What I need to do to make ...
2
votes
0answers
221 views

Why I was able to fix a broken package with aptitude but I could not with either apt-get or synaptic?

Yesterday I upgraded my Debian Testing and Audacious stopped to work. Troubleshooting I found that the problem was that it was updated to a recent version but the needed plugins were not. I tried to ...
2
votes
0answers
70 views

What does apt need to be healed of a bad setup?

I made a couple of earlier posts regarding a libssl-dev that, it seemed, was not removable. Some of the replies touched on that there was a problem with apt, and now that someone posted the command to ...
1
vote
0answers
27 views

Aptitude - uninstalling autoinstalled packages that are recommended by other packages

I am running a Debian Wheezy install on a system where space is tight. Hence, I've turned off the "Automatically install recommended packages" option. The problem occurs if I install a package which ...
1
vote
0answers
72 views

Aptitude installing jre

I am trying to install jre on my debian 7 kali box, but I keep getting these faulty errors. I tried installing it through aptitude and it fails at the end. The result is: dpkg: error processing ...
1
vote
0answers
968 views

How to deal with a package “not upgraded” using aptitude?

I'm (still) on Debian Squeeze. When I try to upgrade the system, here's what I get: [09:20]/root# aptitude upgrade No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly ...
1
vote
0answers
263 views

crossplatformui error in Mint 11

Whenever I try to install something in my system it generally installs but shows some error related to "crossplatformui". I don't know what it is and how to remove it. I am printing here a sample ...