APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

10
votes
1answer
4k views

How can I install more recent versions of software than what Debian provides?

Suppose I want a more recent version of software than is available for my current version of an operating system, what can I do? Cases to consider: There are semiofficial/official sources of ...
4
votes
2answers
1k views

What information do I need to solve an APT dependency issue?

I've seen several times people with unmet dependencies, which apt-get doesn't tells straightforward what's the problem, like this one: The following packages have unmet dependencies: ...
192
votes
10answers
74k views

What is the real difference between “apt-get” and “aptitude”? (How about “wajig”?)

I know that both apt-get and aptitude are command line package management interfaces on Debian derived Linux, with different options, but I'm still somewhat confused. Under the hood, aren't they ...
47
votes
6answers
35k views

List packages by installation date

How can I list installed packages by installation date? I installed a lot of stuff to compile a certain piece of code, and I want to get a list of the required packages, which are the ones I installed ...
67
votes
4answers
159k views

How to add repository from shell in Debian?

In Ubuntu one can add a repository to apt-get via the following command - sudo add-apt-repository ppa:yannubuntu/boot-repair As Ubuntu is based on Debian code base, I was expecting that the same ...
27
votes
3answers
25k views

How to install a single Jessie package on Wheezy?

I want to install a single package (and its dependencies, but only to the extent those are not satisfiable in Wheezy) from Debian Jessie onto my Wheezy system, without upgrading "everything and the ...
16
votes
2answers
12k views

Pacman option to assume “yes” to every question?

When installing software in debian systems we can put something like this: sudo apt-get install -y chromium-browser that way the installation occurs automatically, whitout asking to confirm ...
4
votes
2answers
287 views

How to make apt recognize an installed tar package?

I've installed Oracle Java. I want to be able to remove OpenJDK, but when trying to do so apt wants to install another version of Java. How can I configure apt so that it knows I already have a ...
53
votes
4answers
59k views

How can I update to a newer version of Git using apt-get?

I've just set up a new machine with Ubuntu Oneiric 11.10 and then run apt-get update apt-get upgrade apt-get install git Now if I run git --version it tells me I have git version 1.7.5.4 but on my ...
26
votes
1answer
78k views

“E: Sub-process /usr/bin/dpkg returned an error code (1) ” What does this mean?

I've seen this message several times whenever someone has a problem installing, upgrading or removing some piece of software, but I wonder, what does it mean, and more importantly, is possible to ...
17
votes
2answers
22k views

How to undo sudo add-apt-repository?

I run sudo add-apt-repository ppa:noobslab/indicators to install my-weather-indicator but it requires GTK3 and I don't want to proceed. So I'd like to undo that command. I'd checked my ...
12
votes
2answers
13k views

What packages are installed by default in Debian? Is there a term for that set? Why some of those packages are `automatically installed` and some not?

It's a very simple question, but I wonder, is there a term to refer to the subset of packages that is automatically installed by Debian distribution? I though that it had something to do with ...
11
votes
3answers
12k views

apt-get - autoremove wants to uninstall Gnome

As empathy 2.30 in Debian Wheezy didn't meet all my preferences I tried out empathy 3.1 from experimental, using the command: apt-get -t experimental install empathy I had to find out, this version ...
22
votes
7answers
8k views

Which installed software packages use the most disk space on Debian?

Disk space on my root partition is running low, so I want to delete some applications from the system. How can I see which software packages use the most disk space? Is it possible to view that from ...
12
votes
3answers
2k views

How can I reliably “hold” a package in Debian?

I have a package in Debian that has been manually patched (not ideal, I know) that I must hold at its current version so upgrades don't overwrite the patched changes (I will manually inspect and apply ...
8
votes
1answer
8k views

How to install some packages from “unstable” Debian on a computer running “stable” Debian?

On a computer running "stable" Debian, when trying to install a package which is in the unstable list on the Debian web site using the aptitude install <package>/unstable command, I get output ...
7
votes
1answer
2k views

What is the difference between the “jessie” and “jessie-updates” distributions in /etc/apt/sources.list?

The debian wiki page for the apt sources list gives this example file: deb http://httpredir.debian.org/debian jessie main deb-src http://httpredir.debian.org/debian jessie main deb ...
4
votes
1answer
1k views

Are bsdutils, coreutils, and busybox all necessary in a Debian install?

I first installed Debian with a netinst CD without networking, then edited /etc/apt/sources.list to point to the main repository, then ran dhclient eth0 to set up networking. Then I installed less. ...
3
votes
3answers
21k views

“sudo: apt-get: command not found.” after removing some packages

Recently I executed this command: sudo apt-get remove debian-keyring debian-archive-keyring To prevent this such error message: WARNING: The following packages cannot be authenticated! openerp ...
3
votes
4answers
6k views

Automatically update GCC to a later release without upgrading distribution

My understanding is that C++11 support in G++ 4.7.2 wasn't great (it gives me a warning everytime I try to compile my C++ code, presumably there are good reasons for these warnings), so thought I ...
3
votes
1answer
647 views

apt installing more packages than specified as dependencies

I was trying to install texmaker from the repository. For installing the texlive I followed the steps described here. For this the control file I used is this. It has the file texlive-binaries in it. ...
112
votes
9answers
65k views

Convince apt-get *not* to use IPv6 method

The ISP I work at is setting up an internal IPv6 network in preparation for eventually connecting to the IPv6 internet. As a result, several of the servers in this network now try to connect to ...
56
votes
4answers
125k views

Install from a deb file, by dpkg -i or by apt?

I have a deb package for installation. Shall I install by dpkg -i my.deb, or by apt? Will both handle the software dependency problem well? If by apt, how can I install from the deb by apt?
17
votes
1answer
6k views

apt-get install without debconf prompt

I would like to install chef via apt non-interactively, but by default, apt installation brings up this prompt: Is there a way to skip this step during installation or pass a value to apt install? ...
6
votes
5answers
702 views

Correlating filename with package [duplicate]

Say, I'm given a filename like libasound.so.2. Is there a way to query the package manager to correlate the filename with its corresponding package? I'm interested to get answers for any package ...
8
votes
3answers
10k views

archive.ubuntu.com missing raring-updates

My Linux Mint 15 install on VirtualBox was working great up until about two days ago, when the updater started throwing a ton of errors and refuses to progress with any apt-get update, apt-get ...
6
votes
1answer
5k views

The difference between deb versus deb-src in sources.list

I don't understand the difference between these two lines in my sources.list, please explain: deb http://mirror.optus.net/debian/ testing main contrib non-free versus deb-src ...
5
votes
1answer
2k views

Aptitude on Debian 6.0.4 “media change” to CD ROM

I've just installed Debian 6.0.4 on VirtualBox, and I'm trying to install g++. So, into the terminal I typed: aptitude install build-essential But it's trying to get the package from disk: Media ...
4
votes
5answers
4k views

How to free space on a completely full volume?

I am using Linux. And within an uncontrolled event, my 4GB system disk is full. When I try to uninstall some program by sudo apt-get purge program-name, it gives me this error: /usr/bin/mandb: can't ...
4
votes
2answers
8k views

Invalid signatures when running apt-get update

I'm new to linux and am trying to run an update, I get a lot of "Hit"'s and "Ign"'s but in the end I get these errors, does anybody know what they mean and how I can fix them? W: GPG error: ...
4
votes
1answer
1k views

listing packages in Debian, a la `dpkg -l`, but including the package origin/source

I want to list all packages of the form $ dpkg -l libav\* but in addition to this output, I would like the origin/source (I'm not sure of the preferred term) of each package. If the package doesn't ...
2
votes
2answers
1k views

How to download Debian package's source code?

I want to read source code of some package in Debian, how can i do that?
5
votes
2answers
301 views

Upgrading packages automatically

I'm fairly new to using servers (debian 7) and I'm currently running cron-apt to e-mail me when there are new upgrades available. Is the following command safe to run when new upgrades are shown? ...
3
votes
1answer
332 views

Debian Jessie is installing too many backports

I have Debian Jessie and have added backports (according to these instructions): echo "deb http://http.debian.net/debian jessie-backports main contrib non-free" | sudo tee ...
2
votes
1answer
396 views

How to get all the dependencies for a package

I'm trying to get all the dependencies for a package..for example apache2 I've tried to use apt-cache depends apache2 but it gives some dependencies but when I want to install apache2 on a live CD it ...
2
votes
1answer
880 views

Installing packages by importing the list with dpkg --set-selections

I've tested this using two virtual machines running Lubutu. On the first I Installed a couple of programmes (VIM and cowsay) then ran : sudo apt-get update sudo apt-get upgrade sudo dpkg ...
2
votes
1answer
9k views

Fixing a broken packet system (apt-get)

After I made a system upgrade (apt-get upgrade) on a debian box, I get an error everytime i tries to use apt-get. Example: # apt-get -f install Reading package lists... Done Building dependency tree ...
2
votes
1answer
4k views

Unable to install skype on LMDE,how to resolve these dependencies?

I have downloaded "multiarch" .deb file for latest skype and unable to install it on latest version of LMDE (linux mint debian edition Xfce x86_64). e.g step one : sudo dpkg -i ...
1
vote
2answers
528 views

The following packages have unmet dependencies

Every time I try to use apt-get install or remove or purge on my Debian, I have this error pop up: The following packages have unmet dependencies: libimage-magick-q16-perl : Depends: ...
1
vote
1answer
2k views

Backup and Restore list of installed packages and APT sources

I commonly reinstall Ubuntu and back up my APT stuff [sources, keys and installed package lists] using the tutorial at http://askubuntu.com/a/99151/371765. However I commonly also remove software such ...
1
vote
1answer
194 views

Why does bash output data instead of executing, when a script is piped?

I'm running the following script on Ubuntu 14.04: #!/bin/bash apt-get purge -y nginx apt-get install -y nginx date When I run it like cat /tmp/script | bash, apt-get starts installing, then ...
1
vote
0answers
507 views

Make and apt-get Have Stopped Working

So I downloaded the non-free broadcom driver(b44) for my debian install, however when I try to make it I get the following error: make make -C /lib/modules/2.6.32-5-amd64/build ...
1
vote
1answer
4k views

How to install LXDM instead of GDM3?

I'm running Debian Wheezy and my default Display Manager is GDM3, and I would like to replace it with LXDM. The problem is that I'm trying to run # apt-get install lxde and it's not working, what am I ...
0
votes
1answer
1k views

Cannot install packages in Mint: “Unable to fetch some archives”

I'm running Linux Mint 16 (Petra). I was able to install packages normally until, at least, april 18th (two weeks ago). Since yesterday I cannot install packages anymore. For example, if I try to ...
186
votes
5answers
32k views

What's the story behind Super Cow Powers?

As we know, apt-get has Super Cow Powers and aptitude does not: $ apt-get --help | grep -i cow This APT has Super Cow Powers. $ aptitude --help | grep -i cow ...
59
votes
10answers
68k views

List available updates but do not install them

I want my cron-run reporting script to notify me in case there are updates for my packages. Is the a way to make apt-get give me the list of available updates but don't do anything more?
18
votes
5answers
11k views

How to see package version without install?

I want to see the version of a package before I install it. How can I do this?
35
votes
2answers
22k views

What is yum equivalent of 'apt-get update'?

Debian's apt-get update fetches and updates the package index. Because I'm used to this way of doing things, I was surprised to find that yum update does all that and upgrades the system. This made ...
11
votes
1answer
5k views

Blocking kernel updates with dpkg

I'd like to block all distribution-shipped kernel updates due to a nasty thing that recently happened to me. (I'm on a Ubuntu 12.04 amd64 derivative.) I'd like to block all updates to installed ...
8
votes
1answer
22k views

Unable to install ia32-libs in Debian Wheezy

I was trying to install ia32-libs in Debian Wheezy. I got the error The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-i386 but it is not installable E: Unable to correct ...