APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

0
votes
1answer
25 views

Installing Steam on Debian Wheezy

I downloaded the .deb file from the steam website, but couldn't install it as it complained about having and "outdated" version of libc6. I look around and apparently I have to add jessie sources to ...
4
votes
2answers
2k views

How to manually insert a repository in source.list?

I tried to add a new APT repository using this command: add-apt-repository ppa:atareao/atareao but I got a "command not found" error. I tried installing python-software-properties, but it's already ...
3
votes
2answers
28 views

Get package version of file

I've deleted a file in /etc provided by package packageA. Is there a way that I can reinstall only that file, provided I know where it is and which package provides it? I'm running Ubuntu 12.04 and ...
5
votes
2answers
235 views

Find out what 'apt-get install' did

This might be a really newbie question but here we go: How can I find out what commands a package ran to install the software with apt-get install <package>? For example, if I install a ...
1
vote
1answer
20 views

“Packages have unmet dependencies” but I don't want to install these packages anymore. How do I clean this?

You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: fglrx-driver : Depends: libfglrx (= 1:14.4.2-1kali1) but it is not going to be installed ...
12
votes
3answers
1k views

In Debian based systems, how do we purge configuration files of packages that have already been uninstalled?

To be more specific, I would like to do the equivalent of adding the --purge flag to the following command sudo apt-get autoremove --purge [package name] to packages that are no longer on the ...
2
votes
2answers
96 views

Cannot install mysql-server-5.5/the following packages have unmet dependicies

I'm using ubuntu 14.04. I tried entering mysql with the following command: mysql -u root -p and I got the following message: The program mysql can be found on the following packages: ...
0
votes
0answers
26 views

I may or may not have broken grub during a sudo apt-get upgrade [on hold]

I'm very new to ubuntu and server administration as a whole, so please forgive my ignorance. I just did sudo apt-get upgrade and a gui came up saying something like this A new version of ...
0
votes
1answer
990 views

Packages still not found even after apt-get update

I am working on a Linux Mint 16 computer and since recently, every time I want to install something via apt-get install, the log message says that the packages couldn't be authenticated. I go ahead ...
2
votes
1answer
360 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
4
votes
1answer
613 views

“Sub-process /usr/bin/dpkg returned an error code (1) ” What does this mean?

I've seen this message several times whenever someone has a problem installing, upgrading or removing some piece of software, but I wonder, what does it mean, and more importantly, how can I solve it? ...
0
votes
1answer
29 views

Why does this keep wanting to install Java 7? I don't want Java 7, can I somehow stop it from attempting?

Why does it keep wanting to install oracle-java7-installer? Is there some way I can prevent it from attempting to do this? home@home-Vostro-220s-Series:~$ sudo apt-get upgrade Reading package ...
0
votes
0answers
61 views

Unable to connect to source.repository.backtrack-linux.org

I have a BackTrack5 r3 installed on VMware. As you see below I have internet access in it : root@bt:~# ping www.google.com PING www.google.com (173.194.70.105) 56(84) bytes of data. 64 bytes from ...
15
votes
3answers
1k views

Should I use “apt-get remove” or “apt-get purge”?

For uninstalling an app (or package) should I use apt-get remove package-name or apt-get purge package-name? What is advantage of any of them to other one?
0
votes
1answer
1k views

Debian 7: Add repository for gcc-4.8 and g++-4.8

I want to be able to sudo apt-add-repository with a ppa for gcc-4.8 and g++-4.8. I was able to do this on Ubuntu using (after adding the ppa) sudo apt-get install g++-4.8. So far I have been able to ...
4
votes
0answers
26 views

How to find Debian packages that would free up the most space

Say I have a Debian machine where I would like to free up space on '/' by removing useless packages. To find good candidates of packages to review, I would like to focus my attention on the largest ...
3
votes
3answers
3k views

Fixing broken packages in a Debian testing distribution

I'm playing around with Linux Mint Debian Edition (LMDE) in a VirtualBox instance to try it out and see if it'd be good for a main operating system for me. I'm pretty competent with most system ...
4
votes
2answers
40 views

How to prevent prompt that ask to restart services when installing libpq-dev

I want to install libpq-dev on my Vagrant machine. I install it with $ apt-get install -y libpq-dev During installation a prompt appears which asks if it's allowed to restart some services ...
1
vote
2answers
792 views

Registering Ubuntu Client With Spacewalk

Right now I'm just testing the process for some desktop machines I'll be managing so I have a fresh install of Ubuntu 12.04.04 LTS. We have a non-satellite spacewalk server that I'd like to have ...
1
vote
3answers
309 views

archive.ubuntu.com missing raring-updates

My Linux Mint 15 install on VirtualBox was working great up until about two days ago, when the updater started throwing a ton of errors and refuses to progress with any apt-get update, apt-get ...
-2
votes
0answers
25 views

Installing packages in Oracle Linux Server 6.5

This is the first time working on a non-Ubuntu distribution, I need to get the following packages, which in Ubuntu I just used this commands: sudo apt-get install libreadline6-dev sudo apt-get ...
2
votes
2answers
299 views

Hard drive partition and updating trouble

I'm new to linux and am using Linux Mint 15 Olivia. I am running it alongside windows 7 and I want to increase the size of my current linux hard drive partition. I read somewhere that I should install ...
1
vote
1answer
901 views

Installing php5-cURL on Backtrack leads to dependencies issues

I am trying to install a program called Glype on my computer for a proxy. I am using Backtrack 5 R3 and I have the latest version of Apache running on it. The problem I have is that Glype needs cURL ...
0
votes
2answers
2k views

Get errors when aptitude update

I get the following errors when aptitude update. These errors are after non-error updates. What do I do to fix this, but not remove the ppas, etc? Err http://ppa.launchpad.net Packages 404 Not ...
0
votes
1answer
336 views

Error installing gdb-arm-linux-gnueabi

I get an error when I try to install the gdb-arm-linux-gnueabi package. This is the error that I obtain when I run apt-get install gdb-arm-linux-gnueabi: $ env LC_ALL=C sudo apt-get install ...
1
vote
2answers
58 views

Fix dependencies without updating package?

I updated my Debian installation at home and it updated chromium to the (IMO) awfull 35.0 version. I removed it by using apt-get remove chromium and apt-get autoremove. I went here and grabbed the ...
1
vote
1answer
17 views

APT pinning or faking the version number of my own package?

I'd like to create my own repository for personal use across a number of machines. Packages will be signed as usual and some of the packaged software will be the same as provided by the official ...
1
vote
2answers
86 views

What information do I need to solve an APT dependency issue?

I've seen several times people with unmet dependencies, which apt-get doesn't tells straightforward what's the problem, like this one: The following packages have unmet dependencies: ...
1
vote
1answer
40 views

apt-cache policy gimp libgegl-0.2-0

I have tried to install Gimp on my Ubuntu 14.04, but I encountered an error: root@vitor-pc:~# LANG=C apt-get -f install Reading package lists... Done Building dependency tree Reading state ...
1
vote
0answers
34 views

Installing mysql-workbench from the testing ppa (Jessie) in Wheezy

I would like to install some packages from the testing branch without switching to it if possible. The big packages are things like xfce4 and mysql-workbench. I've done this by making a testing.list ...
2
votes
1answer
389 views

Weird issue with unmet dependencies when cloning package states from earlier installation on same machine

I've been doing the usual routine of saving the package selections and also marking the packages as auto or manual as outlined in the question and answer here: Restoring all data from backup of dpkg ...
16
votes
7answers
11k views

List available updates but do not install them

I want my cron-run reporting script to notify me in case there are updates for my packages. Is the a way to make apt-get give me the list of available updates but don't do anything more?
0
votes
0answers
20 views

Debian system: install specific packages from source automatically to boost the performance

On Debian /Ubuntu systems, how to set a list of packages which can be installed from sources automatically by apt-get or aptitude? The server is mainly for scientific computing and I would like to ...
1
vote
1answer
540 views

Cannot install ia32-libs-i386

I'm trying to install ia32-libs-i386, but it's giving me this error: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
1
vote
1answer
47 views

How do I make apt pick a certain package from a specific source?

I tried pinning the debian_testing source, but it's not really working (I want to pick version 0.10.29): Package: nodejs Pin: release a=debian_testing Pin-Priority: 1000 Here's the apt-cache ...
3
votes
0answers
68 views

Having some trouble authenticating via proxy in order to use apt-get successfully on a corporate network

Context Our server is on a corporate network, which requires corporate proxy authentication (e.g. enter corporate username and password). This is not an issue on the Windows machines on that network ...
1
vote
2answers
43 views

can I get a list of the debian packages I installed AFTER the OS installation?

Extending this question, I would like to ask, if there is a general term that groups all the packages that I have installed POST debian installation? Mind you that for clarity purposes, I refer to ...
5
votes
1answer
1k views

How to I install zabbix-agent over apt-get

Why is it that on my Ubuntu 13.04 system I can easilly install zabbix-agent by doing apt-get install zabbix-agent. When I do it in Debian 7.1, it says that the package zabbix-agent can not be found. ...
1
vote
2answers
247 views

Debian Wheezy problem with packages and architectures

I recently installed Debian wheezy on my desktop PC. Here is the uname -a command: Linux devnet 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1+deb7u1 x86_64 GNU/Linux Once the installation finished, I ...
20
votes
4answers
12k views

List packages by installation date

How can I list installed packages by installation date? I installed a lot of stuff to compile a certain piece of code, and I want to get a list of the required packages, which are the ones I installed ...
7
votes
1answer
4k views

How to install some packages from “unstable” Debian on a computer running “stable” Debian?

On a computer running "stable" Debian, when trying to install a package which is in the unstable list on the Debian web site using the "aptitude install /unstable" command, I get output similar to ...
2
votes
4answers
423 views

How do I automagically update GCC to a later release without upgrading my distro?

My understanding is that c++11 support in G++ 4.7.2 wasn't great (it gives me a warning everytime I try to compile my c++ code, presumably there are good reasons for these warnings), so thought I ...
6
votes
2answers
3k views

Pacman option to assume “yes” to every question?

When installing software in debian systems we can put something like this: sudo apt-get install -y chromium-browser that way the installation occurs automatically, whitout asking to confirm ...
0
votes
1answer
33 views

Package installed as dependency is not removed with “apt-get autoremove”

I'm using LXDE and when I installed gnome-screensaver, it had a bunch of dependencies including pulseaudio. I then immediately uninstalled it with autoremove (no intermediate steps), but nothing of ...
-1
votes
1answer
46 views

Method bzip2 has died unexpectedly -Unable to update /upgrade /installl Ubuntu 14.04

Unable to update/upgrade/install Ubuntu 14.04, and it shows the below: Get:21 http://us.archive.ubuntu.com trusty/universe Translation-en [4,089 kB] E: Method bzip2 has died unexpectedly! E: ...
2
votes
2answers
126 views

Installing python gives dpkg error

Installing python gives a dpkg error. I have done these commands, output below $ sudo apt-get install python3.4 $ sudo dpkg -C $ sudo apt-get check $ apt-cache policy libglib2.0-dev $ sudo ...
2
votes
2answers
147 views

apt-get install doesn't install latest version of Owncloud Client

I'm trying to install the latest version of the Owncloud Client (owncloud-client) on a raspberry Pi running Raspbian Linux. When I just enter sudo apt-get install owncloud-client, I get version 1.2 ...
0
votes
2answers
475 views

Error while installing wireless-bcm43142-dkms-6.20.55.19: dependency linux-headers is not satisfiable

I have to install a .deb file with the firmware for the wifi card (This is the name of the file: wireless-bcm43142-dkms-6.20.55.19_amd64.deb; I've downloaded the file from here: ...
1
vote
1answer
76 views

Every package “has no installation candidate”

While attempting to install openssh-server on Ubuntu 14.04 64-bit, I get the following error: Package openssh-server is not available but is referred to by another package. This may mean that the ...
-3
votes
4answers
99 views

How to install a downloaded deb file [closed]

I am new to Ubuntu and I am trying to install Compiz-Config-Manager, but it will not let me. This computer is not connected to the Internet, so I downloaded the .deb file onto a USB and transferred it ...