APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

2
votes
1answer
20 views

Apt broken after upgrading python on 14.04 - No module named 'lsb_release'

I recently needed an updated version of Python3 for a project, so I built it from source; and I believe I made a bit of a mess. All apt based operations now end in an error here: (Reading database ...
0
votes
2answers
2k views

Error while installing wireless-bcm43142-dkms-6.20.55.19: dependency linux-headers is not satisfiable

I have to install a .deb file with the firmware for the wifi card (This is the name of the file: wireless-bcm43142-dkms-6.20.55.19_amd64.deb; I've downloaded the file from here: ...
0
votes
1answer
1k views

E: Sub-process /usr/bin/dpkg returned an error code (2)

I wanted to install bluefish editor but I got this error. This is not the first error I got involving packages. I installed Linux Mint 17 two days ago and every time after a reboot there is some kind ...
2
votes
1answer
1k views

I can't install new packages and can't update and upgrade

I'm trying to install some program on Ubuntu, but when I try it I got the following error.- E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock ...
58
votes
8answers
28k views

Convince apt-get *not* to use IPv6 method

The ISP I work at is setting up an internal IPv6 network in preparation for eventually connecting to the IPv6 internet. As a result, several of the servers in this network now try to connect to ...
3
votes
2answers
2k views

Cannot install mysql-server-5.5/the following packages have unmet dependicies

I'm using ubuntu 14.04. I tried entering mysql with the following command: mysql -u root -p and I got the following message: The program mysql can be found on the following packages: ...
1
vote
2answers
29 views

Lots of unmet dependencies while updating Python

It was suggested that I uninstall and reinstall Python, so I deleted every directed labeled python until 'which python' and 'which python3.4' didn't show anything. Then I did apt-get remove python ...
1
vote
1answer
25 views

VLC stuck in the wrong version on Linux mint 17 (Qiana)

I'm currently using Linux Mint 17, and have been encountering a bug with VLC, the symptoms of which are a flood of zombie sh processes, progressively slowing down my PC (bloating the scheduler ?) For ...
0
votes
1answer
9 views

Dpkg env variable DPKG_HOOK_ACTION is not set in hook script

According to man dpkg I can use DPKG_HOOK_ACTION to get the current dpkg action being run in my dpkg hook script --pre-invoke=command --post-invoke=command Set an invoke hook command to be run ...
0
votes
1answer
36 views

Debian system: install specific packages from source automatically to boost the performance

On Debian /Ubuntu systems, how to set a list of packages which can be installed from sources automatically by apt-get or aptitude? The server is mainly for scientific computing and I would like to ...
1
vote
2answers
25 views

identify packages and dependencies

I have a list of packages installed via apt and would like to eliminate all packages that are dependencies of another package already in that list: https://gist.github.com/rubo77/bd9183fe2794467f482c ...
6
votes
1answer
49 views

“ValueError: _system not initialized” when using apt.VersionCompare

I wrote a bash script that has to compare two version strings to decide to download new version or not. The test relies on a Python script that does apt.VersionCompare(), which does version comparison ...
0
votes
0answers
24 views

x2go unable to locate package x2goserver

I'm trying to install x2go on my test server following this: http://wiki.x2go.org/doku.php/doc:installation:x2goserver (ubuntu) The repo seems to add fine and gives details on how to use it and what ...
2
votes
1answer
422 views

Can't Install netflix-desktop in Debian…Aptitude Has Unmet/Broken Dependencies

I'm trying to install the netflix-desktop package in Debian 'jessie'. I was able to get this to work on my laptop running Debian 'wheezy' a few months ago, but on my desktop I keep running into these ...
0
votes
1answer
54 views

What does “apt” stand for?

What does the abbreviation "apt" stand for? I'm referring to the "apt" directory, the "apt-cache", and the "apt-get" package manager. I always assumed "apt-get" was short for "get application", but ...
6
votes
3answers
799 views

How do I find installed packages that have no install candidate?

I'd like to retrieve a list of installed packages that have no install candidate (e.g., because I removed an apt source file entry). How would I do that on Debian-based systems?
3
votes
1answer
996 views

Can I upgrade to a new version of Python on an old version of Ubuntu?

I have Ubuntu 8.04.3 LTS and ran this: $ sudo apt-get install python2.7 I got this: Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find ...
0
votes
0answers
9 views

Can't install Amanda in Debian 7.6

I'm trying to install Amanda in Debian 7.6, but when I try to install the needed packages I get the error "Couldn't find package amanda-server, amanda-client and amanda-common" when I put this ...
0
votes
1answer
105 views

OpenVAS 7 not working after apt-get update - Failed to receive data: A TLS packet with unexpected length was received

The problem started when my Kali installation updated OpenVAS to v7: My admin username for the web service stopped working so I could no longer log in. I have tried everything I can think of to fix ...
0
votes
1answer
46 views

Debian 6 upgrade to Wheezy then testing release require kernel upgrade?

Debian 6 upgrade to Wheezy then testing release require kernel upgrade? I was doing a squeeze to wheezy upgrade. Then I got to testing. Each step with upgrade then dist-upgrade. I think I may ...
4
votes
2answers
67 views

Why am I getting so many hits searching for “git” in the apt cache?

When I give the following command: apt-cache search git | wc -l I get the answer 756. How can I list just the half-dozen or so apps associated with git?
0
votes
1answer
574 views

Error installing gdb-arm-linux-gnueabi

I get an error when I try to install the gdb-arm-linux-gnueabi package. This is the error that I obtain when I run apt-get install gdb-arm-linux-gnueabi: $ env LC_ALL=C sudo apt-get install ...
11
votes
3answers
17k views

How can I update to a newer version of Git using apt-get?

I've just set up a new machine with Ubuntu Oneiric 11.10 and then run apt-get update apt-get upgrade apt-get install git Now if I run git --version it tells me I have git version 1.7.5.4 but on my ...
2
votes
2answers
809 views

Installing Steam on Debian Wheezy

I downloaded the .deb file from the Steam website, but couldn't install it as it complained about having and "outdated" version of libc6. I look around and apparently I have to add jessie sources to ...
0
votes
0answers
17 views

apt itself update and download packages

I have Debian SID with the following APT configuration: APT::Periodic::Update-Package-Lists "0"; APT::Periodic::Download-Upgradeable-Packages "0"; APT::Periodic::AutocleanInterval "0"; ...
1
vote
1answer
381 views

Installing mysql-workbench from the testing ppa (Jessie) in Wheezy

I would like to install some packages from the testing branch without switching to it if possible. The big packages are things like xfce4 and mysql-workbench. I've done this by making a testing.list ...
0
votes
1answer
111 views

“Package 'linux-headers-3.13.0-27-generic' has no installation candidate”

I'm trying to resolve an issue that I posted here. I'm basically trying to successfully run this script. To do that, I believe (and I its very possible that I'm wrong) I need to install the ...
3
votes
1answer
45 views

Restore original configuration for every package in system

I have been running a rolling release distro for a couple of years now and switched from LXDE to GNOME to KDE over the years. As you can imagine over the time a lot of configuration files have been ...
5
votes
2answers
18k views

apt-get can't find the package on a old version of my distro

I am working on a Linux Mint 16 computer and since recently, every time I want to install something via apt-get install, the log message says that the packages couldn't be authenticated. I go ahead ...
5
votes
1answer
780 views

Noninteractive script running over ssh is interrupted as apt-get finishes

When I run the following non interactive script on Ubuntu Server 13.04 it's interrupted when lxc-docker package finishes installation. Script : ssh -o StrictHostKeychecking=no -t -t -i $CERT ...
-1
votes
2answers
49 views

is there any command to execute apt-get update and upgrade?

I've ever wonder why there isn't a command in linux (debian and related distros) that instead of having to create an alias for a command like: sudo apt-get update; sudo apt-get upgrade why not ...
1
vote
1answer
64 views

Update single package from Ubuntu Utopic Unicorn when running Trusty Tahr

I'm tasked to update a package on a Ubuntu Server Trusty Tahr installation. Specifically rfc5766-turn-server which is really old on Trusty. https://launchpad.net/ubuntu/+source/rfc5766-turn-server ...
28
votes
4answers
16k views

List packages by installation date

How can I list installed packages by installation date? I installed a lot of stuff to compile a certain piece of code, and I want to get a list of the required packages, which are the ones I installed ...
2
votes
2answers
56 views

How will apt-get handle my manual installed software?

Suppose the Emacs version in the APT repository is 24.3, I configure && make install my own emacs 24.4. After a long time, the software in the APT repository was updated to 24.5. What would ...
0
votes
0answers
13 views

Uninstall apache2 when apt-get claims it's not installed?

I restarted the VPS today only to find out that Nginx refused to start. As it turns out, Apache2 was running on the server already. Naturally, I stopped it and started Nginx, but I never installed ...
2
votes
0answers
18 views

Why libpam-systemd run interactively on apt upgrade, even when specified force-confdef/force-confold

I upgrade my packages using aptitude, specifying the apt options --force-confdef and --force-confold. This generally works, but the package libpam-systemd (204-5ubuntu20.8, on Ubuntu 14.04) still ...
3
votes
1answer
836 views

Unmet dependencies after using a backports repository

I have added a backport repository to apt's sources.list to get an application: deb http://ftp.uk.debian.org/debian/ wheezy-backports main Long story short: I did not manage to install the ...
2
votes
2answers
387 views

Hard drive partition and updating trouble

I'm new to linux and am using Linux Mint 15 Olivia. I am running it alongside windows 7 and I want to increase the size of my current linux hard drive partition. I read somewhere that I should install ...
12
votes
4answers
1k views

In Debian based systems, how do we purge configuration files of packages that have already been uninstalled?

To be more specific, I would like to do the equivalent of adding the --purge flag to the following command sudo apt-get autoremove --purge [package name] to packages that are no longer on the ...
0
votes
1answer
26 views

apt-get purge complains about unmet dependencies

I am trying to strip out all my IME packages, to do a fresh install of a different IME (fcitx). I tried this: apt-get purge ibus-anthy anthy anthy-common libanthy0 \ ibus-mozc mozc-data mozc-server ...
0
votes
1answer
388 views

apt-get unable to fetch archives

I'm trying to install a package using apt-get as root on a Linux Mint host: # apt-get install gparted Reading package lists... Done Building dependency tree Reading state information... Done ...
22
votes
8answers
19k views

List available updates but do not install them

I want my cron-run reporting script to notify me in case there are updates for my packages. Is the a way to make apt-get give me the list of available updates but don't do anything more?
0
votes
3answers
679 views

“Package linux-image-3.5.0-44-generic is not installed” while installing quantal kernel

I am working on a Ubuntu Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-43-generic x86_64) machine. There are some packages that I need to install, and in order to be able to that, first I have to run apt-get ...
2
votes
1answer
375 views

Why I was able to fix a broken package with aptitude but I could not with either apt-get or synaptic?

Yesterday I upgraded my Debian Testing and Audacious stopped to work. Troubleshooting I found that the problem was that it was updated to a recent version but the needed plugins were not. I tried to ...
1
vote
0answers
241 views

“connection timed out” while updating package list from Kali repositories [closed]

I am running Kali Linux on Oracle Virtualbox. I managed to make the internet running. Iceweasel needed a proxy. This is done too. My problem is following: apt-get install [something] tells me ...
1
vote
1answer
28 views

user-level guide to maintaining Debian package update security? [closed]

Recently I listened to an interview with Kim Zetter (audio download here) on cybercrime/warfare, particularly Stuxnet and Flame. While listening to the discussion of how Flame exploited Windows ...
1
vote
1answer
84 views

Debian apt-get broken after trying to install skype

I tried to install Skype on my x86_64 computer, only to be faced with disaster, I followed the instructions on the Debian website, https://wiki.debian.org/skype for the 64bit instruction set, but ...
2
votes
2answers
76 views

Format terminal output to show apt-get upgrade errors in RED

I have a very simple bash script written for my Kali Linux distro so I don't have to run apt-get update, apt-get upgrade, apt-get dist-upgrade, apt-get autoclean, and apt-get autoremove every time I ...
1
vote
2answers
158 views

Can't install any package with sudo apt-get install

I'm running Raspbian on my Raspberry Pi I just set up this day, the problem is that every time I try to install any package I get an error , for example, sudo apt-get install samba gives me : The ...
2
votes
2answers
605 views

apt-get install doesn't install latest version of Owncloud Client

I'm trying to install the latest version of the Owncloud Client (owncloud-client) on a raspberry Pi running Raspbian Linux. When I just enter sudo apt-get install owncloud-client, I get version 1.2 ...