APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

1
vote
1answer
190 views

Reading package lists…Error!

When I run sudo apt-get update I get this error: Reading package lists... Error! E: Unable to parse package file /var/lib/dpkg/status (1) E: The package lists or status file could not be parsed or ...
4
votes
5answers
241 views

Correlating filename with package

Say, I'm given a filename like libasound.so.2. Is there a way to query the package manager to correlate the filename with its corresponding package? I'm interested to get answers for any package ...
1
vote
1answer
72 views

Unattended upgrades and modified configuration files

We have the unattended-upgrades package upgrading our servers with security upgrades every Monday and it works great. Today though, it upgraded all of our servers with a new version of PHP5. Because ...
2
votes
0answers
324 views

Crunchbang/Debian apt-preferences

So I did manage to set up apt-preferences but I'm not sure if I did it correctly. So basically what I want is, if I have the need I want to install packages from TESTING, UNSTABLE and DEB-MULTIMEDIA ...
0
votes
2answers
123 views

Can't install mintupdate 4.5.6-1 (Linux Mint 16)

I can't install mintupdate 4.5.6-1 under Linux Mint 16. When mintupdate tries to upgrade version 4.5.6 to version 4.5.6-1 the following error pops up: E: Could not open lock file ...
0
votes
1answer
70 views

How to remove unmet dependecies Debian 7 Wheezy

I'm trying to install different packages but it's showing unmet dependencies in most of them even after sudo apt-get -f install. Below is my /etc/apt/sources.list file: # # deb-src cdrom:[Debian ...
1
vote
0answers
94 views

PostgreSQL installation error in debian

I'm trying to install PgSql in the system with following specs: Distributor ID: Debian Description: Debian GNU/Linux 7.1 Release: 7.1 x86_64 But I am getting an error like this The ...
0
votes
1answer
16 views

Finding the latest version of package which doesn't require upgrading libc (on Debian)

When I try to upgrade packages using aptitude -t wheezy-backports, they often require newer libc than is installed. Proposed solutions remove hundreds of packages. Is there a way to request only the ...
4
votes
2answers
3k views

Failure to startx on Ubuntu 14.04 after security update - missing libXfont.so.1

I had Ubuntu 14.04 running perfectly on my system and then it underwent a recommended security update. I let it update while I was at work and when I returned I found a black screen stating, "No init ...
0
votes
1answer
671 views

Unable to install a package, newer libc6 required

I was trying to install openvasv6 using instructions given here. I am using Debian Wheezy (amd64). $ sudo apt-get -y install greenbone-security-assistant openvas-cli openvas-manager openvas-scanner ...
1
vote
1answer
44 views

After apt-get update and upgrade, do I need to recompile and re-install software that I did not install via apt-get install?

In particular, I noticed that my OpenSSL has been upgraded after a system update via sudo apt-get update and sudo apt-get upgrade. As I installed my Squid server by manually compiling, configuring ...
1
vote
0answers
680 views

Apache 2.2, PHP 5.3 and MySQLl 5.5 on Linux Mint 17?

Our stack consists of Apache 2.2, PHP 5.3 and MySQL 5.5. I've installed Linux Mint 17 Giana. If I install apache2 via apt, it will install Apache 2.4 which is not required for me. Is there any way ...
0
votes
0answers
18 views

Failed packages list

I am planning to write a script to get the list of upgrades available on Ubuntu server and upgrade them. I can get the list of upgrades with "apt-get -s upgrade". But how to get a report on list of ...
4
votes
1answer
49 views

Issue installing OpenVPN via apt

Pastebin I wanted to install OpenVPN on my Debian Wheezy server at home, so I could create a tunnel with my phone or tablet from outside my home. We use OpenVPN at work, so I figured it would be easy ...
1
vote
1answer
96 views

Installing courier-mta causes sendmail to be installed instead

My Debian workstation will not install courier-mta. The command aptitude install courier-mta appears to complete without error, but actually installs sendmail instead. What I did I'll start without ...
4
votes
1answer
89 views

Package management without the need of root permission

Am looking for a way to install packages in home folder. This thread suggests using apt-get source ./configure --prefix=$HOME However, it doesn't provide a way to manage dependencies like apt-get ...
1
vote
1answer
70 views

How to get “apt-get -y upgrade” within a PHP script to function as expected?

Yes, I'm aware of unattended-upgrade, but I don't like that package's limitations. I've got a PHP script that makes the following calls: ... system("/usr/bin/apt-get update"); ...
2
votes
1answer
248 views

Why did this command delete every package?

I was trying to get a Windows program to run on PlayOnLinux and after it didn't work I went to remove Wine with this command: sudo apt-get remove --purge wine* and without thinking I agreed ...
1
vote
1answer
96 views

How to verify that package-installed files match originals?

Let's say I have an installed, working and up-to-date system, and want to verify that all package-installed files on it are the same as those packaged by the respective package maintainer. In effect, ...
1
vote
1answer
251 views

How to remove emacs 23 related packages and leave installed emacs 24

I installed emacs 24 in Linux Mint 16, and want to uninstall emacs 23. I thought sudo apt-get remove emacs23 is enough, but it was not. This is my packages list relating emacs. $ sudo dpkg ...
0
votes
0answers
57 views

Linux mint parse error

I try too much method but still don't work. W: Failed to fetch gzip:/var/lib/apt/lists/partial/linux-mint.froonix.org_dists_olivia_main_binary-amd64_Packages Hash Sum mismatch W: Failed to fetch ...
7
votes
1answer
825 views

When and why should I use apt-get update?

General question: Could some explain what the command apt-get update does and when I really should use it? Remarks Please give a detailed answer. Not just a copy of the man page, unless your ...
4
votes
1answer
66 views

How to list all aptitude user tags or the user tags for a package?

I'm in a bit of a pickle. Following my own counsel I started using user-tags when working on projects, but now I don't remember how I called some of these tags and this cancels their usefulness. Is ...
1
vote
3answers
112 views

To which Debian package does /etc/nsswitch.conf belong?

I tried to find out to which package /etc/nsswitch.conf belongs on my Debian machine, but dpkg --search /etc/nsswitch.conf won't tell me. Does anyone know?
0
votes
1answer
147 views

Install a different version of Maven from the one provided by Ubuntu

I would like to install a package on Ubuntu 10.04.4 but would like to not use the one available in the one repository that I get when I do: apt-cache policy ${package} I would actually like to ...
0
votes
2answers
1k views

Error while installing wireless-bcm43142-dkms-6.20.55.19: dependency linux-headers is not satisfiable

I have to install a .deb file with the firmware for the wifi card (This is the name of the file: wireless-bcm43142-dkms-6.20.55.19_amd64.deb; I've downloaded the file from here: ...
2
votes
2answers
265 views

dpkg won't install package with dependencies that have newer version

Please someone explain to me this, because it makes no sense: $ dpkg -i freeling-3.1-quantal-x86_64.deb Selecting previously unselected package freeling. (Reading database ... 283003 files and ...
3
votes
2answers
109 views

How to clone an apt repository to keep all old packages?

This may sound trivial, but I haven't found a solution anywhere yet. Is there a way to backup or clone an apt repository such that I get a clone that (1) contains all current packages and (2) keeps ...
1
vote
1answer
259 views

apt-get script to update upgrade dist-upgrade clean and autoremove

I wrote this script, #!/bin/bash # if not root, run as root if (( $EUID != 0 )); then sudo /home/jb/bash/update.sh exit fi apt-get update apt-get -y upgrade apt-get -y dist-upgrade apt-get ...
0
votes
1answer
39 views

How to disable anti-aliasing in git-gui and gitk

After an upgrade to Tcl/Tk 8.5, git-gui and gitk are using anti-aliased fonts which look ugly on my display. I can select different fonts in the preferences dialog, but the fonts I was using before ...
1
vote
0answers
49 views

What does apt-get/aptitude do, when it “hangs”?

Everytime I install/remove something with apt-get or aptitude, it hangs for quite a few seconds after all operations (at least: all shown operations) have finished. After those few seconds (like 10 or ...
4
votes
2answers
104 views

Manage local package repository

I just installed a fresh Waldorf (Crunchbang, Debian Wheezy-based) on a computer which has no Internet access. Previously on a Xubuntu 10.04 VM, what I did when I needed some software was: go to ...
3
votes
4answers
1k views

Automatically update GCC to a later release without upgrading distribution

My understanding is that C++11 support in G++ 4.7.2 wasn't great (it gives me a warning everytime I try to compile my C++ code, presumably there are good reasons for these warnings), so thought I ...
1
vote
1answer
50 views

apt and aptitude died after dist-upgrade

I followed the Debian Instructions for upgrading from Squeeze to Wheezy in Debian. I audited my packages, updated my /etc/apt/sources.list file to get Wheezy sources, I ran apt-get update and apt-get ...
0
votes
1answer
297 views

Clang with Code::Blocks on Debian Wheezy [Stable]

In my pretty default Debian install: devsys@zotac:~$ lsb_release -a No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 7.4 (wheezy) Release: 7.4 Codename: ...
5
votes
1answer
95 views

How can I see when package has been upgraded?

Is there a way to see the upgrade history with date with some program e.g. apt? I want to know when exactly I upgraded security relevant packages the last time and the time before that... Thanks a ...
4
votes
4answers
3k views

How can I upgrade MySQL in Debian using apt-get?

I'm using the Turnkey Linux virtual machine. The version of Debian in there is apparently on the "Wheezy" upgrade path (if that's what you call it). I'm not completely comfortable with Linux, as you ...
4
votes
1answer
452 views

apt-get doesn't upgrade openssl on debian 7

I'm facing the following problem. If I run the command sudo apt-get upgrade, I get: Reading package lists... Done Building dependency tree Reading state information... Done The following ...
3
votes
1answer
515 views

apt python error prevents me from resolving dependency problems for apt-get install

On Debian 6 servers dependency issues are preventing me from installing nis (or any package). When I try to resolve that issue I get a python error. How do I get past this issue and re-gain the ...
3
votes
2answers
489 views

how can I change what the command “apt-get update” looks for when executing the update?

Forgive my incompetence I am still new to GNU/Linux. I use Debian wheezy. When I type apt-get update I get this at the end W: Failed to fetch ...
-1
votes
1answer
70 views

Unable to install new package on debian armhf

I got a debian 7.4 armhf that have been running for month without any problems. A few days ago I made some updates, and after that it seams that my dpkg doesn't work correctly any more. When I try to ...
1
vote
2answers
108 views

How do I resolve an apparent hanging update process

I am trying to update an instance on AWS. I have little familiarity with linux in general. However, I did run the command on my Ras. Pi first and had no problems. However this is the second time ...
1
vote
2answers
196 views

apt-get error: trying to overwrite shared 'filename', which is different from other instances of package 'package'

I tried installing several Ubuntu packages on Debian Wheezy, but it failed and now I have broken packages. The problem is, running apt-get -f install fails as well, with this error: Preparing to ...
1
vote
1answer
214 views

error while install a package

I have a problem when I want to install python-pycurl package: root@edx:/var/tmp/configuration-master/playbooks# apt-get install python-pycurl Reading package lists... Done Building dependency tree ...
0
votes
2answers
8k views

apt-get install openssl doesn't upgrade openssl [closed]

re heartbleed, I'm trying to upgrade openssl, WITHOUT upgrading all packages on my system so I am running apt-get install openssl as shown here, it's implied that doing this should upgrade openssl: ...
0
votes
1answer
90 views

Update Linux 10 Mint Julia to 13 Maya

Everytime I try to apt-get update it comes up with the following: Err http://archive.ubuntu.com Precise/main amd64 Packages 404 Not Found [IP: 91.189.91.14 80] Err http://archive.ubuntu.com ...
2
votes
2answers
2k views

Registering Ubuntu Client With Spacewalk

Right now I'm just testing the process for some desktop machines I'll be managing so I have a fresh install of Ubuntu 12.04.04 LTS. We have a non-satellite spacewalk server that I'd like to have ...
1
vote
1answer
453 views

E: python-setuptools upgrade fails, apt-get broken

I wanted to install gnome-maps with apt-get, and then I got this error: Preparing to unpack .../python-setuptools_3.4.1-1_all.deb ... Unpacking python-setuptools (3.4.1-1) over (3.3-1) ... dpkg: ...
1
vote
1answer
839 views

How to mark “not fully installed” apt-get package as “successfully installed”

I have installed Debian 7.4 on my Iomega ix2-200 NAS, following this blog. The ix2-200 is running an ARM Marvel CPU and has a 128 MB NAND flash memory. The flash contains an initramfs image (uInitrd) ...
2
votes
2answers
727 views

apt-get shows important packages as “no longer required”

I recently installed Kali Linux in my system. It came with a preinstalled Iceweasel. However, instead of Iceweasel I wanted to install firefox so I followed this guide and installed firefox ...