APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

1
vote
1answer
112 views

Why does Linux (Mint 17.2,Ubuntu 14.04 based. KDE) automatically remove certain packages while installing others?

For example Atom text editor. When I run: sudo apt-get install imagemagick # http://www.imagemagick.org/script/index.php gives: you might want to run 'apt-get -f install' to correct these: The ...
1
vote
1answer
21 views

Logging into my desktop from SSH says I have no updates, but I do

When I SSH into my Ubuntu Desktop, I get some output saying: 0 packages can be updated. 0 updates are security updates. However, running sudo apt-get upgrade tells me that a package (numix-icon-...
1
vote
2answers
593 views

The following packages have unmet dependencies

Every time I try to use apt-get install or remove or purge on my Debian, I have this error pop up: The following packages have unmet dependencies: libimage-magick-q16-perl : Depends: libmagickcore-6....
1
vote
1answer
100 views

Better logging than /var/log/dpkg.log of package-management?

Has there been some better logging tools than /var/log/dpkg.log as /var/log/dpkg.log seems to have just installations and upgrades but nothing about removals . Also it seems a bit chaotic, does ...
1
vote
2answers
771 views

403 Forbidden Error when trying to connect to ubuntu repositories

Im running Ubuntu 14.04 and havent run sudo apt-get update for many months. When I try to update local /etc/apt/sources.list apt-get can connect to many repos no problem, but many (maybe 15% of total)...
1
vote
1answer
69 views

Can a Debian package's Priority field be used for selection for install?

In a Debian package's control file, there is a Priority field which can be set to one of: required important standard optional extra APT pinning can be used to specify priorities for packages from ...
1
vote
1answer
614 views

cannot install libreoffice on debian sid

Using Debian sid. I cannot install libreoffice as I get this error: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
1
vote
1answer
48 views

State of ucblogo package in debian / raspbian

My son and I are playing around with LOGO programming on a Raspberry Pi (in Raspbian). We ran into a problem with the current package (v 5.5) not properly interpreting arrow key input: http://...
1
vote
1answer
70 views

Bash script only runs in debug mode [closed]

I have the following bash script: #!/bin/bash -e SUDO=sudo $SUDO apt-get -y update || true $SUDO apt-get -y install lxc bridge-utils || true # remove the default bridge, if it exists DEFAUT_BRIDGE=...
1
vote
1answer
141 views

unstable apt-pinning set to -1 on stable Debian

This is how my /etc/apt/sources.list looks like on Debian 8.1: #### stable ######### deb http://httpredir.debian.org/debian stable main contrib non-free deb-src http://httpredir.debian.org/debian ...
1
vote
2answers
1k views

fglrx on Debian stretch

How do I install the fglrx driver on Debian stretch? The package tracker states that there is no package available right now, so I added Sid, pinned on 100. When I try to install fglrx-driver now, ...
1
vote
1answer
178 views

Linux Mint Rebecca - Packages 404 Not Found

Whenever I do sudo apt-get update I get the following error W: Failed to fetch http://repo.mongodb.org/apt/ubuntu/dists/rebecca/mongodb-org/3.0/multiverse/binary-amd64/Packages 404 Not ...
1
vote
2answers
1k views

Depends: libqtgui4 (>= 4.6.2) but it is not installed

I want to install the Wing IDE for python. When I executed it, dpkg showed me some qt packages that were not installed. I installed a few of them via Synaptic Package Manager, but the rest cannot be ...
1
vote
1answer
216 views

Upgraded to test branch by mistake in debian… how can I go back to stable?

I wanted to upgrade my GLIBC to a newer version on my remote server (to which I only have SSH access), so I added the test branch of Debian to my apt sources. I followed this by the mistake of ...
1
vote
1answer
207 views

Debian dpkg error > libxrender1

apt-get update && apt-get upgrade You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libxrender1 : Breaks: libxrender1:i386 (!= 1:0....
1
vote
1answer
20 views

Recreation of apt based source download

Source for a apt package can be obtained with the command: apt-get source foo This produces a directory with four entries in it: a directory of source and three files, foo*****.dsc, foo*****.tar.gz ...
1
vote
1answer
210 views

Problem with apt-get and locales (inappropriate # in .deb package name)

First of all, I'm running Raspbian, any extra needed info, I will post it here, just ask for it. EDIT: Output of locales -a: C C.UTF-8 en_GB.utf8 POSIX I configured en_GB.utf8, about the others, ...
1
vote
1answer
735 views

Debian - problems updating mysql 5.6

I just tried to update my dev database that runs on debian 7.8. Unfortunately it's now giving me the folllowing error: ... W: Failed to fetch http://repo.mysql.com/apt/debian/dists/wheezy/Release ...
1
vote
1answer
326 views

apt pin priority for a single package in a source

I am trying to get firefox through the debian repo for mint to work within debian wheezy I'm using the following source line: deb http://packages.linuxmint.com debian import i've created a file in: ...
1
vote
1answer
397 views

“Package 'dconf-cli' has no installation candidate”

I want to be able to colour my gnome terminal (on Debian), using this package, and the installation notes require me to first execute sudo apt-get install dconf-cli, but doing so gives me an error. ...
1
vote
1answer
1k views

VLC stuck in the wrong version on Linux mint 17 (Qiana)

I'm currently using Linux Mint 17, and have been encountering a bug with VLC, the symptoms of which are a flood of zombie sh processes, progressively slowing down my PC (bloating the scheduler ?) For ...
1
vote
1answer
3k views

Debian 6 upgrade to Wheezy then testing release require kernel upgrade?

Debian 6 upgrade to Wheezy then testing release require kernel upgrade? I was doing a squeeze to wheezy upgrade. Then I got to testing. Each step with upgrade then dist-upgrade. I think I may over-...
1
vote
1answer
22 views

What files does affect apt-get purge¿?

I want to know before doing apt-get purge <packet> what files thats gonna have effect on. The reverse thing would be, what packet do I have to do purge if I want to remove that file (apt-file ...
1
vote
1answer
1k views

The pool cannot be imported, because is formatted using an incompatible version

I can't access my zfs pool on Debian as it's saying that my version is too old: root@Microknoppix:~# zpool import pool: WD_4TB id: 12726205736285302822 state: UNAVAIL status: The pool is ...
1
vote
1answer
7k views

Sample /etc/apt/sources.list for Linux Mint 17

It seems my /etc/apt/sources.list file only has deb cdrom:[Linux Mint 17 Qiana - Release amd64 20140624]/ trusty contrib main non-free It might have got corrupted when I was trying to download ...
1
vote
2answers
275 views

checkinstall package conflicts with python

I'm trying to do a distribution upgrade from Debian 6 to 7 and am having some issues with some packages I created and installed with checkinstall. When doing the upgrade I get the following message: ...
1
vote
1answer
10k views

Unable to add PPA repository from terminal

I am trying to install ap-hotspot on Ubuntu-14.04 When I enter the command: sudo add-apt-repository ppa:nilarimogard/webupd8 It gives me this message "Cannot add PPA: 'ppa"nilarimogard/webupd8'...
1
vote
2answers
1k views

Unmet dependencies using apt-get on Ubuntu

I am working on a Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-43-generic x86_64) machine. It is a server running in production environment with other projects so I have to be quite careful. I have to install ...
1
vote
1answer
100 views

List packages coming from a specific Codename or Suite (apt based systems)

I already know how to list every package from a given "origin", thanks to aptitude awesome search features: aptitude search "?origin(My Backports)" However, in the repository Release file, there ...
1
vote
1answer
302 views

apt-get update: How to check for GPG errors when using scripts?

When running. sudo apt-get update For example something like this could happen. W: GPG error: http://deb.torproject.org wheezy Release: The following signatures were invalid: KEYEXPIRED 1409325681 ...
1
vote
1answer
892 views

Why -t release don't downgrade the package while package/release does?

When upgrading a package, -t or --default-release works wonder: ➜ ~ sudo apt-get install -t unstable libpam-gnome-keyring Reading package lists... Done Building dependency tree Reading state ...
1
vote
2answers
2k views

'E:The package linux-headers-3.5.0-54 needs to be reinstalled, but I can't find an archive for it. ' when upgrading the system

I am using Ubuntu 12.04, and I try to upgrade to 14.04.1 using the terminal using: do-release-upgrade but I keep getting the following error: SystemError: E:The package linux-headers-3.5.0-54 ...
1
vote
1answer
304 views

Installing courier-mta causes sendmail to be installed instead

My Debian workstation will not install courier-mta. The command aptitude install courier-mta appears to complete without error, but actually installs sendmail instead. What I did I'll start without ...
1
vote
1answer
368 views

netselect - how to get it installed on Mint?

I have been using Linux already for a couple of years, and got used with it. Most of distro I used are: Centos, Ubuntu, Fedora, etc. Recently I decided to put in one of my machines Mint and I must ...
1
vote
1answer
1k views

How to pull dependencies for package/testing from testing

Trying to install a newer version of libav-tools from testing to my otherwise debian-stable installation. I have testing in my sources.list and my preferences look like: Package: * Pin: release a=...
1
vote
1answer
47 views

Is there a way to monitor the Shareable Objects (.so) loaded on launch of a specific application?

I've been through dependency issues, but, finally, have my application running. The problem is I need to force install of some old libraries with dpkg to achieve this, which, in turn, breaks my ...
1
vote
3answers
1k views

Ubunutu software-centre is not working, showing black screen

I am trying to open ubuntu software-center but it get paused and after that shows complete black and nothing is happening. Same thing has happened when I try to run from command line. This is the ...
1
vote
1answer
87 views

Determining archive / suite from `deb` line

Is there an easy way to determine the "Archive", "Suite", "origin" (or whatever else APT uses) just from the deb line? For example, someone (trusted, of course) gives me this deb line: deb http://...
1
vote
1answer
448 views

Install single debian experimental packages? [duplicate]

I'm continually getting this error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found What I did before was add the Debian experimental repo and update to 2.17. But through a long ...
1
vote
1answer
470 views

Apticron notifying about uninstalled packages

I'm using apticron to notify myself about available updates. However, I've got an installation on a VPN that seems to notify about packages I DON'T have installed. For example, it keeps (daily) ...
1
vote
2answers
303 views

Installer packages: .bin, -rpm.bin, tar, tar.z

Is it correct that most of Unix&Linux software supports x-copy deployment? If I download the installation package and uncompress the files into a particular directory - would that be enough to ...
1
vote
1answer
2k views

Installing php5-cURL on Backtrack leads to dependencies issues

I am trying to install a program called Glype on my computer for a proxy. I am using Backtrack 5 R3 and I have the latest version of Apache running on it. The problem I have is that Glype needs cURL ...
1
vote
2answers
9k views

Failing on apt-get update

Very recently when I have been attempting to check for updates on my laptop (Ubuntu 12.04), the check fails. sudo apt-get update: W: GPG error: http://us.archive.ubuntu.com precise Release: The ...
1
vote
1answer
169 views

Why is this apt-cache dumpavail with overrides not working?

I am trying to list available packages from a remote repository without accessing /etc/apt or /var.The following command doesn't return anything and exits with code zero. apt-cache dumpavail -o Dir::...
1
vote
1answer
926 views

Apt-get dist-upgrade fails

I'm trying to upgrade from Mint 13 to Mint 15, but receive the following error: Calculating upgrade... Failed The following packages have unmet dependencies: mate-media : Depends: mate-media-...
1
vote
1answer
192 views

libpam-ck-connector causing apt-get to fail

I used apt-get autoremove on my Debian server and now apt-get won't install or remove anything as it keeps trying but failing to remove libpam-ck-connector. When trying to install anything… ...
1
vote
2answers
67 views

The dependency isn't installed

I'm testing my .deb package and cannot find out why it doesn't install the dependencies: The control file's Depends line is: Depends: zend-grid-module, postgresql-8.4, ${shlibs:Depends}, ${misc:...
1
vote
1answer
435 views

Synchronize software packages between different Linux distributions

Is there any way to synchronize software packages between different Linux distributions? There are several software packages that I need to synchronize between a Linux Mint installation and an Ubuntu ...
1
vote
1answer
303 views

Mint 12 - Error updating MySQL (mysql-client-core-5.1)

I have MySQL 5.5 installed via packages.dotdeb.org. When trying to update 5.1, which is also installed, I get the following error: E: /var/cache/apt/archives/mysql-client-core-5.1_5.1.66-0ubuntu0....
1
vote
1answer
1k views

Apt-Get Install Unmet Dependencies

My debian computer will not install the new kernel. It says I have unmet dependencies, and those dependencies say they have unmet dependencies. Many of these dependencies are already installed however....