APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

1
vote
1answer
254 views

Mint 12 - Error updating MySQL (mysql-client-core-5.1)

I have MySQL 5.5 installed via packages.dotdeb.org. When trying to update 5.1, which is also installed, I get the following error: E: ...
1
vote
1answer
1k views

Apt-Get Install Unmet Dependencies

My debian computer will not install the new kernel. It says I have unmet dependencies, and those dependencies say they have unmet dependencies. Many of these dependencies are already installed ...
1
vote
1answer
303 views

Ubuntu Could not purge package

I've tried to install oracle-java7-installer package from custom repository onto Ubuntu 12. It was failed during executing some post-installation script. So. I want just to rollback it and proceed ...
1
vote
3answers
122 views

Debian Squeeze not whole of package contents installed [closed]

When I do apt-get install usb-modeswitch-data, not all of it's contents are installed under /etc/usb_modeswitch.d. I looked inside package and wasn't able to understand how could it be -- there were ...
1
vote
1answer
3k views

build-dep firefox not working on Linux Mint

I'm on the latest Linux Mint 12. In order to compile Firefox I need to do a sudo apt-get build-dep firefox which isn't working and showing the following error: $ sudo apt-get build-dep firefox ...
1
vote
2answers
1k views

apt-get : no installation candidate for libxul-dev

When I'm installing libxul-dev I end with this error message: $ sudo apt-get install libxul-dev Reading package lists... Done Building dependency tree Reading state information... Done Package ...
1
vote
2answers
1k views

How to set default APT source

Running cat /etc/apt/apt.conf gives: APT::Default-Release "stable"; I thought doing that would disallow the command apt-get install wajig to work, if a newer version was available anywhere but ...
1
vote
1answer
525 views

How to unpack libc6 source on Hardy using debian/rules?

How do I unpack the libc6 source code on Hardy without building everything? I run apt-get source libc6 and I get $ ls -1d glibc-2.7/* glibc-2.7/debian glibc-2.7/glibc-2.7.tar.bz2 ...
1
vote
0answers
16 views

Is granting unattended-upgrade command to non-sudo users safe?

I have found out that I give get a non-sudo user access to certain commands with the sudo privileges. However, my plan to allow them to run apt-get dist-upgrade the system is not safe because they ...
1
vote
0answers
24 views

Weird Wine dependency problems on Xubuntu

I'm on 64-bit Xubuntu 14.10. Nvidia graphics with the proprietary drivers, if that matters. I just ran apt-get update && apt-get upgrade, so I should be up to date. My CPU architecture is ...
1
vote
0answers
19 views

Add Repository In Debian 6.0.8 [duplicate]

I am trying to add a repository in Debian 6.0.8 sudo cat /etc/debian_version 6.0.8 sudo apt-get install software-properties-common E: Unable to locate package software-properties-common sudo ...
1
vote
0answers
48 views

How to update an offline Debian 7 to Debian 8

I have an offline Debian 7 server, which I would like to update to Debian 8 at some stage, but I fear I'll do it wrong, so here I go ask you first for best practice to go about this. Currently the ...
1
vote
0answers
342 views

Broken System due to upgrading libc6

I am using Kali, and I tried to upgrade libc6, because it comes with a lower version than I need. After downloading the latest package from the debian repo ...
1
vote
0answers
26 views

Debian jessie mounted pendrive not trusted by apt

I have installed debian jessie from unetbootin pendrive and without network drivers. After booting from HDD, I have added mounted pendrive to apt sources (with file:// prefix). I have two problems. ...
1
vote
0answers
33 views

How to resolve message '… system lacks support for snapshot feature'?

When I do "sudo apt-get update && sudo apt-get upgrade", I usually get this message in my terminal: Sorry, your system lacks support for the snapshot feature. How do I stop this message ...
1
vote
0answers
162 views

Error during ubuntu upgrade (errors were encountered while processing)

I am trying to upgrade my ubuntu from 11.10 to 14.10 but I got this error message when I ran sudo apt-get -f install errors were encountered while processing: ...
1
vote
1answer
266 views

Debian - problems updating mysql 5.6

I just tried to update my dev database that runs on debian 7.8. Unfortunately it's now giving me the folllowing error: ... W: Failed to fetch http://repo.mysql.com/apt/debian/dists/wheezy/Release ...
1
vote
0answers
19 views

Debian installs new, non depended on packages

I recently dist-upgraded my jessie box and several new packages were installed. It looks like there were no packages that depend on the new packages, as I could autoremove them flawlessly. An example ...
1
vote
0answers
32 views

How can I upgrade an application from new source?

I am runnign debian wheezy. I have PHP 5.4 installed from default repos. And now I have added these to sources list to upgrade to PHP 5.6 deb http://packages.dotdeb.org wheezy all deb-src ...
1
vote
1answer
161 views

Debian offline dist-upgrade in one step

Is there a way to perform a distribution upgrade on an offline Debian system by making only one return trip to an online machine? I've managed to perform the equivalent of apt-get update && ...
1
vote
2answers
339 views

Lots of unmet dependencies while updating Python

It was suggested that I uninstall and reinstall Python, so I deleted every directed labeled python until 'which python' and 'which python3.4' didn't show anything. Then I did apt-get remove python ...
1
vote
1answer
38 views

user-level guide to maintaining Debian package update security? [closed]

Recently I listened to an interview with Kim Zetter (audio download here) on cybercrime/warfare, particularly Stuxnet and Flame. While listening to the discussion of how Flame exploited Windows ...
1
vote
3answers
3k views

Can't install any package with sudo apt-get install

I'm running Raspbian on my Raspberry Pi I just set up this day, the problem is that every time I try to install any package I get an error , for example, sudo apt-get install samba gives me : The ...
1
vote
2answers
43 views

identify packages and dependencies

I have a list of packages installed via apt and would like to eliminate all packages that are dependencies of another package already in that list: https://gist.github.com/rubo77/bd9183fe2794467f482c ...
1
vote
1answer
54 views

Remove Gnome Components detect by Packagename

I have tried out the dpkg, aptitude and apt commands. On the gnome desktop I decided to remove one component. sudo apt-get remove gnome-games or something else, all works fine. But if I don’t ...
1
vote
1answer
209 views

How can I upgrade a complete list of packages from stable to backports

I have installed Qt 4.8.2 from Debian Wheezy on my system. Now, some application requires Qt 4.8.3 on my machine, so I looked at the versions and found that Qt 4.8.6 is avaliable in Wheezy-Backports: ...
1
vote
2answers
294 views

Apt-get failing in bash script?

I have several machines (running Ubuntu LTS 12.4 64-bit) which need to be configured in the same way, so I created a shell script which will run automatically the first time the machine boots. It ...
1
vote
2answers
1k views

“except (IOError, OSError), e: SyntaxError: invalid syntax” when configuring python-lockfile

I am having trouble installing any new packages in Ubuntu because of python. I tried sudo apt-get install python3 python3-dev but I am getting the following output :: dpkg: error processing ...
1
vote
0answers
479 views

Fix the debian default version to wheezy

I followed this tutorial http://kemitix.postach.io/install-viber-on-debian-wheezy to install viber on debian wheezy 7.6. My problem is about the part that says: Fix the default version to wheezy. ...
1
vote
1answer
95 views

installing libsocket-perl, apt-get searches for wrong filename extension, gets 404

I've been having trouble installing a package for a number of days now and can't find the solution anywhere, though I have been able to figure out more exactly what's going wrong. It appears that ...
1
vote
1answer
284 views

Unattended upgrades and modified configuration files

We have the unattended-upgrades package upgrading our servers with security upgrades every Monday and it works great. Today though, it upgraded all of our servers with a new version of PHP5. Because ...
1
vote
0answers
1k views

Crunchbang/Debian apt-preferences

So I did manage to set up apt-preferences but I'm not sure if I did it correctly. So basically what I want is, if I have the need I want to install packages from TESTING, UNSTABLE and DEB-MULTIMEDIA ...
1
vote
0answers
318 views

PostgreSQL installation error in debian

I'm trying to install PgSql in the system with following specs: Distributor ID: Debian Description: Debian GNU/Linux 7.1 Release: 7.1 x86_64 But I am getting an error like this The ...
1
vote
0answers
837 views

Apache 2.2, PHP 5.3 and MySQLl 5.5 on Linux Mint 17?

Our stack consists of Apache 2.2, PHP 5.3 and MySQL 5.5. I've installed Linux Mint 17 Giana. If I install apache2 via apt, it will install Apache 2.4 which is not required for me. Is there any way ...
1
vote
0answers
128 views

What does apt-get/aptitude do, when it “hangs”?

Everytime I install/remove something with apt-get or aptitude, it hangs for quite a few seconds after all operations (at least: all shown operations) have finished. After those few seconds (like 10 or ...
1
vote
1answer
835 views

E: python-setuptools upgrade fails, apt-get broken

I wanted to install gnome-maps with apt-get, and then I got this error: Preparing to unpack .../python-setuptools_3.4.1-1_all.deb ... Unpacking python-setuptools (3.4.1-1) over (3.3-1) ... dpkg: ...
1
vote
0answers
108 views

apt repository not showing in apt-cache policy, why?

I have a private mini-dinstall based repository. sources.list.d has an entry for it, like https://user:pass@my.host/repos/ tools/ I have installed apt-transport-https and I can happily install ...
1
vote
1answer
246 views

Wireshark or MC installation wants to remove gnome and more

I want to install wireshark or mc (Midnight Commander) with apt-get or synaptic, but I get a message that "this installation will remove a lot of actually installed packages". There are for example ...
1
vote
2answers
624 views

Error Installing “ia32-libs” to run ADB and Fastboot Linux Mint 16 “Petra”

I have been trying to get adb, fastboot, avd and others to work with the latest version of Linux Mint (16 "Petra") I originally got this error when trying to run ADB: ➜ platform-tools ./adb ./adb: ...
1
vote
2answers
551 views

Installing OpenJDK 7 (JRE) but only policytools found in ./jre/bin

I'm trying to install Java 7 onto my Ubuntu machine through apt-get. I'm issuing the to install using apt-get: sudo apt-get openjdk-7-jre apt-get claims a successful install, but I cannot appear to ...
1
vote
0answers
242 views

Aptitude installing jre

I am trying to install jre on my debian 7 kali box, but I keep getting these faulty errors. I tried installing it through aptitude and it fails at the end. The result is: dpkg: error processing ...
1
vote
0answers
23 views

Pin or hold? What's the proper way to tell apt-get dist-upgrade that I want to keep a particular package over another? [duplicate]

At the moment, when I do apt-get dist-upgrade on my Raspbian it prompts me to throw out upstart again and install sysvinit. I don't get the same with apt-get upgrade. However, I find the behavior of ...
1
vote
1answer
3k views

apt-get update won't update - undo /apt-add-repository

When I run apt-get update, this happens: Hit http://dl.google.com stable Release.gpg Hit http://dl.google.com stable Release Hit http://security.debian.org ...
1
vote
0answers
28 views

Fix broken apt: insserv: Service killprocs has to be enabled to start service single [duplicate]

After I made a system upgrade (apt-get upgrade) on a Debian box, I get an error every time I try to use apt-get. Example: # apt-get -f install Reading package lists... Done Building dependency tree ...
1
vote
1answer
269 views

Ubuntu LTS : best practice for installing gems

Ubuntu 12.04 LTS Server I'm relatively new to Unix/Ubuntu. I need to install the ruby gem libopenssl-ruby. I know that Ubuntu LTS versions maintain lists of authorized package versions. apt-get ...
1
vote
1answer
2k views

How do I add a custom package to debian repository?

I run my own debian apt repository server. I have a .deb file that i would like to add into the repository (Adaptec Storage Manager deb). I need the ability to manage that package independent of the ...
1
vote
1answer
152 views

libpam-ck-connector causing apt-get to fail

I used apt-get autoremove on my Debian server and now apt-get won't install or remove anything as it keeps trying but failing to remove libpam-ck-connector. When trying to install anything… ...
1
vote
0answers
460 views

Make and apt-get Have Stopped Working

So I downloaded the non-free broadcom driver(b44) for my debian install, however when I try to make it I get the following error: make make -C /lib/modules/2.6.32-5-amd64/build ...
1
vote
0answers
402 views

Mono spits out too many errors after update, try to reinstall, more errors

I had errors with apt-get update && apt-get dist-upgrade, from mono mono, so I tried this instead: sudo apt-get install --reinstall banshee banshee-extension-soundmenu ...
1
vote
0answers
396 views

Resolving unmet installation dependencies; file system problems

Somehow part of my ext3 file system got corrupted and large portions of my python installation got all sorts of messed up. The only thing I could notice immediately was Python raising a missing module ...