APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

learn more… | top users | synonyms (1)

0
votes
0answers
319 views

My apt-get installer has no autocompletion for some packages

I have installed Kali Linux v1.1.0 (Debian based). Filename completion for sudo was not running at the beginning, so I added: complete -c sudo And everything seems to autocomplete now, except for ...
1
vote
2answers
58 views

Getting the diff of a package update

Before (or after) updating a package with apt-get update, how can I view the source code diff between the the new and the old version?
4
votes
1answer
108 views

Why does apt-get think packages “are no longer required”

I ran apt-get install raspberrypi-net-mods on my Raspberry Pi running Raspbian and got the following message:- The following packages were automatically installed and are no longer required: git ...
0
votes
1answer
173 views

How to solve nsf-common related error when install zsh in ubuntu?

Everytime I install some kind of package, at the last phase, apt-get install could return a common-nfs related error. Why the installation can't be done without this error? detailed pastebin here ...
0
votes
1answer
750 views

GPG error with http://volatile.debian.org : 'The following signatures were invalid: NODATA 1 NODATA 2'

I am currently trying to add a new repository to apt-get but it is not working. I'm adding it like this: deb http://volatile.debian.org/debian-volatile wheezy/volatile non-free Then I get this ...
0
votes
0answers
566 views

Device tree compiler won't update

I have a problem on Ubuntu 12.04. I am trying to flash a Toradex Colibri T20 with Linux, following these instructions: http://falstaff.agner.ch/2014/03/16/colibri-t20-upstream-linux-kernel/. However, ...
0
votes
0answers
82 views

error when install library ubuntu 10.10

I have installed Ubuntu 10.10 I have chosen this Ubuntu because I want to run openbts 2.6 on this machine. My problem is that when I run this library: sudo apt-get -y install libfontconfig1-dev ...
1
vote
1answer
126 views

How to manage Debian source code packages using aptitude or apt?

Background: I would like to regularly download and install source to /usr/src for certain important development packages. (For me: Qt5 and friends.) I have seen this other question about one-time ...
0
votes
1answer
21 views

“Description Language:” field in apt-cache showpkg

The output of apt-cache provide a field named "Description Language:" in about every file, and - as far as I was able to find out - they all are empty. From man 8 apt-cache For the specific ...
11
votes
4answers
558 views

Why isn't apt-cache policy output piped?

Cannot get why $ apt-cache policy foo N: Unable to locate package foo but $ apt-cache policy foo 2>&1 | grep . is empty. Where in the latter call am I doing the wrong assumption? The ...
5
votes
2answers
298 views

Upgrading packages automatically

I'm fairly new to using servers (debian 7) and I'm currently running cron-apt to e-mail me when there are new upgrades available. Is the following command safe to run when new upgrades are shown? ...
0
votes
1answer
206 views

PHP upgrade after installing phpmyadmin

I had a Debian Server with Apache 2.2 and PHP 5.3 I installed phpmyadmin (sudo apt-get install phpmyadmin). Now, the versions of Apache and PHP have been upgrade (2.4/5.6) Is this possible? How can ...
6
votes
2answers
4k views

How do I install mod_pagespeed using apt-get?

I remember seeing an article at one time on how to do this, but now I can't find it. I have seen other install directions. I want to make sure I can easily update it via apt.
7
votes
1answer
7k views

How to I install zabbix-agent over apt-get

Why is it that on my Ubuntu 13.04 system I can easilly install zabbix-agent by doing apt-get install zabbix-agent. When I do it in Debian 7.1, it says that the package zabbix-agent can not be found. ...
3
votes
2answers
143 views

Is there a way to see why certain dependency of a package is needed?

I was about to install mysql-client-5.5 package which has debianutils package as a dependency. However, I first checked which binaries are installed with debianutils package. It installs nine ...
0
votes
1answer
1k views

Cannot install packages in Mint: “Unable to fetch some archives”

I'm running Linux Mint 16 (Petra). I was able to install packages normally until, at least, april 18th (two weeks ago). Since yesterday I cannot install packages anymore. For example, if I try to ...
2
votes
0answers
33 views

Debian jessie mounted pendrive not trusted by apt

I have installed debian jessie from unetbootin pendrive and without network drivers. After booting from HDD, I have added mounted pendrive to apt sources (with file:// prefix). I have two problems. ...
0
votes
2answers
33 views

apt-get --option -> one time or permanent?

Does apt-get --option set the defined option permanently or is this a one-time action? I know I should try for myself but I have 1 (one) computer here and I really don't want to fumble with the ...
1
vote
1answer
276 views

Can apt-get upgrade perform a dist-upgrade from one version of debian stable to the next?

I just wanted to do a regular upgrade on my Debian Wheezy system. I did the usual $ sudo apt-get update $ sudo apt-get upgrade I noticed that the number of packages to be upgraded was pretty large ...
0
votes
0answers
62 views

Debian stable and dependencies

I have a computer running Debian Jessie and am trying to install a version of the FEniCS library from the Sid repository. I've added an unstable.list file containing the repository info to the ...
0
votes
0answers
261 views

Depends: sqlite3 (>= 3.7) but it is not installable

Firstly, i'm new linux, so apologies if this is a dumb question... I recently picked up a Raspberry PI 2 and have installed Raspbian (Debian Wheezy). I'm trying to install an application called ...
2
votes
1answer
57 views

Create a subset of debian repo

I need to create a subset of an existing repository that contains certain packages. The dependencies of these packages need to be satisfied. Now, I know how to create an Apt repository from a given ...
1
vote
1answer
211 views

Upgraded to test branch by mistake in debian… how can I go back to stable?

I wanted to upgrade my GLIBC to a newer version on my remote server (to which I only have SSH access), so I added the test branch of Debian to my apt sources. I followed this by the mistake of ...
0
votes
1answer
494 views

How to erase duplicate repository?

I'm having this problem a few times now when execute sudo apt-get install something... this is the part of the output which tells me there is a problem.. W: Duplicate sources.list entry ...
0
votes
1answer
681 views

Can't use apt because python encoding issue

I'm getting a python unicode error every time I try to install or update anything with apt or aptitude, preventing me to update my system. The error I'm getting is the following: File ...
5
votes
1answer
536 views

Bypass GPG signature checks only for a single repository

I have read the following article: How do I bypass/ignore the gpg signature checks of apt? It outlines how to configure apt to not check the signatures of packages at all. However, I'd like to limit ...
0
votes
1answer
317 views

Uninstall Phusion Passenger and repair package database

Some time ago I installed Phusion Passenger with these instructions. I also have the debdeb.org repository in my sources.list. I now want to remove Passenger and install a clean nginx package from ...
5
votes
3answers
5k views

apt-get shows important packages as “no longer required”

I recently installed Kali Linux in my system. It came with a preinstalled Iceweasel. However, instead of Iceweasel I wanted to install firefox so I followed this guide and installed firefox ...
0
votes
1answer
127 views

build-essential tries to install unrelated package nautilus-dropbox

Whenever I try to install them through the Software Center it will remain at 0% for hours. I instead attempted to install the application I needed by compiling it from source. I needed the ...
1
vote
1answer
93 views

List packages coming from a specific Codename or Suite (apt based systems)

I already know how to list every package from a given "origin", thanks to aptitude awesome search features: aptitude search "?origin(My Backports)" However, in the repository Release file, there ...
0
votes
0answers
49 views

“sudo: apt-get: command not found.” after removing packages [duplicate]

I have a problem similar to the issue here: "sudo: apt-get: command not found." after removing some packages. Did the same stupid thing removing something: sudo apt-get remove gnupg ...
3
votes
3answers
21k views

“sudo: apt-get: command not found.” after removing some packages

Recently I executed this command: sudo apt-get remove debian-keyring debian-archive-keyring To prevent this such error message: WARNING: The following packages cannot be authenticated! openerp ...
6
votes
3answers
350 views

What provides /etc/exports and how do I find that out?

I have two Debian virtual machines that were built from the same netinstall iso, but probably have different packages installed. One of them has an /etc/exports file for nfs mounts but the other one ...
-1
votes
1answer
995 views

why is install-recommends default true? [duplicate]

In debian the default configuration for installing recommendations in apt is set to true. if you edit /etc/apt/apt.conf and add the line apt::install-recommends "false"; recommendations are ...
0
votes
1answer
518 views

cannot install wine on 17.1 mint: unmet dependencies, broken packages

i have a Linux Mint 17.1 Rebecca - Release amd64 20141126]/ trusty contrib main non-free installed, and the apt-get install wine wont do the trick. it returns the following: Some packages could not ...
3
votes
1answer
4k views

How to use zypper in bash scripts for someone coming from apt-get?

I have a few questions about moving from apt-get to zypper in bash scripts. What is the equivalent of this? sudo apt-get install curl --assume-yes (where curl could be any package) I found the ...
4
votes
1answer
14k views

I can't install new packages and can't update and upgrade

I'm trying to install some program on Ubuntu, but when I try it I got the following error.- E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock ...
1
vote
4answers
372 views

Change apt-get's installation path

I have a machine on which the root partition is running out of space. I have another disk on which there is plenty of free space. How do I configure apt-get to install packages on a different ...
2
votes
3answers
144 views

is there a system-wide “extension” to /etc/services that does not get replaced on package updates?

I know how to use /etc/services but if I change it and the inetd package is later updated via apt-get to a new default one, my changes are gone (happened to me on a apt-get dist-upgrade from Debian ...
190
votes
10answers
72k views

What is the real difference between “apt-get” and “aptitude”? (How about “wajig”?)

I know that both apt-get and aptitude are command line package management interfaces on Debian derived Linux, with different options, but I'm still somewhat confused. Under the hood, aren't they ...
1
vote
1answer
291 views

Debhelper recursive dependency

Unfortunately, debhelper has a recursive dependency. When I try to install with apt-get source --compile debhelper, it says: Reading package lists... Done Building dependency tree Reading ...
2
votes
2answers
554 views

Hard drive partition and updating trouble

I'm new to linux and am using Linux Mint 15 Olivia. I am running it alongside windows 7 and I want to increase the size of my current linux hard drive partition. I read somewhere that I should install ...
1
vote
1answer
191 views

Debian dpkg error > libxrender1

apt-get update && apt-get upgrade You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libxrender1 : Breaks: libxrender1:i386 (!= ...
0
votes
2answers
146 views

Package deb dependencies unmet error

I am trying to install deb package in a new AWS 14.04 ami instance, but it fail with the following error - The following packages have unmet dependencies: youtube-snapshot-taker : Depends: firefox ...
2
votes
1answer
415 views

Why apt wants to remove gnome-core when I try to remove gnome-terminal only?

Why apt wants to remove gnome-core when I try to remove gnome-terminal only? I am also wondering why apt is considering many packages useless? I am using latest version of Kali Linux and it is based ...
2
votes
1answer
468 views

apt-get error 503

I tried installing pyqt4-dev-tools on Linux Mint using: sudo apt-get install pyqt4-dev-tools After a few prompts the installation is aborted with the following message: Err ...
2
votes
1answer
631 views

Problems installing software with apt-get

I am running Ubuntu 12.04 LTS and I would like to install FSLView. I cannot install it through Ubuntu Software Center, and when I try installing the package via the command line with sudo dpkg -i ...
1
vote
1answer
2k views

Apt-get, no sudoers file

I am trying to install a module using apt-get. For that I do the following: sudo apt-get install But I get the following error: sudo: can't stat /etc/sudoers: No such file or directory sudo: no ...
2
votes
1answer
660 views

Error in : sudo apt-get update

I am Using Linux Mint 17. I try to run this command: sudo apt-get update But I am getting the following error: W: Failed to fetch ...
0
votes
1answer
2k views

Some index files failed to download - Linux Mint 17.1 Cinnamon

Running sudo apt-get update i get the following error message: ... Ign http://packages.linuxmint.com rebecca/upstream Translation-en_US Ign http://packages.linuxmint.com rebecca/upstream ...