0
votes
1answer
514 views

Error while Compiling Subversion with a custom-compiled Apache on a shared server

Am using a RHEL 5.5 shared server, my user has complete access to /opt folder. No root access, cant write to /etc, /usr etc. So, I downloaded httpd-2.4.6 and httpd-2.4.6-deps onto /opt (ie. ...
0
votes
0answers
167 views

Upgrading Apache 2.2.16 (package version) to the latest version 2.2.26 (compiled version) on Debian Squeeze

I have Debian Squeeze which is shipped with Apache 2.2.16, the latest version of the package. For PCI compliance I need to upgrade to the latest 2.2.26. But this version does not exist as a binary ...
1
vote
2answers
794 views

Ubuntu: can't find ndbm.h

I need to compile an old apache version, 1.3 and compilation process fails because: mod_auth_dbm.c:77:18: fatal error: ndbm.h: File or directory not found where is it?
1
vote
0answers
200 views

Run Apache2 as root

I am teaching a security class and I would like to show them how it is very stupid to run apache as root (that means I don't need to be preached to about how stupid it is; I agree with you) I'm having ...
0
votes
0answers
265 views

mod_python won't “./configure” because it can't determine httpd version

I'm trying to install mod_python 3.3.1 on Apache 2.4.3 and whenever I try to run ./configure (with apxs etc) and instead of configuring correctly, it says that Apache 2.x is required and my current ...
1
vote
3answers
2k views

Troubles installing php with MySQL support

So I wasn't sure if this question would go best here or on Overflow or Server Fault, but decided to try here first. I'm installing LAMP on a VPS, and am running into issues configuring and building ...
1
vote
1answer
1k views

Mod_Auth_MySQL will not compile under Slackware 13

I tried to add the auth_mod_auth (3.0.0) module to my Slackware 13 (apache 2.2 & MySQL 5.0) system. I ran the usual command line for apxs (as mention in the BUILD file) apxs -c -L/usr/lib/mysql ...