ALSA (Advanced Linux Sound Architecture ) is an API of audio functions for the linux platform.

learn more… | top users | synonyms

1
vote
0answers
16 views

USB MIDI keyboard (Oxygen 61) now not appearing in QJackCtl

I've had a USB Oxygen61 MIDI keyboard for awhile now, and it has worked fine in the past (maybe a month ago, last I tried). But now when I plug it in, it no longer shows up in aconnect -l, and I ...
0
votes
0answers
11 views

Left channel sound level very low compared to Right one

I am using the front analog audio jack from the NUC (microphone in/headphone out/speaker out) with a standard jack and standard speakers or headphones (which work well on another computer). I tried ...
1
vote
0answers
12 views

How to switch off my laptop speaker when headphones is plugged

I've Kubutu 15.04 then KDE Plasma 5 and my laptop speaker doesn't switch off when headphones is plugged. Here my alsamixer snaptshot: My laptop is a ASUS N550L My sound card I found with lspci: ...
1
vote
0answers
14 views

Low volume from rear line out, fine from the front panel

When I plug my headphones in the jack on the rear panel of my machine, the sound comes out low, even after I turn up every imaginable slider from PulseAudio or AlsaMixer or whatever. When I plug them ...
1
vote
0answers
9 views

How to join the two input streams of a multidevice soundcard?

I have an old M-Audio Blackbox that consists of two sub-devices. If I open qjackctl those are advertised as hw:Box,0 and hw:Box,1. Up to now I readily switched between those configurations as needed, ...
0
votes
1answer
672 views

pulse-audio does not recognise my Logitech mic and my Webcam mic

I use the (great) AK5370 microphone for Skype, but it is not recognized by my archlinux i86_64. It also fails to recognize the mic on my Logitech Webcam (PTZ, which I do not use). Both are connected ...
2
votes
0answers
27 views

How to make Alsa Loopback device to work in Puredata

I'm trying to route an audio signal from an Airplay source (with Shairport-sync) to Puredata. To do so, I created a Loopback Device in Alsa. Then I set this virtual device as Shairport's output like ...
0
votes
2answers
35 views

Choppy Sound in Chrome on Linux (flash or HTML5) but not VLC

As the title states, I currently have choppy sound on Chrome in Linux in both flash and HTML5 content, however VLC does not have choppiness. I am running Arch, using Chrome (dev channel), and using ...
2
votes
1answer
17 views

See a serial port as a MIDI IN device

I have connected a MIDI device to my UART RX / serial port /dev/ttyAMA0 using some electronics as described here. I have properly configured the right baud setting (31250 baud, etc.). It works: I can ...
7
votes
1answer
655 views

Merge two audio sources with x11grab, possible?

Currently I'm running with the following setup. ffmpeg \ -i http://pub1.di.fm:80/di_vocaltrance \ -f x11grab -s 1920x1080 -r 25 -i :0.0 \ -c:v libx264 -preset fast -pix_fmt yuv420p -s 1280x800 \ ...
1
vote
1answer
19 views

Plug dmix into JACK

There are several guides of how to use JACK with ALSA dmix plugin, like this and this. All of them suggest to route the JACK output through dmix, which causes a latency to the jackified programs. To ...
4
votes
4answers
1k views

Is there any gnome-shell mixer icon relying on alsa and not pulseaudio?

So, long story short, when I installed Mint 12 on my Dell laptop I realized my HDA-intel sound board have problems with pulseaudio. I uninstalled pulseaudio and got my sound back, but removing ...
2
votes
2answers
598 views

Why does Arch Linux keep Windows headphone mute

I have Windows 7 installed, and headphones work perfectly. Few days ago, I installed Arch Linux along with Win7. This issue appears with gnome/xfce4/openbox. Perhaps it is not related to desktop ...
1
vote
1answer
44 views

How can I use ALSA dmix and multi plugins together?

I'm playing with a console sound visualiser which wants its own ALSA device to listen on. I'm editing ~/.asoundrc. I know I'll need the multi plugin to split the sound data onto separate devices. ...
1
vote
1answer
17 views

Alsamixer has extra things that won't go away

While trying to put a "pre-amp" slider into Alsamixer, using /etc/asound.conf, I managed to get it wrong several times. Each time I changed something in /etc/asound.conf and restarting ALSA, I wound ...
1
vote
0answers
26 views

Share alsa capture device with alsaloop

I'm trying to 'share' the microphone input such that programs can have access to it. Initial naive attempt. In one terminal: alsaloop -C hw:1,0 -P hw:0,0 -t 500 -c1 -A 5 -T-1 --resample -v In ...
0
votes
1answer
1k views

Ubuntu sound not working after sleep/suspend

Whenever I sleep my laptop I mean if I down the flap sound doesn't work, every time i have to restart my laptop for sound to make working. Fo instance right now sound is not working(since I closed ...
0
votes
1answer
62 views

How to troubleshoot audio problems / issues in Arch?

I've been running Arch for almost a year now, and my audio was working great until I started messing around with things (>.>) The reason I started messing around with things is because I want to get ...
2
votes
1answer
1k views

what device name should I have to give in snd_pcm_open other than “default”

I want to record sound from 2 devices simultaneously: internal mic external usb webcam mic Using pulseaudio sound controller, I set either of these devices as default and could record sound with ...
2
votes
1answer
651 views

Trying to hear audio coming from LINE IN using ALSA on Debian

I have a netbook with Debian sid, command line only, using it for a server. I am trying to configure it so that the speakers play back what is going in through the netbook's line in audio port. I can ...
1
vote
1answer
66 views

Issues with arecord command

I'm having some mixed results with the arecord command in the terminal. The hardware I'm using consists of the Cirrus Audio Card for the Raspberry Pi. I'm trying to record a 24-bit 192kHz sound (from ...
2
votes
2answers
1k views

firefox + html5 + .asoundrc = No sound

Here's the problem: Manjaro Xfce/3.15.4, Alsa (No Pulse), Firefox 30 and 31, Gmusicbrowser, mplayer/smplayer Firefox with youtube html5 player - no problems Firefox with youtube html5 player and a ...
0
votes
0answers
33 views

Fedora - Integrated microphone not working

I just installed a fresh Fedora 21, my system is now up to date. Now, my problem is that my integrated microphone is not working. I tried several different fixes that doesn't work (install and ...
0
votes
1answer
27 views

Change audio volume on the right device

I'm trying to change the master output volume of my USB DAC (PCM 2704). When doing aplay -L I get: null Discard all samples (playback) or generate zero samples (capture) default:CARD=ALSA ...
1
vote
1answer
59 views

How do I set the output port on my audio card?

My audio card has two ports, for clarity I'll call them the 'speaker' and 'headphone' port. In windows, the audio control sees two separate ports, and I can switch back and forth between speaker and ...
1
vote
0answers
51 views

Playback and simultaneous recording through external USB sound card

I've an external USB sound card (in my case it's a TerraTec Aureon 7.1 USB). I've looped the earphone-out to the line-in using a 3.5mm jack cable. I'm interested in starting the playback of a MP2 ...
3
votes
0answers
59 views

Set maximum volume in Arch Linux

Recently, I purchased new over-ear headphones that have some really powerful speakers. I usually have to listen at ~4% volume to use them comfortably. Each time I restart my computer, they move back ...
1
vote
1answer
77 views

Why does `systemctl enable rpcbind' change the volume of my sound? And how do I prevent this?

I just did: $ systemctl enable rpcbind And this caused the volume on my headphones to increase severly. First off, I don't understand why this happens, as rpcbind seems completely unrelated to my ...
0
votes
2answers
96 views

Alsa mixer unmute problem on Thinkpad laptop

After updating my Debian jessie laptop yesterday, the mute/unmute button stopped working. The volume up/down buttons work and I can mute the sound but when I press the mute button again to un-mute, ...
3
votes
1answer
589 views

Record audio from multiple devices with ALSA and Pulseaudio

I want to record audio from multiple input devices using ALSA and Pulseaudio. More precisely, I want to play UltraStar Deluxe. It is a game using SDL. As far as I can tell, it supports ALSA only. ...
1
vote
0answers
73 views

PULSEAUDIO does not list my ALSA capture device as a capture source

First of all, Hello everybody! My name is Przemek Gajos and this is my first post here. I have recently written an ALSA driver for my audio capture card and I have problems with PULSEAUDIO ...
1
vote
1answer
320 views

ALSAEQUAL runs, but sliders do not seem to affect audio

I want to have an equalizer that lets me easily adjust sound for listening to music on my laptop with headphones. I'm trying to install ALSAEQUAL since it seems that this is the preferred tool for ...
1
vote
1answer
30 views

audio play not starting at beginning

When I run a audio file with like mpg321 or aplay or sox or even in TTS's (Text to speak) audio only outputs correctly from the second time I reproduce the audio file... per example in Text to ...
1
vote
0answers
30 views

Set up a sound client “server”

I have a server that its main usage is being all day long up and running and serve some VMs to the web. I want to be able to play music from the laptop to the speakers that are connected to the ...
2
votes
1answer
109 views

Lost sound with xmonad

I downloaded this config to set up xmonad. Hit volume up, down, works fine. Hit the volume mute hotkey, sound's gone. All good. Hit the mute key again, sound's still off. Hit volume up, nothing. ...
2
votes
2answers
303 views

How to combine dmix with ladspa plugins to default device

A while I have abandoned all sound daemons and lived happily ever since with just the dmix plugin. However, recently I got annoyed by the different volume levels of youtube videos and decided to plug ...
0
votes
1answer
440 views

mpd fails to open ALSA device where aplay succeeds

I am trying to set up an Raspberry Pi / Raspbian wheezy audio player using the onboard sound hardware via ALSA LADSPA plugins to stereo downmix and compress the audio. aplay, sox, mpg123, moc (cd ...
0
votes
0answers
43 views

my bluetooth headset works, and linphone works, but not together

i have my headset working via bluez-alsa and ~/.asoundrc, and i have linphone working. can anyone clue me how to put 2+2 together and get linphone working through my headset? or any other softphone? ...
0
votes
0answers
238 views

Unable to use python speech_recognition lib Microphone class due to ALSA

I am attempting to write a speech recognition program for the raspberry pi, however I am facing some issues using python's speech_recognition library. From the error messages (posted below) I think ...
2
votes
0answers
52 views

arecord until sound level drops low enough

I am trying to implement constant voice recognition on my Pi at the moment, I am achieving this by having two threads running, one constantly recording (with arecord in a bash script) for X amount of ...
0
votes
0answers
104 views

Archlinux Skype problems with build-in microphone

So. My problems with next: I use pulseaudio as a sound server. I check my mic settings by arecord. All ok, but in Skype mic not working. Only silence. But when I tested it with Skype service and look ...
1
vote
1answer
42 views

PCM not affecting sound volume with ALSA

I have a computer that's running some software developed in our company, that also plays some sounds. For some reason the volume of the sound made by the software isn't affected by the PCM setting in ...
0
votes
0answers
290 views

Can't open audio device /dev/dsp: Device or resource busy

I am install Debian Jessie Beta2 on my laptop, and I just compiled mplayer on it. however when i use mplayer command to play some videos, i can't get the sound, the error shows as below: Can't open ...
1
vote
0answers
86 views

How to troubleshoot jack detection in Pulseaudio

Pulseaudio apparently supports "jack detection", meaning auto-detection of whether anything is plugged into each jack (e.g., headphone jack, line out jack) or not. Unfortunately, Pulseaudio's jack ...
0
votes
0answers
174 views

Jabra BIZ 2400 USB HeadSet doesn't output sound

I'm trying to get my Jabra BIZ 2400 USB HeadSet working on my Debian Jessie install, but I get nothing from the headphones. I've installed Audacity to test things and it will record audio, but then ...
0
votes
1answer
400 views

Problems with USB microphone ARCHLinux

My USB mic in webcam in Skype not working (cam works fine). I use Arch Linux with alsa. I set up pulseaudio but then I removed it because it is not stable. cat /proc/asound/cards 0 [SB ...
1
vote
1answer
93 views

Send sound output to application and speaker

I'm using my Ubuntu 14.04 LTS Laptop toplay music at a party. I'm using Mixxx and is performs very well for that task. Now I'd like to add some light effects and plan to use Qlcplus for that. So I ...
0
votes
0answers
422 views

No sound in arch linux with xfce4

I have installed Arch Linux with Xfce4, I installed alsa-firmware, utils and plugins. I haven't installed PulseAudio. I have no sounds in my laptop at all :/ I have unmuted in alsamixer my speakers. ...
2
votes
1answer
230 views

How to make PulseAudio and OSS only applications coexist on Debian Wheezy?

Before I fell back to ALSA, I had severe problems with PulseAudio deadlocks for years on my Debian system on which I am using some OSS only (requiring /dev/dsp) applications. I would like to see ...
5
votes
5answers
2k views

recording audio from web-based audio player using ALSA loop device

I am trying to save voicemail messages from Verizon Fios phone in best quality possible. The voicemail messages are available online, but for playing only (Java based player), no saving. Officially, ...