ALSA (Advanced Linux Sound Architecture ) is an API of audio functions for the linux platform.

learn more… | top users | synonyms

12
votes
1answer
2k views

Debian systems seems to recognize speakers but not the headphones for Lenovo laptops

First of All, I know there are lot of questions out there on same topic but still I could not figure out the solution. Being a average system level programmer (beginner in kernel programming) I would ...
8
votes
1answer
757 views

Merge two audio sources with x11grab, possible?

Currently I'm running with the following setup. ffmpeg \ -i http://pub1.di.fm:80/di_vocaltrance \ -f x11grab -s 1920x1080 -r 25 -i :0.0 \ -c:v libx264 -preset fast -pix_fmt yuv420p -s 1280x800 \ ...
2
votes
2answers
700 views

Why does Arch Linux keep Windows headphone mute

I have Windows 7 installed, and headphones work perfectly. Few days ago, I installed Arch Linux along with Win7. This issue appears with gnome/xfce4/openbox. Perhaps it is not related to desktop ...
0
votes
1answer
576 views

Problems with USB microphone ARCHLinux

My USB mic in webcam in Skype not working (cam works fine). I use Arch Linux with alsa. I set up pulseaudio but then I removed it because it is not stable. cat /proc/asound/cards 0 [SB ...
4
votes
4answers
1k views

Is there any gnome-shell mixer icon relying on alsa and not pulseaudio?

So, long story short, when I installed Mint 12 on my Dell laptop I realized my HDA-intel sound board have problems with pulseaudio. I uninstalled pulseaudio and got my sound back, but removing ...
2
votes
2answers
45 views

Alsa not detecting my soundcard

So my onboard sound-card died and I bought a new small usb one. With windows it works perfectly, but on my debian testing not so much. It isn't detected by my audio system, and I cannot choose the ...
0
votes
0answers
21 views

Alsa Problems: Playback Crashes Audacity

I have been having this problem in audacity ever since I switched to Arch. I can start audacity and open a mp3 file, but as soon as I press play, the sound is fast, distorted, and crackles. Once I ...
0
votes
1answer
1k views

mpd fails to open ALSA device where aplay succeeds

I am trying to set up an Raspberry Pi / Raspbian wheezy audio player using the onboard sound hardware via ALSA LADSPA plugins to stereo downmix and compress the audio. aplay, sox, mpg123, moc (cd ...
1
vote
0answers
10 views

PulseAudo list-sinks missing ALSA Devices

I'm attempting to switch at runtime between two ALSA devices on the same ALSA card: >>> [blake@e530 ~]$ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], ...
1
vote
1answer
60 views

Int. speaker sound at login screen - but not after login (only ext. speakers work)?

Sound plays (drum roll) at login screen. In Ubuntu and Xubuntu XFCE no sound emits from the laptop speaker, but does from the external speakers. Pulseaudio panel monitor bar dances with the sound.... ...
2
votes
1answer
767 views

Trying to hear audio coming from LINE IN using ALSA on Debian

I have a netbook with Debian sid, command line only, using it for a server. I am trying to configure it so that the speakers play back what is going in through the netbook's line in audio port. I can ...
1
vote
0answers
31 views

USB Audio detected by ALSA but not JACK?

I have a Presonus AudioBox USB device, connected to a USB 3 port, that supports both MIDI and Audio input. When I launch JACK and open the connection list from QJackCtl, I can see that the AudioBox ...
1
vote
0answers
19 views

Headphones always muted after restart

After system restart my headphones are always muted. I have to unmute and crank volume from 0% to 100% using alsamixer. I of course tried to do alsactl store multiple times but it does not help. It is ...
0
votes
1answer
15 views

Setting Alsa to output 44.1kHz

I would like Alsa to output everything at 44.1kHz (by default it looks like it's using 48kHz). I understand that the correct option would be something like: defaults.pcm.dmix.rate 44100 But where ...
0
votes
0answers
2k views

Ubuntu sound not working after sleep/suspend

Whenever I sleep my laptop I mean if I down the flap sound doesn't work, every time i have to restart my laptop for sound to make working. Fo instance right now sound is not working(since I closed ...
1
vote
0answers
23 views

Help me to find my speakers and headphone paths (name of PCM device)

I am really confused trying to get my speakers and headphone device PCM names like a "hw:x,x" or something like that; cat /proc/asound/devices 2: [ 0] : control 3: [ 0- 0]: digital audio ...
2
votes
1answer
2k views

what device name should I have to give in snd_pcm_open other than “default”

I want to record sound from 2 devices simultaneously: internal mic external usb webcam mic Using pulseaudio sound controller, I set either of these devices as default and could record sound with ...
0
votes
1answer
748 views

pulse-audio does not recognise my Logitech mic and my Webcam mic

I use the (great) AK5370 microphone for Skype, but it is not recognized by my archlinux i86_64. It also fails to recognize the mic on my Logitech Webcam (PTZ, which I do not use). Both are connected ...
0
votes
0answers
39 views

RME Multiface (HDSP) sound on Debian/Jessie (Systemd / PulseAudio)

Troubles getting my sound setup to work on a fresh install of Debian/Jessie. The RME Multiface is an external rack mounted Pro Audio interface with a ton of channels and connectors (18 output ...
2
votes
1answer
1k views

Is there an easy way to switch playback soundcards?

I recently purchased the roccat kulo headset which comes with a nice USB soundcard, completely functional under linux :). Howsoever I now struggle to easily siwtch between my laptops integrated ...
0
votes
0answers
45 views

No output from headphones jack (occasionally), although system displays output

I am having an issue where I will start or restart my PC and suddenly no audio comes from the headphones jack. This only happens occasionally, and I don't know the cause. My PC speakers work fine ...
1
vote
0answers
7 views

Increasing volume causes left/right channels to be unbalanced

In Gnome 3, I mapped my volume up to amixer set Master 1000+, and down to amixer set Master 1000-. This works just fine, as long as I spin the volume roller slowly. If I am to spin it really ...
0
votes
2answers
89 views

xfce4-notifyd Not Showing Volume Change Notification on Fedora 22

I am using xfce4 on Fedora 22. I am able to use my volume keys to change the volume and use my mute key with no issue. However, no notification is showing on the desktop indicating volume change. ...
2
votes
1answer
38 views

Alsa mixer for assigning specific apps to a specific soundcard?

I am looking for a Alsa mixer GUI for Xfce (or better yet, desktop-independent) to replace PulseAudio Mixer. While I'm happy with the latter, my USB DAC is very poorly handled by PulseAudio and I need ...
1
vote
0answers
20 views

Snowball microphone no longer shared between applications

I recently bought a Snowball USB microphone for a podcast. Previously, I would record my track using audacity, and simultaneously use the microphone for Skype. I tried to do this yesterday and was ...
2
votes
2answers
207 views

Why there is no sound on my Debian 7?

There is no sound on my Debian 7. How to set the sound properly now? root@localhost:/home/debian# alsactl init Found hardware: "HDA-Intel" "Realtek ALC887-VD" ...
1
vote
0answers
59 views

Sound card not detected by ALSA, but detected by kernel

Running arch linux with: Linux hunchback 3.17.4-1-ARCH #1 SMP PREEMPT Fri Nov 21 21:14:42 CET 2014 x86_64 GNU/Linux When i run: $ aplay -l aplay: device_list:268: no soundcards found... But it ...
0
votes
0answers
27 views

Switching sound card without restarting the browser

Does anyone know if Iceweasel (Firefox) runs HTML5 audio/video in a separate process that can be restarted? With Flash I can restart plugin-container after changing the sound card in ~/.asoundrc. With ...
4
votes
2answers
174 views

Sound crackles and echos to the point of being unusable

I recently got a new desktop, installed debian 64 bit, and found out that the sound doesn't work at all. I'm not entirely sure what information I should give to help identify the problem but I'll do ...
1
vote
1answer
107 views

How to mute microphone using command line in debian 8?

I use lenovo t420. It has mute mic button. But it cannot be assigned to any action, because I got error "The key you just pressed is not supported by Qt" when I'm trying to assign to any action. But ...
1
vote
2answers
2k views

How to change mixing of channels by pulse audio / alsa

I have a recent problem with my sound configuration. Basically, it's way too loud until I set the volume below 10%. And then it's very quickly too silent. Using the alsa mixer, I can set the headphone ...
0
votes
1answer
14 views

alsamixer not incrementing volume at proper interval

I am trying to use amixer to change the volume of the speaker on my computer at an incremental rate. The command below successfully changes the master volume of my speaker, but not at a consistant 5%. ...
0
votes
0answers
14 views

Need help configuring asoundrc

New Dell latitude E5450 I'm almost able to get the sound right. alsamixer does not save its configuration. $ sudo alsactl store $ alsactl store are no help. By trial and error, I did manage to ...
1
vote
0answers
61 views

Use equalizer and an usb audio card

I have Raspbian installed on my Rasperry Pi. I have a Delock USB Audio Card and setted it up, works good. My speaker set has a quite strong bass, so I need an equalizer. There is an alsa plugin which ...
5
votes
1answer
52 views

Default sound volume for all ALSA devices

I woud like to set up the default sound volume once for all, for all ALSA devices that will be connected ever. Of course, I could do amixer ... or even alsamixer to modify the volume of currently ...
1
vote
0answers
29 views

How to find the configuration differences between two identical usb audio dongle devices?

I have two units of the same headset model that use a wireless USB dongle (Logitech H800). Each headset only pairs with its own dongle, but I want to get the same dongle to work with both headsets. ...
2
votes
1answer
78 views

Command line per-application volume (maybe amixer or pactl?)

I can change the master volume with these commands (from the command line), and it affects all applications, but how do I change the volume for just one application (XMMS for example)? amixer -q set ...
1
vote
0answers
13 views

Is it possible to let the active virtual term be the only one with audio access?

I'm currently running Fedora 22 and want a setup where Kodi runs on vterm1 while steam runs on vterm2. I have set up two seats using LightDM. I am currently using ALSA in order to let Kodi bitstream ...
1
vote
0answers
16 views

Speakers don't un-mute after muting the audio

I recently installed Bluedevil on my Fedora 21 XFCE notebook to be able to use my AS-600 bluetooth headphones, and they worked pretty well, the problem now is that whenever I mute the audio by running ...
0
votes
0answers
282 views

How to setup “Creative Sound Core 3D” on Debian Jessie correctly?

I justed installed Debian Jessie and was happy to see (or hear) that my Creative Sound Core 3D (as onboard chip on my Gigabyte GA-X99-Gaming 7 WIFI mainboard) worked out of the box when trying to play ...
1
vote
0answers
36 views

How can I synchronise kmix and alsamixer volumes at maximum?

Occasionally, I can increase kmix's volume to its maximum (using the volume hotkeys), but the sound is still very quiet. I can open up alsamixer, and see Master at ~8%, even though kmix's volume is ...
1
vote
1answer
26 views

Detect when audio card is powered (using alsa)

How can I detect in a script if my audio card is being powered? Motivation: I have a Linux mini computer (Odroid U3), used as a music player. And I want to power on a connected amplifier only when ...
1
vote
1answer
162 views

CVLC: alsa name?

Someone know how to pass an alsa device name to cvlc? I did aplay -L null Discard all samples (playback) or generate zero samples (capture) default:CARD=SB HDA ATI SB, VT1708S Analog ...
2
votes
1answer
47 views

After each reboot, speakers have volume 0

For some reason my audio volume keeps being reduced to zero when I reboot. I am able to fix this temporarily like so: rm ~/.config/pulse/* If I reboot, the volume functions normally. Rebooting ...
1
vote
0answers
101 views

USB MIDI keyboard (Oxygen 61) now not appearing in QJackCtl

I've had a USB Oxygen61 MIDI keyboard for awhile now, and it has worked fine in the past (maybe a month ago, last I tried). But now when I plug it in, it no longer shows up in aconnect -l, and I ...
1
vote
0answers
65 views

How to switch off my laptop speaker when headphones is plugged

I've Kubutu 15.04 then KDE Plasma 5 and my laptop speaker doesn't switch off when headphones is plugged. Here my alsamixer snaptshot: My laptop is a ASUS N550L My sound card I found with lspci: ...
1
vote
0answers
46 views

Low volume from rear line out, fine from the front panel

When I plug my headphones in the jack on the rear panel of my machine, the sound comes out low, even after I turn up every imaginable slider from PulseAudio or AlsaMixer or whatever. When I plug them ...
1
vote
0answers
13 views

How to join the two input streams of a multidevice soundcard?

I have an old M-Audio Blackbox that consists of two sub-devices. If I open qjackctl those are advertised as hw:Box,0 and hw:Box,1. Up to now I readily switched between those configurations as needed, ...
2
votes
0answers
112 views

How to make Alsa Loopback device to work in Puredata

I'm trying to route an audio signal from an Airplay source (with Shairport-sync) to Puredata. To do so, I created a Loopback Device in Alsa. Then I set this virtual device as Shairport's output like ...
0
votes
2answers
119 views

Choppy Sound in Chrome on Linux (flash or HTML5) but not VLC

As the title states, I currently have choppy sound on Chrome in Linux in both flash and HTML5 content, however VLC does not have choppiness. I am running Arch, using Chrome (dev channel), and using ...