ALSA (Advanced Linux Sound Architecture ) is an API of audio functions for the linux platform.

learn more… | top users | synonyms

0
votes
1answer
15 views
+50

Alsa mixer unmute problem on Thinkpad laptop

After updating my Debian jessie laptop yesterday, the mute/unmute button stopped working. The volume up/down buttons work and I can mute the sound but when I press the mute button again to un-mute, ...
1
vote
1answer
39 views

Why does `systemctl enable rpcbind' change the volume of my sound? And how do I prevent this?

I just did: $ systemctl enable rpcbind And this caused the volume on my headphones to increase severly. First off, I don't understand why this happens, as rpcbind seems completely unrelated to my ...
1
vote
0answers
39 views
+50

PULSEAUDIO does not list my ALSA capture device as a capture source

First of all, Hello everybody! My name is Przemek Gajos and this is my first post here. I have recently written an ALSA driver for my audio capture card and I have problems with PULSEAUDIO ...
1
vote
1answer
20 views

audio play not starting at beginning

When I run a audio file with like mpg321 or aplay or sox or even in TTS's (Text to speak) audio only outputs correctly from the second time I reproduce the audio file... per example in Text to ...
1
vote
0answers
9 views

Set up a sound client “server”

I have a server that its main usage is being all day long up and running and serve some VMs to the web. I want to be able to play music from the laptop to the speakers that are connected to the ...
0
votes
1answer
111 views

mpd fails to open ALSA device where aplay succeeds

I am trying to set up an Raspberry Pi / Raspbian wheezy audio player using the onboard sound hardware via ALSA LADSPA plugins to stereo downmix and compress the audio. aplay, sox, mpg123, moc (cd ...
1
vote
1answer
63 views

Lost sound with xmonad

I downloaded this config to set up xmonad. Hit volume up, down, works fine. Hit the volume mute hotkey, sound's gone. All good. Hit the mute key again, sound's still off. Hit volume up, nothing. ...
0
votes
0answers
16 views

my bluetooth headset works, and linphone works, but not together

i have my headset working via bluez-alsa and ~/.asoundrc, and i have linphone working. can anyone clue me how to put 2+2 together and get linphone working through my headset? or any other softphone? ...
0
votes
0answers
89 views

Unable to use python speech_recognition lib Microphone class due to ALSA

I am attempting to write a speech recognition program for the raspberry pi, however I am facing some issues using python's speech_recognition library. From the error messages (posted below) I think ...
0
votes
0answers
72 views

Archlinux Skype problems with build-in microphone

So. My problems with next: I use pulseaudio as a sound server. I check my mic settings by arecord. All ok, but in Skype mic not working. Only silence. But when I tested it with Skype service and look ...
2
votes
0answers
38 views

arecord until sound level drops low enough

I am trying to implement constant voice recognition on my Pi at the moment, I am achieving this by having two threads running, one constantly recording (with arecord in a bash script) for X amount of ...
1
vote
1answer
23 views

PCM not affecting sound volume with ALSA

I have a computer that's running some software developed in our company, that also plays some sounds. For some reason the volume of the sound made by the software isn't affected by the PCM setting in ...
0
votes
0answers
86 views

Can't open audio device /dev/dsp: Device or resource busy

I am install Debian Jessie Beta2 on my laptop, and I just compiled mplayer on it. however when i use mplayer command to play some videos, i can't get the sound, the error shows as below: Can't open ...
1
vote
0answers
37 views

How to troubleshoot jack detection in Pulseaudio

Pulseaudio apparently supports "jack detection", meaning auto-detection of whether anything is plugged into each jack (e.g., headphone jack, line out jack) or not. Unfortunately, Pulseaudio's jack ...
0
votes
0answers
103 views

Jabra BIZ 2400 USB HeadSet doesn't output sound

I'm trying to get my Jabra BIZ 2400 USB HeadSet working on my Debian Jessie install, but I get nothing from the headphones. I've installed Audacity to test things and it will record audio, but then ...
1
vote
1answer
52 views

Send sound output to application and speaker

I'm using my Ubuntu 14.04 LTS Laptop toplay music at a party. I'm using Mixxx and is performs very well for that task. Now I'd like to add some light effects and plan to use Qlcplus for that. So I ...
0
votes
1answer
232 views

Problems with USB microphone ARCHLinux

My USB mic in webcam in Skype not working (cam works fine). I use Arch Linux with alsa. I set up pulseaudio but then I removed it because it is not stable. cat /proc/asound/cards 0 [SB ...
0
votes
0answers
171 views

No sound in arch linux with xfce4

I have installed Arch Linux with Xfce4, I installed alsa-firmware, utils and plugins. I haven't installed PulseAudio. I have no sounds in my laptop at all :/ I have unmuted in alsamixer my speakers. ...
2
votes
1answer
130 views

How to make PulseAudio and OSS only applications coexist on Debian Wheezy?

Before I fell back to ALSA, I had severe problems with PulseAudio deadlocks for years on my Debian system on which I am using some OSS only (requiring /dev/dsp) applications. I would like to see ...
1
vote
0answers
74 views

Why PulseAudio can not mix multiple OSS program's sound output? [closed]

I have (had) problems with PulseAudio frequently deadlocking when starting applications using OSS for sound output. I would like to know how to fix / work these around if possible, or if not, since I ...
2
votes
0answers
58 views

Recording loopback doesn't work with alsa

I want to record a sound from speakers, not a microphone in my Linux desktop. I'm using Centos 7. I searched this subject and found this thread but it only partially works. I edited my .asoundrc ...
1
vote
1answer
145 views

Alsa resampling

My setup is Vortexbox 2.3, a Linux music distro based on Fedora. I have a multichannel sound card, USBStreamer from miniDSP. I have set up separate stereo devices in asound.conf so I can have ...
0
votes
1answer
42 views

Enable microphone on boot

On Arch Linux with Gnome 3.14, the microphone is disabled by default. So every time I need to use Skype I need to open Sound settings and enable the mic. How do I enable the mic so that it's ...
1
vote
0answers
107 views

Why don't I hear audio playing from my CentOS 6.5 Vagrant box?

I want to play a wave file from my CentOS 6.5 Vagrant box using aplay and of course I want to hear the sound. This is what I do: > aplay sine.wav Playing WAVE 'sine.wav' : Signed 16 bit Little ...
0
votes
0answers
16 views

Dynamic audio sinks and sources with alsa

So, I have a speakers, a usb headset, and HDMI output available to my system and would like to switch which is used by any specific application, or all of them on the fly. So far I am able to use ...
1
vote
1answer
167 views

No sound on linux

Have no sound on my system (opensuse 13.1 | gnome 3.12). alsamixer ALSA lib control.c:953:(snd_ctl_open_noupdate) Invalid CTL default cannot open mixer: No existe el fichero o el directorio Some ...
1
vote
0answers
73 views

System freeze on “setting up alsa”

I use Debian wheezy and I boot the computer and get stuck in the line: [....] setting up alsa .... It freezes, it only responds to "REUSIB" (Emergency Reboot With Magic SysRq), but it is unusable as ...
0
votes
1answer
315 views

No Audio on my system (currently running elementary OS)

So I haven't used a Linux distribution in a long while, and I decided to install it in my new computer. I settled for Elementary OS, but it seems I am completely unable to get my computer to play any ...
1
vote
1answer
65 views

how to test sco packets in bluetooth

Issue : Monitor sco packets between master and slave bluetooth. Description of problem. I have small in-house Bluetooth device (developed in Linux fedora OS) and is configured as slave device. I am ...
1
vote
1answer
352 views

Low sound volume issues on Z97 motherboard and linux mint KDE

I've recently set up a new system with MSI Z97 gaming 5 motherboard however the first issue I've encountered was that the sound was crackling. I've fixed that by updating the kernel to 3.16.3 Now the ...
5
votes
0answers
806 views

Debian systems seems to recognize speakers but not the headphones for Lenovo laptops

First of All, I know there are lot of questions out there on same topic but still I could not figure out the solution. Being a average system level programmer (beginner in kernel programming) I would ...
1
vote
1answer
23 views

snd_rawmidi_open() waits forever - no error message

I am trying to use ALSA for MIDI purposes in C. My problem is, snd_rawmidi_open() sort of "crashes" (waits forever like a while loop) when using valuable arguments : #include <stdio.h> ...
0
votes
1answer
53 views

Jack not recognizing MIDI device

Jack does not recognize my MIDI keyboard, whereas ALSA does. Here are the logs : pi@raspberrypi / $ jack_lsp system:playback_1 system:playback_2 LinuxSampler:midi_in_0 LinuxSampler:0 ...
3
votes
1answer
63 views

ALSA sampling rate

Couple of questions: If you set the capture sampling rate in ALSA API to say 1000Hz, is the input really sampled at 1000Hz, or does the sound card always sample at its maximum capable sampling rate, ...
0
votes
0answers
98 views

.asoundrc, alsaequal as default breaks firefox MP3 playback

Alright, so the important thing to note here is that it (appears) to ONLY break MP3 playback, other formats work. Youtube html5 videos and .ogg playback work fine and use the equalizer as expected, ...
0
votes
0answers
46 views

HDA Realtek and Auto-Sensing Disable

I have a couple different devices using Realtek audio chipsets (one is ALC269VC, another is ALC262). On both devices (laptop/tablet type devices, with internal speakers and a headphone jack) when I ...
0
votes
0answers
190 views

Crunchbang Linux Waldorf: Sound Problems with NVIDIA Corporation MCP61 High Definition Audio (rev a2)

$ lspci | grep -i audio 00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2) 02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device aab0 $ sudo speaker-test ...
2
votes
0answers
57 views

PulseAudio: Sound works after first pacat call

I've got a strange problem with PulseAudio and a gstreamer python script (pygst). The script below works only if I execute a cat /dev/urandom | pacat before. I've absolutely no idea what can ...
2
votes
0answers
72 views

Modify sound volume per application [closed]

In Fedora 12 + Gnome 2 I used to be able to modify the volume of each application seperately. Now, I'm on Fedora 20 + MATE 1.6.2, and this option is gone. If I click Notification Area > Sound > ...
3
votes
0answers
124 views

Sound crackles and echos to the point of being unusable

I recently got a new desktop, installed debian 64 bit, and found out that the sound doesn't work at all. I'm not entirely sure what information I should give to help identify the problem but I'll do ...
2
votes
3answers
80 views

Alsa driver update in client machine without make

I have a Debian 6 system and updated alsa from 1.0.23 to 1.0.25, It works as expected. Steps which I performed to compile: ./configure make make install Now , I have 100's of client machines in ...
2
votes
0answers
585 views

Configuring USB digital microphone under Linux

I just bought a digital USB microphone. It looks nice, but I cannot make it work. I use openSuse 12.3. How do I ever know whether my system has the drivers for such and such microphone? The good ...
1
vote
2answers
508 views

Volume too quiet at maximum

I recently replaced my broken Sennheiser PC350 to a Beyerdynamic DT770 Pro 80 Ohm headphones and I've encountered a really annoying issue. Everything is too low. I can listen to it, but it's almost as ...
2
votes
0answers
147 views

Focusrite Scarlett on Linux input mapping?

Does anyone use these interfaces on Linux? If so, how do the inputs map (e. g. with ALSA/PulseAudio)? E. g. the Scarlett 6i6 has the following connections. Inputs: 2x symmetric XLR inputs (one for ...
1
vote
1answer
112 views

Set Sound Settings to 152% on Boot (LMDE)

I have installed Linux Mint Debian Edition and everything is working correctly, except that 100% sound setting is not ideal on my speakers, so I see that I can increase it to 152% from my sound ...
2
votes
1answer
1k views

firefox + html5 + .asoundrc = No sound

Here's the problem: Manjaro Xfce/3.15.4, Alsa (No Pulse), Firefox 30 and 31, Gmusicbrowser, mplayer/smplayer Firefox with youtube html5 player - no problems Firefox with youtube html5 player and a ...
1
vote
1answer
343 views

Focusrite Scarlett 8i6 With linux mint

I have a focusrite scarlett 8i6 soundcard and I would like to make many sounds with it. Currently it's deadly silent and I want to crack on with some programming whilst listening to music! I usually ...
0
votes
0answers
95 views

Calling speaker-test from usermode-helper API

I needed to call come audio-producing applications from kernel in a toy module. In order to test that, I thought of calling speaker-test from a simpler module, but no sound would ever come from it. I ...
0
votes
0answers
112 views

Understanding Mixing of sounds in ALSA

I can't seem to bend ALSA completely to my will, even after I spent a lot of time configuring it. I just do not seem to understand it well enough. Here is my /etc/asound.conf: pcm.dmixed { ...
2
votes
1answer
253 views

FFmpeg doesn't recognize my audio sources

I want to record my screen with audio for practice. I saw recommendations to use this command line: ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 25 -s 800x600 -i :0.0+200,100 -c:a pcm_s16le -c:v ...