Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install apt-get install php5-dev but when I run the command

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-dev: Depends: autoconf (>= 2.63) but 2.61-8 is to be installed
            Depends: libtool (>= 2.2) but it is not going to be installed
E: Broken packages

How can I solve this situation?

share|improve this question

migrated from stackoverflow.com Mar 24 '11 at 0:05

This question came from our site for professional and enthusiast programmers.

1  
You know what's disturbing? Googling the error and finding this question as the #3 result. Damnit Google, stop that! –  Charles Mar 22 '11 at 16:03
1  
tried to apt-get install libtool ? –  MiPnamic Mar 22 '11 at 16:03
2  
@albertopriore, what happens if you try to install libtool? Also, this probably belongs over on ServerFault. –  Charles Mar 22 '11 at 16:03
    
I've installed libtool and autoconf but it still do not work. What can I do now? –  albertopriore Mar 22 '11 at 16:29
    
@alberto, has the error message changed? If so, please edit your question and add the new error. –  Charles Mar 22 '11 at 16:53

1 Answer 1

up vote 2 down vote accepted

The problem is that you are trying to install php5-dev from squeeze instead of lenny. The lenny version of php5-dev doesn't depend on any particular version of libtool or autoconf the way that the squeeze version does. If I were to guess how you got into this situation, I'd guess that you got into this because you now or at some time had "squeeze" in your sources.list and installed some stuff, or perhaps you are referencing "stable" instead of "lenny" or "squeeze" in your sources.list and now you might be running some mix of lenny in squeeze.apt-cache policy php5-dev should tell you where you are getting php5-dev from, which might help.

share|improve this answer
    
I had a similar issue when upgrading from lenny to squeeze. Make sure all your apt sources reference the correct version. –  Rocket Mar 23 '11 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.