Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a laptop with Broadcom 4313 wireless module, using Ubuntu 13.10 and Windows 7 as OS

When reconnecting to network or when waking laptop from suspend/rebooting it sometimes cannot connect to any wireless network. Disable/re-enable network doesn't help. I have to reboot laptop few times in a row to make it work again.

It throws these errors to syslog:

wpa_supplicant[1091]: wlan0: Authentication with xx:xx:xx:xx:b4:80 timed out.
NetworkManager[814]: <info> (wlan0): supplicant interface state: associating -> disconnected
NetworkManager[814]: <info> (wlan0): supplicant interface state: disconnected -> scanning
wpa_supplicant[1091]: wlan0: Trying to associate with xx:xx:xx:xx:b4:80 (SSID='xxxxxxxxx' freq=2457 MHz)
NetworkManager[814]: <info> (wlan0): supplicant interface state: scanning -> associating
wpa_supplicant[1091]: wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wpa_supplicant[1091]: wlan0: Authentication with xx:xx:xx:xx:b4:80 timed out.

The only solution to have any wireless connection is to switch from proprietary driver wl to opensource brcmsmac (or reboot few times), the the second one has so poor connection even if sitting next to wireless router that it becomes unusable in most situations.

Btw, sometimes it even happens on Windows, but it has some 'troubleshooting' routine which somehow makes it work then.

Does anyone know why this is happening?

Is there any way to properly flush networking so it will think that system has just rebooted? service networking restart doesn't fit because it breaks X server somehow.

Google doesn't give me any clue how to fix it.

share|improve this question
    
Did you get it sorted? –  matcheek Dec 26 '13 at 21:23
add comment

1 Answer 1

For the benefit of people landing on this page

There is a bug raised on launchpad

In the comment #29 there is a solution provided that is to reload the wl module:

modprobe -r wl && modprobe wl
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.