Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Network manager is the one thing that holds my system boot time from becaming really barelly existing. I'm connecting to wi-fi. My boot chain indicates what's wrong with network manager:

graphical.target @12.494s
└─multi-user.target @12.494s
  └─ntpd.service @12.198s +295ms
    └─network.target @12.172s
      └─NetworkManager.service @5.914s +6.258s
        └─basic.target @5.913s
          └─timers.target @5.912s
            └─systemd-tmpfiles-clean.timer @5.912s
              └─sysinit.target @5.912s
                └─systemd-update-utmp.service @5.861s +50ms
                  └─systemd-tmpfiles-setup.service @5.834s +26ms
                    └─local-fs.target @5.833s
                      └─opt.mount @5.712s +120ms
                        └─systemd-fsck@dev-sda7.service @5.303s +395ms
                          └─dev-sda7.device @5.302s

When I move to static network boot with wpa_supplicant, time cuts by reasonatble amount. However I want to use Network manager after boot anyway. Is there any way to make network manager way faster (Wicd is not helping it has even worse boot time), or get rid/substitute it in boot sequence and load it latter (probably only after GUI was loaded, for example). This is my entire blame table, with all services:

  6.258s NetworkManager.service
  4.501s gdm.service
  2.436s thermald.service
  2.429s systemd-logind.service
  1.297s systemd-vconsole-setup.service
  1.125s systemd-binfmt.service
  1.120s kmod-static-nodes.service
  1.042s colord.service
   913ms systemd-modules-load.service
   851ms systemd-remount-fs.service
   765ms systemd-fsck@dev-sda6.service
   578ms sys-kernel-debug.mount
   576ms dev-hugepages.mount
   576ms polkit.service
   568ms dev-mqueue.mount
   523ms systemd-udev-trigger.service
   519ms systemd-sysctl.service
   464ms wpa_supplicant.service
   438ms upower.service
   405ms tmp.mount
   395ms systemd-fsck@dev-sda7.service
   352ms accounts-daemon.service
   295ms ntpd.service
share|improve this question

1 Answer 1

You don't have NetworkManager-wait-online.service at all? That would be one thing you can disable/mask if your system doesn't depend on network for booting. This also took something like 6s during boot here. You probably have to mask it via systemctl mask NetworkManager-wait-online.service as it seems disabling it does not persist.

It might also be worth looking at the chart created by
systemd-analyze plot > boot.svg to see if your boot process is really waiting on networkmanager or if the boot continues in parallel.

You could also try to debug networkmanager further by adding a section

[logging]
level=DEBUG

into /etc/NetworkManager/NetworkManager.conf to see what it's doing during the time where it supposedly blocks your boot. Log can be obtained via
journalctl -b -u NetworkManager.service for the current boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.