Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've noticed this when trying to watch movies on that laptop running eOS. After 10 minutes or so the display is turned down.

I've looked for settings against this and found the following:

  • Power setting: put the computer to sleep: I set that to 'Never'. But it couldn't be this setting, my problem being that the display is shut, not that the computer is put to sleep.

  • Brightness and lock: Brightness: Turn screen off when inactive for: set that to 'Never'. That should be it but it does not work.

   enter image description here

Because I'd experienced a similar issue with GUI settings for display not being followed in another Ubuntu based distro - Xfce - reported here - I imagined also that a screensaver setting was the matter. I've found a situation similar to that and tried that solution. Only that, unlike in Xfce, now a gnome-screensaver was installed but without accessible GUI settings for it. So, it looked like a certain blank-screen screensaver was active in the background. To get a GUI for screensaver I installed xscreensaver. When starting that I was prompted that gnome-screensaver was already running and asked to shut it down. Said yes and then disabled screensaver in Xscreensaver.

  enter image description here

Afterwards I also uninstalled gnome-screensaver, but the same problem would still reappear.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Background

There are 2 solutions that were determined for this particular problem. The 1st involved launching xscreensaver, and disabling it so that no screensaver is configured.

The 2nd method involved completely disabling the screensaver in X altogether, through the use of the xset command.

Solution #1

A solution with a narrow scope (by cipricus) is that of adding a fourth step to those included in the answer.

  1. Install xscreensaver
  2. Remove gnome-screensaver
  3. Set Xscreensaver NOT to use any screensaver ('Disable screensaver')
  4. Add xscreensaver in the startup programs list. The command to add is:

    xscreensaver -no-splash
    

This solution was suggested by the fact that this message appeared when starting xscreensaver before adding the fourth step:

                    enter image description here

Further instructions came from this source.

NOTE: To add a program to startup list in eOS, go to System Settings > Stertup Applications > Add

Solution #2

A solution with a wider scope by slm:

xset

Check to see what the xset setting is for screen blanking as well. You can check using this command:

$ xset q

We're specifically interested in this section of the output from the above command:

$ xset q
...
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
...

Disabling screensaver

You can change these settings like this:

$ xset s off
$ xset s noblank

Confirm by running xset q again:

$ xset q
...
Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  0    cycle:  600
...

DPMS

You might also need to disable power management as well, that's the DPMS settings in the xset q output:

$ xset q
...
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
...

Disable it like so:

$ xset -dpms

Confirm:

$ xset q
...
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled
...

Re-enabling features

You can re-enable these features at any time with these commands

$ xset s blank       # blanking screensaver
$ xset s 600 600     # five minute interval
$ xset +dpms         # enable power management

Confirming changes:

$ xset q
...
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
...
...
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
...

share|improve this answer
    
i was about to answer myself. maybe i will add as edit to your answer if that's all right with you: starting xscreenserver i got a message that the daemon is not running, so i guessed it should have started with the system and that it was not. so, i added to startup applications the command xscreensaver -no-splash. after restart, the xset q command gives under 'screenserver': prefer blanking: no allow exposures: no timeout: 0 cycle: 0. but i hadn't time to watch a movie for 10 minutes yet :) –  cipricus Nov 5 '13 at 11:40
    
@cipricus - your call. Either edit or add I'm fine either way 8-) –  slm Nov 5 '13 at 12:48

This is on freya mind you, but I went into dconf-editor then org.gnome.desktop.session and just turned the value for idle-delay to 0. It seems to have stopped the dimming during videos...or maybe I'm delusional and keep moving my mouse a lot more than I think I do. But I've found it to work. So yeah!

Image of what I mean: enter image description here

sudo apt-get install dconf-tools, I think is how you can draw this into freya to get the editor that is visible in the image.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.