Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My wifi Wireless-N 2230 has quite often connection problems. My system is Fedora 18. Below are some logs from /var/log/messages. I can see that it changes "World regulatory domain" from PL to CZ and back all the time but not sure what that means.

Nov  4 00:21:38 den kernel: [158784.028392] wlan0: disassociating from 00:01:38:fb:84:9d by local choice (reason=3)
Nov  4 00:21:38 den kernel: [158784.033850] cfg80211: Calling CRDA to update world regulatory domain
Nov  4 00:21:38 den kernel: [158784.034732] wlan0: deauthenticating from 00:01:38:fb:84:9d by local choice (reason=3)
Nov  4 00:21:38 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associated -> disconnected
Nov  4 00:21:38 den kernel: [158784.046507] cfg80211: World regulatory domain updated:
Nov  4 00:21:38 den kernel: [158784.046516] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:38 den kernel: [158784.046521] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.046526] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.046529] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.046533] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.046537] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.046577] cfg80211: Calling CRDA for country: CZ
Nov  4 00:21:38 den kernel: [158784.051348] cfg80211: Regulatory domain changed to country: CZ
Nov  4 00:21:38 den kernel: [158784.051354] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:38 den kernel: [158784.051359] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.051363] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2301 mBm)
Nov  4 00:21:38 den kernel: [158784.051366] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:38 den kernel: [158784.051370] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)                                                          
Nov  4 00:21:38 den kernel: [158784.051373] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)                                                      
Nov  4 00:21:39 den NetworkManager[855]: <info> (wlan0): supplicant interface state: disconnected -> scanning                                                             
Nov  4 00:21:39 den kernel: [158785.560724] wlan0: authenticate with 00:01:38:fb:84:9d
Nov  4 00:21:39 den kernel: [158785.562341] wlan0: send auth to 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:39 den kernel: [158785.564375] wlan0: authenticated
Nov  4 00:21:39 den kernel: [158785.564826] iwlwifi 0000:02:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Nov  4 00:21:39 den kernel: [158785.564835] iwlwifi 0000:02:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Nov  4 00:21:39 den kernel: [158785.564840] iwlwifi 0000:02:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Nov  4 00:21:39 den kernel: [158785.564995] wlan0: associate with 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:39 den NetworkManager[855]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Nov  4 00:21:39 den kernel: [158785.567720] wlan0: RX AssocResp from 00:01:38:fb:84:9d (capab=0x431 status=0 aid=3)
Nov  4 00:21:39 den NetworkManager[855]: <info> (wlan0): supplicant interface state: authenticating -> associating
Nov  4 00:21:39 den kernel: [158785.571052] wlan0: associated
Nov  4 00:21:39 den kernel: [158785.571223] cfg80211: Calling CRDA for country: PL
Nov  4 00:21:39 den kernel: [158785.575645] cfg80211: Regulatory domain changed to country: PL
Nov  4 00:21:39 den kernel: [158785.575653] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:39 den kernel: [158785.575658] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:39 den kernel: [158785.575662] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:39 den kernel: [158785.575665] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:39 den kernel: [158785.575669] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
Nov  4 00:21:39 den kernel: [158785.575673] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Nov  4 00:21:39 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associating -> associated
Nov  4 00:21:49 den kernel: [158795.577247] wlan0: disassociating from 00:01:38:fb:84:9d by local choice (reason=3)
Nov  4 00:21:49 den kernel: [158795.584453] cfg80211: Calling CRDA to update world regulatory domain
Nov  4 00:21:49 den kernel: [158795.585791] wlan0: deauthenticating from 00:01:38:fb:84:9d by local choice (reason=3)
Nov  4 00:21:49 den kernel: [158795.591456] cfg80211: World regulatory domain updated:
Nov  4 00:21:49 den kernel: [158795.591465] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:49 den kernel: [158795.591470] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.591475] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.591478] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.591482] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.591486] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.591517] cfg80211: Calling CRDA for country: CZ
Nov  4 00:21:49 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associated -> disconnected
Nov  4 00:21:49 den kernel: [158795.597174] cfg80211: Regulatory domain changed to country: CZ
Nov  4 00:21:49 den kernel: [158795.597177] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:49 den kernel: [158795.597178] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.597180] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2301 mBm)
Nov  4 00:21:49 den kernel: [158795.597181] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:49 den kernel: [158795.597182] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
Nov  4 00:21:49 den kernel: [158795.597183] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Nov  4 00:21:50 den NetworkManager[855]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Nov  4 00:21:51 den kernel: [158797.086187] wlan0: authenticate with 00:01:38:fb:84:9d
Nov  4 00:21:51 den kernel: [158797.090017] wlan0: send auth to 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:51 den NetworkManager[855]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Nov  4 00:21:51 den kernel: [158797.091987] wlan0: authenticated
Nov  4 00:21:51 den kernel: [158797.092377] iwlwifi 0000:02:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Nov  4 00:21:51 den kernel: [158797.092390] iwlwifi 0000:02:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Nov  4 00:21:51 den kernel: [158797.092398] iwlwifi 0000:02:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Nov  4 00:21:51 den kernel: [158797.093302] wlan0: associate with 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:51 den kernel: [158797.096083] wlan0: RX AssocResp from 00:01:38:fb:84:9d (capab=0x431 status=0 aid=3)
Nov  4 00:21:51 den NetworkManager[855]: <info> (wlan0): supplicant interface state: authenticating -> associating
Nov  4 00:21:51 den kernel: [158797.099180] wlan0: associated
Nov  4 00:21:51 den kernel: [158797.099395] cfg80211: Calling CRDA for country: PL
Nov  4 00:21:51 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associating -> associated
Nov  4 00:21:51 den kernel: [158797.106784] cfg80211: Regulatory domain changed to country: PL
Nov  4 00:21:51 den kernel: [158797.106793] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:51 den kernel: [158797.106798] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:51 den kernel: [158797.106802] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:51 den kernel: [158797.106805] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:51 den kernel: [158797.106809] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
Nov  4 00:21:51 den kernel: [158797.106812] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Nov  4 00:21:52 den NetworkManager[855]: <warn> Activation (wlan0/wireless): association took too long.
Nov  4 00:21:52 den kernel: [158798.436347] wlan0: deauthenticating from 00:01:38:fb:84:9d by local choice (reason=3)
Nov  4 00:21:52 den NetworkManager[855]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Nov  4 00:21:52 den NetworkManager[855]: <warn> Activation (wlan0/wireless): asking for new secrets
Nov  4 00:21:52 den kernel: [158798.440551] cfg80211: Calling CRDA to update world regulatory domain
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Nov  4 00:21:52 den kernel: [158798.446961] cfg80211: World regulatory domain updated:
Nov  4 00:21:52 den kernel: [158798.446972] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:52 den kernel: [158798.446985] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.446987] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.446989] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.446990] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.446992] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.447008] cfg80211: Calling CRDA for country: CZ
Nov  4 00:21:52 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associated -> disconnected
Nov  4 00:21:52 den NetworkManager[855]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Nov  4 00:21:52 den kernel: [158798.451172] cfg80211: Regulatory domain changed to country: CZ
Nov  4 00:21:52 den kernel: [158798.451176] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:52 den kernel: [158798.451178] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.451180] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2301 mBm)
Nov  4 00:21:52 den kernel: [158798.451182] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:52 den kernel: [158798.451184] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
Nov  4 00:21:52 den kernel: [158798.451186] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Nov  4 00:21:52 den NetworkManager[855]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Nov  4 00:21:52 den NetworkManager[855]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0/wireless): connection 'Auto Ikarie' has security, and secrets exist.  No new secrets needed.
Nov  4 00:21:52 den NetworkManager[855]: <info> Config: added 'ssid' value 'Ikarie'
Nov  4 00:21:52 den NetworkManager[855]: <info> Config: added 'scan_ssid' value '1'
Nov  4 00:21:52 den NetworkManager[855]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Nov  4 00:21:52 den NetworkManager[855]: <info> Config: added 'psk' value '<omitted>'
Nov  4 00:21:52 den NetworkManager[855]: <info> Config: added 'proto' value 'WPA RSN'
Nov  4 00:21:52 den NetworkManager[855]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Nov  4 00:21:52 den NetworkManager[855]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Nov  4 00:21:53 den kernel: [158799.070448] wlan0: authenticate with 00:01:38:fb:84:9d
Nov  4 00:21:53 den kernel: [158799.073906] wlan0: send auth to 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:53 den kernel: [158799.075947] wlan0: authenticated
Nov  4 00:21:53 den kernel: [158799.076258] iwlwifi 0000:02:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Nov  4 00:21:53 den kernel: [158799.076269] iwlwifi 0000:02:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Nov  4 00:21:53 den kernel: [158799.076276] iwlwifi 0000:02:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Nov  4 00:21:53 den NetworkManager[855]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Nov  4 00:21:53 den kernel: [158799.077217] wlan0: associate with 00:01:38:fb:84:9d (try 1/3)
Nov  4 00:21:53 den kernel: [158799.080030] wlan0: RX AssocResp from 00:01:38:fb:84:9d (capab=0x431 status=0 aid=3)
Nov  4 00:21:53 den NetworkManager[855]: <info> (wlan0): supplicant interface state: authenticating -> associating
Nov  4 00:21:53 den kernel: [158799.083331] wlan0: associated
Nov  4 00:21:53 den kernel: [158799.083503] cfg80211: Calling CRDA for country: PL
Nov  4 00:21:53 den kernel: [158799.088635] cfg80211: Regulatory domain changed to country: PL
Nov  4 00:21:53 den kernel: [158799.088643] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Nov  4 00:21:53 den kernel: [158799.088648] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:53 den kernel: [158799.088652] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:53 den kernel: [158799.088656] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
Nov  4 00:21:53 den kernel: [158799.088659] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
Nov  4 00:21:53 den kernel: [158799.088663] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Nov  4 00:21:53 den NetworkManager[855]: <info> (wlan0): supplicant interface state: associating -> associated
share|improve this question
    
Regarding the regulatory domain, your computer seems to be confused about whether it's Poland or Czechoslovakia. Couldn't say why, though. –  Matthew Cline Nov 3 '13 at 22:54
add comment

1 Answer

up vote 1 down vote accepted

See this previous question, titled: recurrent loss of wireless connectivity. The N-1000 cards have continuously suffered from this issue. Generally there has been 3 options to get around it:

  1. Disable Wireless-N on your WiFi access point
  2. Disable Wireless-N in the WiFi client
  3. Upgraded the firmware or drivers to resolve the issue
share|improve this answer
    
Thank you! It is not that often that it happens so ill go with removing/adding the wifi kernel module (they say it is iwlang, in my case it is iwldvm). –  clime Nov 4 '13 at 0:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.