Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

It's like this: (U+201C) (U+201D).

share|improve this question
    
Gnome? KDE? Any particular application? –  Mikel Mar 22 '11 at 8:52
    
See superuser.com/questions/59418/… –  Mikel Mar 22 '11 at 8:54

6 Answers 6

up vote 6 down vote accepted

In Gnome, you would press and hold down Ctrl+Shift, then type u201c.

Of course, that won't work in Gnome Terminal if Ctrl+Shift+c is bound to Copy, in which case type it in GEdit and paste it in, or learn how to enter it in your editor of choice.

share|improve this answer
8  
You only have to hold down ctrl+shift while typing the u. After that you can let go of ctrl and shift and type 201c followed by a space. –  Wodin Mar 22 '11 at 21:06
    
@Wodin: The documentation says you have to keep holding it until the end of the numbers, but you're right, it seems to work if you let go after typing the u. –  Mikel Mar 22 '11 at 22:20
    
Would be a pain if you had to keep holding them for the whole thing :) I'm sure I've seen documentation that mentioned my way, but I have no idea where I saw it. –  Wodin Mar 24 '11 at 11:02

If you have a Compose key (on some PC configurations, it's the key to the left of the right Ctrl key):
    Compose < "     Compose > "

share|improve this answer
2  
No, it doesn't work for me. I've set the Compose key to the right Alt, but either holding it or tapping it won't make <" to “ –  trVoldemort Mar 23 '11 at 1:42
    
@trVoldemort Using Compose < " and Compose > " worked for me. If it helps, I am using Linux Mint 12, running the unity shell, on a Macbook Pro, with the right option key set to Multi_key in my xmodmap. I reference specific hardware only in case the specific keyboard may make a difference. –  user18286 May 1 '12 at 1:05
    
@trVoldemort Are you using XIM or any similar input methods? They tend to break usage of Compose. –  ephemient May 2 '12 at 0:27
    
Compose key combinations also depend on the locale. I like to disambiguate it by sticking my favourites in my ~/.XCompose file. –  Alexios May 2 '12 at 5:26
    
@trVoldemort Notice that to use Compose < " differs from Compose , '. To get the first, the Shift key must be held down while hitting < " (which might be a little awkward). –  Joshua Taylor May 24 '13 at 15:10

I redefined my keyboard layout for good and I simply press alt-key + ; or ' to get: “ ”. Works in every desktop env.

There are many choices how to do it -- for example, you can use character map app (present in Gnome and KDE for sure) to get any character you want.

share|improve this answer
    
How exactly to map the key using character map app? I can't find this command in the app. –  trVoldemort Mar 24 '11 at 10:28

For anyone that runs across this: the Compose key for curly quotes didn't work for me until recently. I'd tried it in 2-3 major distros with GNOME 2 and changing the assigned key didn't help, but when I tried with KDE 4 in SimplyMepis and set it to use CapsLock it started working just fine. So trying it again or switching environments, distros, or keys might be worthwhile.

share|improve this answer
    
I prefer to assign Control to Caps Lock. Compose has always worked for me, mapped to the right Ctrl or Menu keys, which closely approximates its natural location on keyboards that have it. Which key I use depends on ergonomics, because I use Compose very frequently. –  Alexios May 2 '12 at 5:16

Some ‘smart’ [1] quotes without using Compose (and without remembering Unicode codepoints):

AltGr + 9 = ‘

AltGr + 0 = ’

AltGr + [ = «

AltGr + ] = »

AltGr + Shift + [ = “

AltGr + Shift + ] = ”

These work on any desktop, provided you have ISO_Level3_Shift assigned to your AltGr key and are using a keyboard mapping like the US International Keyboard with AltGr.

For Compose combinations, check Gilles' answer (or the XCompose file for your locale). They, in turn, are dependent on your locale and/or the presence/settings of your ~/.XCompose file.

[1] ‘Typographical’ is probably more appropriate. ‘Smart’ refers to the ability of a word processor to automatically use the correct character in a quote pair when you type the ASCII quotes ' or ".

share|improve this answer
    
Exactly what I needed, since I use the altgr keyboard. –  neverfox Apr 26 at 1:36

Linux Ubuntu users can type smart quotes with ...

AltGr+v / AltGr+b ( “ / ” )

... or ...

AltGr+Shift+v / AltGr+Shift+b ( ‘ / ’ )

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.