Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My problem is a little weird (maybe to me only).

Specification: Lenovo, Ideapad Z510. i7 intel core. 1920x1080. ISO: GNOME Debian 7.2.0 amd64. Bootable Device: Universal USB Installer.

---Process begins---

After making the bootable USB, I, in Windows 8, go to Settings -> Change PC Settings -> Update and Recovery -> ... -> Change UEFI Settings.

In the UEFI settings, I directly make the boot method Legacy Boot with Legacy First enabled. I restart. As I expect, of course, the installation screen shows up. I hit Install, without DHCP network configured because my computer can only access a wireless network at the time. When dealing with the partitioning, I see that I have already had an ESP, so I only did two things: 1. Have a 4-GiB free space formatted to be the swap area; 2. Have a 100-GiB free space formatted to be the ex4 primary partition. Then I go on installing. The progress is fluid, and after finishing, I reboot it.

Hooray! I see both Debian and Windows 8 on the GRUB menu (I am still in Legacy Boot method).

Here come the problems:

I hit "Debian..." on the GRUB menu, and I see this: "GNOME 3 failed to load... Unfortunately GNOME 3 failed to start properly and started in the fallback mode. This most likely means your system (graphics hardware or driver) is not capable of delivering the full GNOME 3 experience... Learn more about GNOME 3". I looked up the Internet and I found something about 3D acceleration, but it doesn't apply. How do I know it doesn't? I boot the GNOME Debian live CD 64-bit in VMWare Player with 3D Acceleration turned on, but the message still pops up. So here is the first problem I have.

I hit "Windows 8" on the GRUB menu, and I see this: "Windows failed to start. A recent hardware or software change might have caused the issue...". Probably it's because I am using Legacy Boot.

--- Process stops ---

The only way to dual-boot successfully is to make Debian boot under UEFI boot method with Secure Boot turned off and Fast Boot (in Power Options in Control Panel in Windows 8) turned off. In short, what I need is that Debian will boot normally without any form of errors (like the GNOME 3 message above) with UEFI Boot turned on and Secure Boot disabled.

I first try to do this by getting in Debian. After opening a terminal with my mouse (Ctrl-Alt-T doesn't work and I haven't checked the keyboard shortcut yet.), I typed in "grub-install" but it complains "command not found"; thus I am not able to proceed. I checked the /boot directory but I didn't see the "efi" directory. I don't know why when there should be one since GRUB 2 can be for UEFI boot. By the way, during the installation I see the grub-install run without any warning or error so I am super confused right now.

I try to use EasyBCD but Debian won't boot, but saying something similar to "Windows 8 failed to start...".

I try different software for creating a bootable device including YUMI, Unetbootin, SARDU, but the problem is still not solved.

I am almost desperate now; thus I post the problem here.

share|improve this question
    
Don't get me wrong, but why do you need Debian? Fedora Desktop comes with Gnome 3 by default, and the packages are almost always up-to-date. It has support for EFI/UEFI too. (fedoraproject.org) –  arielnmz Jun 2 at 19:05

1 Answer 1

Ok, first Linux does not yet have a great track record with EFI booting. When it works, it works quite well, but when it doesn't it's a PIA.

The most frequent issue I personally have seen is video card drivers not working in EFI mode when they work in BIOS mode. Other issues like NICs and sound cards have on occasion worked in one mode and not the other. That said. You seem to have two problems.

First, your need to boot windows in EFI mode and Linux in BIOS mode (based on your current setup). The eaisest way to do this is a project called refind I have used it in the past and it works quite well.

Basically it lets you boot EFI, then choose to pass control to the windows boot loader (EFI) or Grub (BIOS).

Finally your second problem "GNOME 3 failed to load..." may be nothing more then you need to install the video drivers for your card. Try the open source drivers first, there quite nice these days, but keep in mind that they do not cover as much as the close source ones. If the open sourced drivers don't work for you, revert to the proprietary drivers.

share|improve this answer
    
I guess my bet would be sticking in virtual machine for now :P –  Default-Cat Nov 3 '13 at 20:14
    
Your really really close, you just have this one little issue to get over. And it's most certainly something that can be gotten over. –  coteyr Nov 3 '13 at 20:43
    
Do you think I can play with GRUB 2? I think GRUB 2 boots under UEFI. –  Default-Cat Nov 3 '13 at 22:32
    
Grub2 EFI mode will work, it's just a question of "Does the video card work in Linux, via EFI?" –  coteyr Nov 4 '13 at 0:57
    
Does the Boot Manager affect the hardware compatibility of the desktop environment? –  Default-Cat Nov 4 '13 at 2:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.