Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have several Linux VMs on VMware + SAN.

What happened

A problem occured on the SAN (failed path) so that for some time, there were I/O errors on the Linux VMs drives. When the path failover had been done, it was too late: every Linux machine considered most of its drives as not "trustworthy" anymore, setting them as read-only devices. The root filesystem's drives were also impacted.

What I tried

  • mount -o rw,remount / without success,
  • echo running > /sys/block/sda/device/state without success,
  • dug into /sys to find a solution without success.

What I may have not tried

  • blockdev --setrw /dev/sda

Finally...

I had to reboot all my Linux VMs. The Windows VMs were fine...

Some more info from VMware...

The problem is described here. VMware suggests to increase the Linux scsi timeout to prevent this problem to happen.

The question!

However, when the problem does eventually happen, is there a way to get the drives back to read-write mode? (once the SAN is back to normal)

share|improve this question
2  
I have been able to get a disk back to read-write with mount -o remount /mountpoint on a real system. Perhaps that would work inside a VM too. –  Michael Suelmann Nov 2 '13 at 17:08
    
Thanks, but I already tried that, and it didn't work... I've edited my question accordingly. –  Totor Nov 2 '13 at 17:35

1 Answer 1

We have had this problem here a couple of times, usually due to the network going down for an extended period. The problem is not that the file system is read-only but that the disk device itself is marked read-only. No option here other than reboot. Increasing the scsi timeout will work for transient glitches such as a path failover. Won't work well for a 15-minute network outage.

share|improve this answer
    
Hmm, this is a Linux kernel limitation then. It deserves a bug report... –  Totor Mar 20 at 14:34
    
Did you try blockdev --setrw /dev/sda? I edited my question accordingly. –  Totor Apr 8 at 17:37
    
That's a new one to me. Hopefully I'll never see the problem again but I'll try this when it does happen. Thanks. –  Doug O'Neal Apr 10 at 12:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.