Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a server with an Asus P9D-I mainboard. It has two onboard Intel NICs:

# lspci -nn | grep Eth
01:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03)
02:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03)

The server is running Debian wheezy with the most recent backports kernel:

# cat /etc/debian_version
7.2

# uname -a
Linux hostname 3.10-0.bpo.3-amd64 #1 SMP Debian 3.10.11-1~bpo70+1 (2013-09-24) x86_64 GNU/Linux

# dpkg -l | grep -E '(linux-image-amd64|linux-image-3.10)'
ii  linux-image-3.10-0.bpo.3-amd64          3.10.11-1~bpo70+1                   amd64        Linux 3.10 for 64-bit PCs
ii  linux-image-amd64                       3.10+52~bpo70+1                     amd64        Linux for 64-bit PCs (meta-package)

The ethernet interfaces do show up in ifconfig -a:

# ifconfig -a
eth0      Link encap:Ethernet  HWaddr ac:22:0b:8b:30:a7  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:dfe00000-dfe80000 

eth1      Link encap:Ethernet  HWaddr ac:22:0b:8b:30:a8  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:dfd00000-dfd80000 
[...]

But for some reason, I can't actually use them for anything:

# ifconfig eth0 up
SIOCSIFFLAGS: No such device
# ifconfig eth1 up
SIOCSIFFLAGS: No such device
# ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available
# ethtool eth1
Settings for eth1:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available

dmesg doesn't seem to have any interesting output from the responsible igb driver:

# dmesg | grep igb
[    0.555167] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.0.3-k
[    0.555168] igb: Copyright (c) 2007-2013 Intel Corporation.
[    0.555669] igb 0000:01:00.0: irq 44 for MSI/MSI-X
[    0.555674] igb 0000:01:00.0: irq 45 for MSI/MSI-X
[    0.555679] igb 0000:01:00.0: irq 46 for MSI/MSI-X
[    0.555683] igb 0000:01:00.0: irq 47 for MSI/MSI-X
[    0.555689] igb 0000:01:00.0: irq 48 for MSI/MSI-X
[    0.599539] igb 0000:01:00.0: added PHC on eth0
[    0.599551] igb 0000:01:00.0: Intel(R) Gigabit Ethernet Network Connection
[    0.599553] igb 0000:01:00.0: eth0: (PCIe:2.5Gb/s:Width x1) ac:22:0b:8b:30:a7
[    0.599732] igb 0000:01:00.0: eth0: PBA No: 001300-000
[    0.599733] igb 0000:01:00.0: Using MSI-X interrupts. 4 rx queue(s), 4 tx queue(s)
[    0.600233] igb 0000:02:00.0: irq 50 for MSI/MSI-X
[    0.600237] igb 0000:02:00.0: irq 51 for MSI/MSI-X
[    0.600241] igb 0000:02:00.0: irq 52 for MSI/MSI-X
[    0.600244] igb 0000:02:00.0: irq 53 for MSI/MSI-X
[    0.600247] igb 0000:02:00.0: irq 54 for MSI/MSI-X
[    0.641792] igb 0000:02:00.0: added PHC on eth1
[    0.641794] igb 0000:02:00.0: Intel(R) Gigabit Ethernet Network Connection
[    0.641796] igb 0000:02:00.0: eth1: (PCIe:2.5Gb/s:Width x1) ac:22:0b:8b:30:a8
[    0.641853] igb 0000:02:00.0: eth1: PBA No: 001300-000
[    0.641854] igb 0000:02:00.0: Using MSI-X interrupts. 4 rx queue(s), 4 tx queue(s)

Does anyone know what could be going wrong here and how I can get these NICs working? If it's at all possible to do that without manually compiling kernels or drivers, I would prefer that.

share|improve this question
    
The igb driver comes with a debug parameter, which you can set from 0 (no debug info) to 16 (all). You might try to set that to some low value, then report back. –  MariusMatutiae Nov 1 '13 at 16:21

2 Answers 2

up vote 2 down vote accepted

I've found the cause - we had the acpi-support package installed which enables lots of unwanted power saving features due to a bug. Apparently the igb driver doesn't like those power save settings at all.

I've described the details in a bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728692

If anyone else encounters the problem: remove acpi-support and install acpi-support-base. The power button will still work, but all the remaining power saving magic of acpi-support that you don't want on a server is gone.

share|improve this answer
1  
+1 for filing a Debian bug report. :-) –  Faheem Mitha Nov 5 '13 at 18:16

Martin's solutions works fine - just make sure you install the back port kernel as the stable kernel does not support the Intel I210 NICs:

apt-get -t wheezy-backports install linux-image-amd64

this might take some time though.
Backporting details under back ports.debian.org

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.