Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Strange things have been going on with arch recently after I installed libreoffice.

The first sign was that there were no longer any icons on my desktop. I thought this was strange so I rebooted, same thing. I tried opening chromium to google an answer but it would not open from the menu, I decided to then try running it from the terminal, and I got my answer...something like below:

Libicuuc.so:51: could not open file: file is not in dir blah blah

So, I looked around and it seemed that upgrading my whole system would solve the issue(pacman -Syu) and updated quite a bit of stuff, 231 packages. After I was finished updating I rebooted the computer, and now I get this error on boot:

Failed to execute init.
Kernel panic - not syncing: no init found

And then a couple lines of text, then a call trace. It stops there and can't do anything else. I looked around a bit before posting here and couldn't find anything that worked for me.

share|improve this question

closed as unclear what you're asking by strugee, jasonwryan, Anthon, slm, Chris Down Feb 25 at 12:04

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Chroot in and look at pacman's log to see what you updated. Deal with any *.pacnew files that were created. –  jasonwryan Oct 31 '13 at 6:42

1 Answer 1

This warning typically indicates that there is a problem with your RAM disk. Given you cannot reboot, I would suggest you download and boot a recent Arch installer, mount your partitions (I think at a minimum you need /boot and /etc), and arch-chroot into your non-working system. Once there, you should be able to recreate your RAM disk

# mkinitcpio -p linux

You may need to configure your options by editing /etc/mkinitcpio.conf before creating the RAM disk.

share|improve this answer
    
This did not work. I chrooted into the system and still getting the same output as before. –  MineSQL Nov 1 '13 at 4:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.