Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Note: This question is specifically on a clean install of OpenSuse 11.3 with gnome as the display/desktop manager

I can't get custom keyboard shortcuts to work, default shortcuts are working properly, but the ones I changed I can only get one of them to work, I'm using the "windows key" to match functionality of Windows 7 for a few keys like maximize window (winkey+up), minimize window (winkey+down), etc; none of them work; for the record I did the exact same thing in Ubuntu and it worked without any problems.

additional info: I also noticed that gnome-do by default uses a key that I had assigned (winkey+space) and it "wins" (runs gnome-do) over the custom global key I had assigned (show main menu), actually, I can change the key in gnome-do to another that I have in the keyboard shortcuts, and the gnome-do works; this just makes me wonder if there are other applications that are disabling the usage of the "winkey"

update: I also tried using gconf-editor apps/metacity, adding the keys there, still no luck, I tried Windows, Super, Mod4 for the WinKey name, none worked

In some apps it seems the WinKey is completely ignored, i.e. it performs the action associated to the key without the WinKey, though, like I said before, there's one or two custom WinKey+SomeKey that ARE working (changed them to something else, stopped working, changed it back, worked again)

Found this article from 2006 that sounds very much like the problem I'm having, though I followed the steps to fix it but didn't work for me

There seems to be a bug in Gnome / Metacity / X somewhere that means you can't use SUPER_L or SUPER_R (the left and right windows keys on a keyboard) with gnome system commands such as "Lock Screen".

another thread of the same issue I'm having

I've been reading linux forums, it seems this might a be a bug on recent OpenSuse releases:

Many actions do not work with shortcuts in 11.3

Changing the Keyboard shortcuts in System->personal->Keyboard Shortcuts does not seem to be working.

and several others

share|improve this question
    
@BlackTigerX questions like this are most likely very Destkop Environment/Window Manager specific, so adding tag Gnome. –  xenoterracide Aug 21 '10 at 23:48
    
yup, using gnome, thanks –  BlackTigerX Aug 21 '10 at 23:52
    
@BlackTigerX just out of curiousity... try running xev in a terminal then press the windows key. you should see SUPER_ in the output. Just making sure your key is actually working. –  xenoterracide Aug 21 '10 at 23:59
    
I get this "KeyPress event, serial 35, synthetic NO, window 0x4c00001, root 0xac, subw 0x0, time 5827841, (162,-13), root:(166,18), state 0x10, keycode 133 (keysym 0xffeb, Super_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False" –  BlackTigerX Aug 22 '10 at 0:08
    
Now this is interesting, if I assign WinKey+Space (one I'm trying to get to work) to the Home folder, it works!, opens the home folder, but the same key, assigned to "show main menu" does not work –  BlackTigerX Aug 22 '10 at 0:16

2 Answers 2

up vote 1 down vote accepted

Just found an answer, or at least a temporary fix to my problem; you can consider me a Linux n00b, so I'm not familiarized yet with the terms and subsystems available or how to tell what I'm actually running.

simple answer: Disable desktop effects

Long answer: I didn't even know compiz was my window manager!, I thought it was "gnome", somewhere in the configuration I saw "gnome-wm" listed as the "window manager", but I just found out that this is just a script to load the actual window manager

There's also an environment variable WINDOWMANAGER=/usr/bin/gnome

so I guess this raises more questions for me, how do I know which display/desktop manager, window manager, is actually active? well I actually know the display manager is gnome, because that was part of the installation

anyway, for anyone else having the same problem, open up the control center, go to "look and feel", select "Desktop effects" and uncheck the box "enable desktop effects"

a quicker way to get to the same dialog is to run the command simple-ccsm (from the run application dialog, gnome-do, or the terminal).

now, that (I think) I know that I have compiz as my window manager, I also tried going into the gconf-editor/apps/compiz/general/allscreens/options and set my shortcuts there, but that didn't work (did try logging out and back in again)

share|improve this answer
    
Its been awhile since I've run compiz. If I remember right it over rides the gnome settings which can be really annoying, I think. –  decriptor Aug 23 '10 at 19:45

You do not have to disable Compiz completely. I had the same issue, but it affected specifically the "Run Application Dialog" and "Open Main Menu". The problem is that Compiz Fusion takes control over some keyboard shotcuts to keep compatibility. This can be configured through the Compiz plugin "Gnome Compatibility" and other areas of the Compiz Panel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.