Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running a JNativeHook capture program on Ubuntu. When I run the session on default X session things are working fine. However when I run the same program from vnc session, it fails with "Xlib: extension "RECORD" missing on display".

I checked that this extension is loaded in X which is started by display manager/init. However I am not sure if indeed is initialized during vncserver startup. I could not see anything related in the vnc log.

I tried create custom xorg.conf with Module section, which explicitly loads RECORD extension as suggested by many posts but did not help.

My environment: Xorg-server: 2.1.12.4-6 tightvncserver: 1.3.9

The same thing works fine on my CentOS 6.4 setup.

share|improve this question

migrated from serverfault.com Oct 30 '13 at 13:31

This question came from our site for professional system and network administrators.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.