Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Dell Poweredge running Ubuntu 13.04 in my office to serve up an interal web-app address system. It has been at least a 2 months possibly 3 since my last login. Everything is running great, but I can not login. I know I have the correct credentials because they are saved in putty.

Error simply says: Access Denied

What could possibly cause this to happen? Can it be fixed without pulling it off the shelf and hooking up monitors and keyboards etc (as a side-note it weighs something like 50+ pounds so I am not looking forward to that at all)?

guest@buildsys2:~$ ssh -v me@192.168.1.10
OpenSSH_5.9p1 Debian-5ubuntu1.1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.10 [192.168.1.10] port 22.
debug1: Connection established.
debug1: SELinux support disabled
debug1: identity file /tmp/guest-YBscPe/.ssh/id_rsa type -1
debug1: identity file /tmp/guest-YBscPe/.ssh/id_rsa-cert type -1
debug1: identity file /tmp/guest-YBscPe/.ssh/id_dsa type -1
debug1: identity file /tmp/guest-YBscPe/.ssh/id_dsa-cert type -1
debug1: identity file /tmp/guest-YBscPe/.ssh/id_ecdsa type -1
debug1: identity file /tmp/guest-YBscPe/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 > 
Debian-5ubuntu1.1
debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA [removed]
The authenticity of host '192.168.1.10 (192.168.1.10)' can't be established.
ECDSA key fingerprint is [removed].
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.10' (ECDSA) to the list of known hosts.
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /tmp/guest-YBscPe/.ssh/id_rsa
debug1: Trying private key: /tmp/guest-YBscPe/.ssh/id_dsa
debug1: Trying private key: /tmp/guest-YBscPe/.ssh/id_ecdsa
debug1: Next authentication method: password
me@192.168.1.10's password: 
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
me@192.168.1.10's password: 
share|improve this question

closed as off-topic by Braiam, polym, slm Aug 5 at 13:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, polym, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What kind of credentials? Password? Those can expire. –  kurtm Oct 29 '13 at 20:32
4  
You say you saved the credentials in putty, but that doesn't mean the password wasn't changed on the server's end. You say it's been 3 months since you last logged in, can you say you are certain it didn't change on the other side? –  kurtm Oct 29 '13 at 20:56
7  
We can see above that it's prompting for a password (from Linux's ssh anyways). If you're positive those credentials should work then you're going to need to get console on the machine and check /var/log/secure for a descriptive reason why it's not. It's possible something else is configured. PuTTY saying "Access Denied" could just be it trying to authenticate to the Linux server with the Kerberos ticket from your Windows login (if on AD for instance) so that might not be relevant to your issue. –  Joel Davis Oct 30 '13 at 1:26
1  
Looking at the logs it seems that the password might have been changed but the odder thing is that when using passwd I get an "Authentication token manipulation error" "password unchanged" ***EDIT that was due to not being in read/write mode. I've updated my password but would still like to figure out what happened. –  MFI-Spencer Oct 30 '13 at 14:52
1  
Thank you guys it seems I have a larger problem. Chkrootkit has come up with some interesting results so I am going to start a thread on ubuntu forums. –  MFI-Spencer Oct 30 '13 at 15:26

2 Answers 2

Please make sure that AllowUser directive is not set in /etc/ssh/ssd_config

share|improve this answer
    
Or if the directive is set, the user trying to login is allowed. –  pconcepcion Jan 5 at 12:31

Check permissions on the destination machine on the $HOME directory (should not be group or wordl writable), $HOME/.ssh (should be 700), $HOME/.ssh/authorized_keys (should be 644).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.